Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 19:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Работа с ссылками COM  (Прочитано 844 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nem0i

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-09-08
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день!
Сломал голову.. с 7-кой не работал, но задача стоит!
Нужно через Com соединение вытащить из скульной 7-ки из справочника ОС значение реквизита Код и из реквизита МОЛ(Ссылка на справочник Сотрудники)Наименование сотрудника. Подключился к базе, Код достал, а вот Наименование МОЛ не получается никак.
Вот код:

ОС77 = База.CreateObject("Справочник.ОсновныеСредства");
   ОС77.ВыбратьЭлементы(0);
   Для Каждого СТР Из ТабличнаяЧасть1 Цикл
      Если ОС77.НайтиПоКоду(СТР.Номер82) = 1 Тогда
                        СТР.ИНВ = ОС77.Код;         
                        СОТР = База.CreateObject("Справочник.Сотрудники");
         СОТР.НайтиПоНаименованию(ОС77.МОЛ.Наименование);
         СТР.МОЛ = СОТР.Наименование;
         //СТР.МОЛ = ОС77.МОЛ.Наименование;         
          КонецЕсли;
   КонецЦикла;
Помогите пжлст разобраться!


Оффлайн nem0i

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-09-08
  • Сайт: 
  • Профессия: Ученик 1С
Номер получаю просто для проверки наличия Основного средства в базе.
В отладчике: Поле объекта не обнаружено (Наименование) СОТР.НайтиПоНаименованию(ОС77.МОЛ.Наименование)

Оффлайн G_Re

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2011-12-17
  • Сайт: 
  • Профессия: Ученик 1С
А если просто

СОТР.НайтиЭлемент(ОС77.МОЛ)

Ведь Сотр и ОС77 одновременно ТАМ, поэтому должно сработать???

И ещё, задача стОит или стоИт? :))

Оффлайн Dmitrij19631025

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-25
  • Сайт: 
  • Профессия: Программист 7.7
Насколько я понимаю Вы код пишите в 1с8.х и из модуля 1с8.х обращаетесь к 1с7.7. Если реквизитом справочника ОС является справочник МОЛ то
ОС77 = База.CreateObject("Справочник.ОсновныеСредства");
ОС77.ВыбратьЭлементы(0);
 Для Каждого СТР Из ТабличнаяЧасть1 Цикл
  Если ОС77.НайтиПоКоду(СТР.Номер82) = 1 Тогда
ОС77.ТекущийЭлемент();
СТР.ИНВ = ОС77.Код;         
СТР.МОЛ = ОС77.МОЛ.Наименование;//где МОЛ- имя реквизита справочника ОС
  КонецЕсли;
 КонецЦикла;


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
48 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 214
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal