Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 06:26
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание заказаов на производство на основании заказа на производство.  (Прочитано 7888 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Елена1986

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -4
  • Регистрация: 2015-09-02
  • Сайт: 
  • Профессия: Ученик 1С
УПП 8.3 Здравствуйте!Не подскажете как дописать код, что бы при нажатии "сформировать" заказ на производство, формировалось сразу несколько(в моём случае два) заказа на производство?
Код
Процедура СформироватьВыполнитьНажатие(Сформировать)
   СоздатьДокументЗаказНаПроизводство(Основание);
   
КонецПроцедуры

Процедура СоздатьДокументЗаказНаПроизводство(Основание)
   НовыйДокумент = Документы.ЗаказНаПроизводство.СоздатьДокумент();
   НовыйДокумент.Дата = Основание.Дата;
   НовыйДокумент.Заполнить(Основание);
   НовыйДокумент.ЗаполнитьМатериалыПоСпецификации(НовыйДокумент.Материалы, "Материалы");
   НовыйДокумент.ДатаЗапуска = Основание.ДатаЗапуска;
   НовыйДокумент.ДатаИсполнения = Основание.ДатаИсполнения ;
   НовыйДокумент.Записать();
   
   Запрос = Новый Запрос;
   Запрос.Текст ="ВЫБРАТЬ
   |   ЗаказНаПроизводствоМатериалы.Номенклатура,
   |   ЗаказНаПроизводствоМатериалы.ВидВоспроизводства
   |ИЗ
   |   Документ.ЗаказНаПроизводство.Материалы КАК ЗаказНаПроизводствоМатериалы
   |ГДЕ
   | ЗаказНаПроизводствоМатериалы.Ссылка = &ВидВоспроизводства";
   Запрос.УстановитьПараметр("ВидВоспроизводства",Основание.Ссылка);
   ТаблЗнач = Запрос.Выполнить().Выгрузить();
   ТаблЗнач.ВыбратьСтроку();
   Для каждого Строка ИЗ ТаблЗнач Цикл
      Результат = Строка.ВидВоспроизводства;
      Если Результат = Перечисления.ВидыВоспроизводстваНоменклатуры.Производство Тогда
         Основание = НовыйДокумент.Ссылка;         
      КонецЕсли;
      Если Результат = Перечисления.ВидыВоспроизводстваНоменклатуры.Закупка Тогда
         Прервать;
      КонецЕсли;
   КонецЦикла;   
   
КонецПроцедуры


Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Немного неясно: что должно попадать в первый заказ на производство и что во второй?
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн Елена1986

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -4
  • Регистрация: 2015-09-02
  • Сайт: 
  • Профессия: Ученик 1С
Немного неясно: что должно попадать в первый заказ на производство и что во второй?
[/quot
Существует заказ на производство, на основании него создаются заказы на производство, из первого заказа выбираются материалы с видом воспроизводства (производство)  и вносятся во второй, из второго выбираются материалы с видом воспроизводства (производство) и помещаются в третий.
Как то так, здесь надо применят рекурсию.

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Не проще ли сделать так?
НовыйДокумент = Документы.ЗаказНаПроизводство.СоздатьДокумент();
// код по заполнению документа
НовыйДокумент.Записать();

НовыйДокумент1 = НовыйДокумент.Скопировать();
НовыйДокумент1.Записать();
// и так далее
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн Елена1986

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -4
  • Регистрация: 2015-09-02
  • Сайт: 
  • Профессия: Ученик 1С
Не проще ли сделать так?
НовыйДокумент = Документы.ЗаказНаПроизводство.СоздатьДокумент();
// код по заполнению документа
НовыйДокумент.Записать();

НовыйДокумент1 = НовыйДокумент.Скопировать();
НовыйДокумент1.Записать();
// и так далее

Не получается, создается один документ и выскакивает ошибка:
{Форма.Форма.Форма(15)}: Ошибка при вызове метода контекста (Записать)
НовыйДокумент1.Записать();
по причине:
Значение поля "Дата" не может быть пустой датой
 

Добавлено: 08 Сен 2015, 11:09

Не проще ли сделать так?
НовыйДокумент = Документы.ЗаказНаПроизводство.СоздатьДокумент();
// код по заполнению документа
НовыйДокумент.Записать();

НовыйДокумент1 = НовыйДокумент.Скопировать();
НовыйДокумент1.Записать();
// и так далее
Извините не правильно записала, ошибки нет.
Создаёт два заказа, но они одинаковые, на основании первого заказа.

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
Немного неясно: что должно попадать в первый заказ на производство и что во второй?
[/quot
Существует заказ на производство, на основании него создаются заказы на производство, из первого заказа выбираются материалы с видом воспроизводства (производство)  и вносятся во второй, из второго выбираются материалы с видом воспроизводства (производство) и помещаются в третий.
Как то так, здесь надо применят рекурсию.
Как-то здесь надо написать чего хочу или чего нужно, а потом делать.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн Елена1986

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -4
  • Регистрация: 2015-09-02
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
Немного неясно: что должно попадать в первый заказ на производство и что во второй?
[/quot
Существует заказ на производство, на основании него создаются заказы на производство, из первого заказа выбираются материалы с видом воспроизводства (производство)  и вносятся во второй, из второго выбираются материалы с видом воспроизводства (производство) и помещаются в третий.
Как то так, здесь надо применят рекурсию.
Как-то здесь надо написать чего хочу или чего нужно, а потом делать.
Так Я же написала, что нужно создать заказы на производство на основании заказа на производство. Из существующего заказа на производство выбираются материалы с видом воспроизводства(производство) и помещаются в первый заказ на производство. Из первого заказа на производства выбираются материалы с видом воспроизводства(производство) и помещаются во второй заказ на производство.

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
В цикл заключите создание НовыйДокумент1 и в цикле пропишите количество создаваемых документов.
Понятно?
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн Елена1986

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -4
  • Регистрация: 2015-09-02
  • Сайт: 
  • Профессия: Ученик 1С
В цикл заключите создание НовыйДокумент1 и в цикле пропишите количество создаваемых документов.
Понятно?
Для каждого Строка ИЗ НовыйДокумент1 Цикл
   
   Если Результат = Перечисления.ВидВоспроизводства.Производство Тогда
      Основание = НовыйДокумент.Ссылка;         
   КонецЕсли;
   Если Результат = Перечисления.ВидыВоспроизводстваНоменклатуры.Закупка Тогда
      Прервать;
   КонецЕсли;
КонецЦикла;   
Так?

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Для Сч = 1 По 10 Цикл
    НовыйДокумент1 = НовыйДокумент.Скопировать();
    НовыйДокумент1.Записать();
КонецЦикла;

Где 10 - количество скопированных документов
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс


Теги:
 

Автоматическое создание " Заполнение" документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4457
Последний ответ 06 Мар 2014, 14:48
от mashencev_anton
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3888
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Создание плана закупок с использованием плана продаж

Автор NataVlРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1193
Последний ответ 26 Сен 2016, 16:25
от NataVl
Создание расчета "курсовой разницы" 1С 8.3 УТ

Автор HabiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1624
Последний ответ 18 Фев 2017, 17:47
от Геннадий ОбьГЭС
Создание конфигурации "Электронный ценник"

Автор Серега МошенскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 337
Последний ответ 14 Май 2017, 20:40
от Artjomrgv

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 221
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal