Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 22:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание заказаов на производство.  (Прочитано 462 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Елена1986

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -4
  • Регистрация: 2015-09-02
  • Сайт: 
  • Профессия: Ученик 1С
УПП 8.3 Здравствуйте!Не подскажете как дописать код, что бы при нажатии сформировать заказ на производство, формировалось сразу несколько(в моём случае два) заказа на производство.
Код
Процедура СформироватьВыполнитьНажатие(Сформировать)
   СоздатьДокументЗаказНаПроизводство(Основание);
   
КонецПроцедуры

Процедура СоздатьДокументЗаказНаПроизводство(Основание)
   НовыйДокумент = Документы.ЗаказНаПроизводство.СоздатьДокумент();
   НовыйДокумент.Дата = Основание.Дата;
   НовыйДокумент.Заполнить(Основание);
   НовыйДокумент.ЗаполнитьМатериалыПоСпецификации(НовыйДокумент.Материалы, "Материалы");
   НовыйДокумент.ДатаЗапуска = Основание.ДатаЗапуска;
   НовыйДокумент.ДатаИсполнения = Основание.ДатаИсполнения ;
   НовыйДокумент.Записать();
   
   Запрос = Новый Запрос;
   Запрос.Текст ="ВЫБРАТЬ
   |   ЗаказНаПроизводствоМатериалы.Номенклатура,
   |   ЗаказНаПроизводствоМатериалы.ВидВоспроизводства
   |ИЗ
   |   Документ.ЗаказНаПроизводство.Материалы КАК ЗаказНаПроизводствоМатериалы
   |ГДЕ
   | ЗаказНаПроизводствоМатериалы.Ссылка = &ВидВоспроизводства";
   Запрос.УстановитьПараметр("ВидВоспроизводства",Основание.Ссылка);
   ТаблЗнач = Запрос.Выполнить().Выгрузить();
   ТаблЗнач.ВыбратьСтроку();
   Для каждого Строка ИЗ ТаблЗнач Цикл
      Результат = Строка.ВидВоспроизводства;
      Если Результат = Перечисления.ВидыВоспроизводстваНоменклатуры.Производство Тогда
         Основание = НовыйДокумент.Ссылка;         
      КонецЕсли;
      Если Результат = Перечисления.ВидыВоспроизводстваНоменклатуры.Закупка Тогда
         Прервать;
      КонецЕсли;
   КонецЦикла;   
   
КонецПроцедуры



Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Может так сработает..
Процедура СформироватьВыполнитьНажатие(Сформировать)
   СоздатьДокументЗаказНаПроизводство(Основание);
   СоздатьДокументЗаказНаПроизводство(Основание);
КонецПроцедуры

Или

Процедура СформироватьВыполнитьНажатие(Сформировать)
   СоздатьДокументЗаказНаПроизводство(Основание);
   СоздатьДокументЗаказНаПроизводство2(Основание);
КонецПроцедуры

И повторяете тоже самое в СоздатьДокументЗаказНаПроизводство2(Основание);
Не уверен не пробовал..B)

Оффлайн Елена1986

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -4
  • Регистрация: 2015-09-02
  • Сайт: 
  • Профессия: Ученик 1С
Может так сработает..
Процедура СформироватьВыполнитьНажатие(Сформировать)
   СоздатьДокументЗаказНаПроизводство(Основание);
   СоздатьДокументЗаказНаПроизводство(Основание);
КонецПроцедуры

Или

Процедура СформироватьВыполнитьНажатие(Сформировать)
   СоздатьДокументЗаказНаПроизводство(Основание);
   СоздатьДокументЗаказНаПроизводство2(Основание);
КонецПроцедуры

И повторяете тоже самое в СоздатьДокументЗаказНаПроизводство2(Основание);
Не уверен не пробовал..B)


Здраствуйте, да создаёт два заказа, но они одинаковые. А мне надо,что бы формировалось сразу несколько(в моём случае два) заказа на производство, но разные. 


Теги:
 

Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4472
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Автоматическое создание " Заполнение" документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4442
Последний ответ 06 Мар 2014, 14:48
от mashencev_anton
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3873
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Создание плана закупок с использованием плана продаж

Автор NataVlРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1183
Последний ответ 26 Сен 2016, 16:25
от NataVl
Создание расчета "курсовой разницы" 1С 8.3 УТ

Автор HabiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1609
Последний ответ 18 Фев 2017, 17:47
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 316
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal