Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 14:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Типы реквизитов Получение и Присваивание  (Прочитано 354 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн darkmessiahan

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 1
  • КПД: 33%
  • 1с.теут.рф
  • Регистрация: 2015-09-05
  • Сайт: 1с.теут.рф
  • Профессия: Программист 1С
Весьма замученная тема, однако не смогу найти ответ на свою задачу.
Нужно получить реквизиты объекта. Объект может быть любой справочник, заранее не известно какой именно. И создать на форме точно такие же реквизиты (то есть перенести реквизиты справочника в форму). Как понятно из темы, проблемы у меня с типами.
Реквиз.Тип
возвращает только обычные типы (Строка, число, булево) а вот в сложных данных код возвращает только имя(Вместо СправочникСсылка.Номенклатура возвращается только номенклатура). Через XMLТип(ЭлементТип)и типХМЛ.ИмяТипа возвращается иной вариант названия Объектов. Было у меня предположение исправить это через СтрЗаменить(); Но оно возвращает Строку, а нужен Тип, что бы засунуть это в
ТипыРеквизита.Добавить(Тип(ПЕРЕМЕННАЯ));
&НаСервере
Функция ПолучениеМетаданных()
//Объект.Справочник - ссылка на спраовчник
Для каждого Реквиз Из Объект.Справочник.Метаданные().Реквизиты Цикл
   ВозможныеТипы = Реквиз.Тип.Типы();
Сообщить(Реквиз.Тип);
            Для каждого ЭлементТип Из ВозможныеТипы Цикл
//тут скорее всего нужно вставить какой то код

КонецЦикла;
ТипыРеквизита = Новый Массив;
ТипыРеквизита.Добавить(Тип(ПЕРЕМЕННАЯ));
КонецЦикла;
КонецФункции

1с.теут.рф


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
А просто отрыть форму элемента/документа?


Теги:
 

В строке "1" табличной части "Состав набора": Не заполнено значение реквизитов Цена

Автор rusalkaРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2425
Последний ответ 11 Апр 2014, 16:52
от rusalka
Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9154
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Заполнение строки документа значениями реквизитов табличной части документа

Автор green_ezhikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 3635
Последний ответ 01 Апр 2015, 22:19
от vitasw
опять вопрос про "много" реквизитов в справочнике (или документе)

Автор andron81_81Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 20
Просмотров: 445
Последний ответ 08 Дек 2017, 07:54
от andron81_81
Получение налогового вычета компании, которая оформила договор купли-продажи товара и внесла в качестве аванса заемные средства

Автор topicsРаздел Статьи

Ответов: 1
Просмотров: 1032
Последний ответ 12 Окт 2014, 23:14
от lux4home

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal