Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 15:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Операции сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов (Булево, Число, Строка, Дата)  (Прочитано 4966 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ktu78

  • ***
  • Сообщений: 153
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-21
  • Сайт: 
  • Профессия: Программист 1С
Добрый день, коллеги.
При выполнении выборки запроса для проверки наличия ТМЦ на складе и в партии смотри код:

//проверка наличия ТМЦ  на складе и в партии
   Для Каждого ТекСтрока Из СписокПеремещенийТМЦ Цикл
   Запрос = ПроверкаНаличияТМЦНаСкладеВПартии(Ссылка, СкладОтправитель, ТекСтрока.Партия);
   
   Выборка=Запрос.Выполнить().Выбрать();
      
   
       Пока Выборка.Следующий() Цикл
      Если Выборка.КоличествоСклад < Выборка.КоличествоДок Тогда
         Сообщение=Новый СообщениеПользователю;
         Сообщение.Текст="Не хватает товаров на складе в размере:"+Строка(Выборка.КоличествоДок-Выборка.КоличествоСклад)+" единиц";
         Сообщение.Сообщить();
         Отказ=Истина;
      КонецЕсли;
      КонецЦикла;
   КонецЦикла;

 ........

Функция ПроверкаНаличияТМЦНаСкладеВПартии(Документ, Склад, Партия)
//контроль наличия на складе отправителе
   Запрос=Новый Запрос;
   Запрос.Текст="ВЫБРАТЬ
                |   ТМЦОстатки.ТМЦ,
                |   ТМЦОстатки.Склад,
                |   ТМЦОстатки.Партия,
                |   ТМЦОстатки.КоличествоОстаток КАК КоличествоСклад,
                |   ПеремещениеТМЦСписокПеремещенийТМЦ.Количество КАК КоличествоДок
                |ИЗ
                |   Документ.ПеремещениеТМЦ.СписокПеремещенийТМЦ КАК ПеремещениеТМЦСписокПеремещенийТМЦ
                |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ТМЦ.Остатки(
                |            ,
                |            Склад = &Склад
                |               И Партия = &Партия) КАК ТМЦОстатки
                |      ПО ПеремещениеТМЦСписокПеремещенийТМЦ.ТМЦ = ТМЦОстатки.ТМЦ
                |ГДЕ
                |   ПеремещениеТМЦСписокПеремещенийТМЦ.Ссылка = &Ссылка"; 
            

            
   Запрос.УстановитьПараметр("Ссылка",Ссылка);
   Запрос.УстановитьПараметр("Склад",Склад);
   Запрос.УстановитьПараметр("Партия",Партия);
   
   Возврат Запрос;   
КонецФункции


При проведении документа Перемещение ТМЦ выдается ошибка:

Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{Документ.ПеремещениеТМЦ.МодульОбъекта(20)}: Операции сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов (Булево, Число, Строка, Дата)
Если Выборка.КоличествоСклад < Выборка.КоличествоДок Тогда

помогите пожалуйста, заранее благодарен


Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 187
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Даже не смешно, если честно.
Вы по каким то религиозным причинам не хотите пользоваться отладчиком?
Проверка выборки занимает меньше минуты.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6650
  • РЕПУТАЦИЯ: 787
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
ЕСТЬNULL(ПеремещениеТМЦСписокПеремещенийТМЦ.Количеств,0) КАК КоличествоДок


Теги:
 

Обнаружено дублирование ключевых значений в колонке ссылка [&quot;обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 689
Последний ответ 20 Мар 2018, 16:54
от alex0402
как в отчете "Главная книга" отображать для счетов столбцы не только "С кредита", но и "На дебет"

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1337
Последний ответ 13 Мар 2016, 00:55
от дфтын
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 1314
Последний ответ 15 Июн 2017, 07:53
от mvk843
Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5488
Последний ответ 24 Ноя 2015, 15:38
от welldone
Вид договора только "Прочие"

Автор GendelfРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 9449
Последний ответ 09 Сен 2013, 16:51
от 33lab

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
55 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 263
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal