Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 06:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание заказа на производство.  (Прочитано 3900 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Елена1986

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -4
  • Регистрация: 2015-09-02
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Помогите пожалуйста разобраться с вопросом. На основании заказа покупателя нужно создать заказы на производство


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Вы опять в своем репертуаре :kmtu: С такой постановкой вопроса вам никто ничего не расскажет. Обязательно нужно указывать конфигурацию и желательно релиз конфигурации, а так же степень изменений конфигурации.

Оффлайн Елена1986

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -4
  • Регистрация: 2015-09-02
  • Сайт: 
  • Профессия: Ученик 1С
Вы опять в своем репертуаре :kmtu: С такой постановкой вопроса вам никто ничего не расскажет. Обязательно нужно указывать конфигурацию и желательно релиз конфигурации, а так же степень изменений конфигурации.
Извините, Я только учусь!:nhsrm:
УПП 8.3

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Ок, плывем дальше.
Какого рада вас интересует ответ? Если вы программист (а эта ветка форума именно для программистов), то покажите что уже сделали. Если вопрос только с точки зрения "как пользоваться", то вам сюда:
http://forum-1c.ru/index.php?board=55.0

Оффлайн Елена1986

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -4
  • Регистрация: 2015-09-02
  • Сайт: 
  • Профессия: Ученик 1С
Ок, плывем дальше.
Какого рада вас интересует ответ? Если вы программист (а эта ветка форума именно для программистов), то покажите что уже сделали. Если вопрос только с точки зрения "как пользоваться", то вам сюда:
http://forum-1c.ru/index.php?board=55.0
Процедура СформироватьВыполнитьНажатие(Сформировать);
   Если Не ЗначениеЗаполнено(ЗаказНаПроизводство) Тогда 
      Предупреждение("Документ Не Выбран");
      Возврат;
   КонецЕсли;
   Если ЗаказНаПроизводство.ПометкаУдаления Тогда
      Предупреждение ("Выберите Документ Не Помеченный На Удаление");
      Возврат;
   КонецЕсли;
   Если Не ЗаказНаПроизводство.Проведен Тогда
      Предупреждение ("Выберите  Проведённый Документ");
      Возврат;
   КонецЕсли;
   ТЗ=Новый ТаблицаЗначений;
   ТЗ.Колонки.Добавить("Спецификация");
   
   Стр=ТЗ.Добавить();
   Стр.Спецификация = "Нужная спецификация";
   
   Для Каждого Стр Из ТЗ Цикл
      
      Запрос = Новый Запрос;
      Запрос.Текст =
      "
      |ВЫБРАТЬ
      |    СпецификацииНоменклатурыИсходныеКомплектующие.Номенклатура
      |ПОМЕСТИТЬ ВТ
      |ИЗ
      |    РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних(&Дата, СпецификацияНоменклатуры = &Спецификация) КАК ОсновныеСпецификацииНоменклатурыСрезПоследних
      |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК СпецификацииНоменклатурыИсходныеКомплектующие
      |        ПО ОсновныеСпецификацииНоменклатурыСрезПоследних.СпецификацияНоменклатуры = СпецификацииНоменклатурыИсходныеКомплектующие.Ссылка;
      |
      |////////////////////////////////////////////////////////////////////////////////
      |ВЫБРАТЬ
      |    ВТ.Номенклатура,
      |    ОсновныеСпецификацииНоменклатурыСрезПоследних.СпецификацияНоменклатуры КАК Спецификация
      |ИЗ
      |    ВТ КАК ВТ
       |ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних КАК ОсновныеСпецификацииНоменклатурыСрезПоследних
       |ПО ОсновныеСпецификацииНоменклатурыСрезПоследних.Номенклатура = ВТ.Номенклатура"; 
      
      Запрос.УстановитьПараметр("Дата",ТекущаяДата());
      Запрос.УстановитьПараметр("Спецификация",Стр.Спецификация);
      
      Результат = Запрос.Выполнить().Выбрать();
   КонецЦикла;
   
   Пока Результат.Следующий() Цикл
      
      Стр1=ТЗ.Добавить();
      Стр1.Спецификация = Результат.Спецификация;
   КонецЦикла;
   
   ТЗ1=Новый ТаблицаЗначений();
   Ссылка =ЗаказНаПроизводство.ПолучитьОбъект();
   ТЗ1 = Ссылка.Материалы.Выгрузить();
   
   НовДок = Документы.ЗаказНаПроизводство.СоздатьДокумент();
   КолДок =1;
   НовДок.Дата = ТекущаяДата();
   НовДок.УстановитьВремя();
   НовДок.УстановитьНовыйНомер();
   НовДок.Организация = Ссылка.Организация;
   НовДок.Подразделение = Ссылка.Подразделение;
   НовДок.ОсновнойЗаказНаПроизводство = Ссылка.ОсновнойЗаказНаПроизводство;
   НовДок.ДатаЗапуска = Ссылка.ДатаЗапуска;
   НовДок.ДатаИсполнения = Ссылка.ДатаИсполнения;
   
   Для Каждого Т из ТЗ1 Цикл
      Если Т.ВидВоспроизводства = Перечисления.ВидыВоспроизводстваНоменклатуры.Производство Тогда
         
         НоваяСтрока=НовДок.Продукция.Добавить();
         НоваяСтрока.Номенклатура = Т.Номенклатура;
         НоваяСтрока.ХарактеристикаНоменклатуры = Т.ХарактеристикаНоменклатуры;   
         НоваяСтрока.Количество = Т.Количество;
         НоваяСтрока.Заказ = Т.Заказ;
         НоваяСтрока.Спецификация = НайтиСпецификацию(Т.Номенклатура);
         НоваяСтрока.Коэффициент = Т.Коэффициент;
         НоваяСтрока.ЕдиницаИзмерения = Т. ЕдиницаИзмерения;
         НовДок.Записать();
         
      КонецЕсли;
   КонецЦикла;   
КонецПроцедуры

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
И каков результат сего кода? Что именно не получается?

Оффлайн Елена1986

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -4
  • Регистрация: 2015-09-02
  • Сайт: 
  • Профессия: Ученик 1С
И каков результат сего кода? Что именно не получается?
Заказ создаёт, но спецификацию продукции не прописывает.
 

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Н-да.
1.Почему "производится" та номенклатура, которая указана в таблице "Материла" в заказе покупателя, а не из закладки "Продукция"?
2. В заказе покупатели какой стоит вид операции?
3. Как определить ту номенклатуру, которую нужно произвести?

Оффлайн Елена1986

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -4
  • Регистрация: 2015-09-02
  • Сайт: 
  • Профессия: Ученик 1С
Н-да.
1.Почему "производится" та номенклатура, которая указана в таблице "Материла" в заказе покупателя, а не из закладки "Продукция"?
2. В заказе покупатели какой стоит вид операции?
3. Как определить ту номенклатуру, которую нужно произвести?
Номенклатура та, у которой вид воспроизводства- производство.
В заказе покупателя стоит продажа.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Почему "производится" та номенклатура, которая указана в таблице "Материлы" в заказе покупателя, а не из таблицы "товары"? При виде операции = продажа, таблица "материалы" не видна.



Теги:
 

Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4510
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Автоматическое создание " Заполнение" документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4457
Последний ответ 06 Мар 2014, 14:48
от mashencev_anton
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3888
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Создание плана закупок с использованием плана продаж

Автор NataVlРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1193
Последний ответ 26 Сен 2016, 16:25
от NataVl
Создание расчета "курсовой разницы" 1С 8.3 УТ

Автор HabiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1624
Последний ответ 18 Фев 2017, 17:47
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 242
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal