Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 12:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка при проведении расходного документа  (Прочитано 469 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Olegyaro

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2014-11-25
  • Сайт: 
  • Профессия: Бухгалтер

<code>
Процедура ОбработкаПроведения(Отказ, РежимПроведения)
   
         
       Движения.ОстаткиТоваров.Записывать = Истина;
      Движения.ОстаткиПоСкладам.Записывать = Истина;
        Запрос = Новый Запрос;
      Запрос.Текст =
      "Выбрать
      |   Номенклатура,
      |   Сумма(Количество) Как Количество,
      |   Минимум(НомерСтроки) Как НомерСтроки
      |   ПОМЕСТИТЬ ДокТч
      |   Из
      |   Документ.Расходная.Товары
      |Где
      |   Ссылка = &Ссылка И НЕ Номенклатура.Услуга
      |Сгруппировать По Номенклатура
      |;
      |Выбрать
      |   ДокТч.НомерСтроки,
      |   ДокТч.Номенклатура,
      |   ДокТч.Количество,
      |   ЕстьNULL(Остатки.КоличествоОстаток,0) Как КоличествоОстаток,
      |   ЕстьNULL(Остатки.СтоимостьОстаток,0) Как СтоимостьОстаток,
      |   ЕстьNULL(ОстаткиСКЛ.КоличествоОстаток,0)Как ОстатокНаСкладе
      |ИЗ
      |   ДокТч Как ДокТч
      |   
      |   ЛЕВОЕ СОЕДИНЕНИЕ
      |   РегистрНакопления.ОстаткиТоваров.Остатки(&МоментВремени, Номенклатура В (Выбрать Номенклатура Из ДокТЧ КАК ДокТч)) КАК Остатки
      |   По ДокТч.Номенклатура = Остатки.Номенклатура
      |   
      |   ЛЕВОЕ СОЕДИНЕНИЕ
      |   РегистрНакопления.ОстаткиПоСкладам.Остатки(&МоментВремени, Склад = &Склад
      |   И Номенклатура В (Выбрать Номенклатура Из ДокТч КАК ДокТч)) КАК ОстаткиСКЛ
      |   По ДокТч.Номенклатура = ОстаткиСКЛ.Номенклатура";
      
       Запрос.УстановитьПараметр("МоментВремени", МоментВремени());
       Запрос.УстановитьПараметр("Ссылка", Ссылка);
       Запрос.УстановитьПараметр("Склад", Склад);
      
       Результат = Запрос.Выполнить();
      
       Выборка = Результат.Выбрать();
      
       Пока Выборка.Следующий() Цикл
         
          Если Выборка.Количество > Выборка.КоличествоОстаток Тогда
             Сообщение = Новый СообщениеПользователю;
             Сообщение.Текст = "Не хватает товара""" + Выборка.Номенклатура
                + """, из необходимых" +
               Выборка.Количество + "в наличии осталось только" +
               Выборка.КоличествоОствток;
            Сообщение.Поле = "Товары[" + (Выборка.НомерСтроки-1) + "].Количество";
            Сообщение.УстановитьДанные(ЭтотОбъект);
            Сообщение.Сообщить();
            
            Отказ = Истина;
            Движения.ОстаткиТоваров.Записывать = Ложь;
            Движения.ОстаткиПоСкладам.Записывать = Ложь;
         КонецЕсли;
         
         Если Отказ Тогда
            Продолжить;
         КонецЕсли;
         
      
      Движение = Движения.ОстаткиТоваров.ДобавитьРасход();
      Движение.Период = Дата;
      Движение.Номенклатура = Выборка.Номенклатура;
      Движение.Количество = Выборка.Количество;
      Движение.Стоимость = Выборка.Количество/Выборка.КоличествоОстаток * Выборка.СтоимостьОстаток;
      
   
      
      Движение = Движения.ОстаткиТоваров.ДобавитьРасход();
      Движение.Период = Дата;
      Движение.Номенклатура = Выборка.Номенклатура;
      Движение.Количество = Выборка.Количество;
      Движение.Склад = Склад;

   КонецЦикла;

КонецПроцедуры
</code>
При попытке проведения документа выдает ошибку
<code>Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{Документ.Расходная.МодульОбъекта(81)}: Поле объекта не обнаружено (Склад)
      Движение.Склад = Склад;</code>
Пожалуйста ткните носом новичка, а то голову сломалui;;t;


Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Проверьте есть ли в регистре накопления ОстаткиТоваров измерение склад.
Возможно оно зовется по другому.

А вообще не понятно, почему у вас дважды формируются движения по одному регистру:

Движение = Движения.ОстаткиТоваров.ДобавитьРасход();
Движение.Период = Дата;
Движение.Номенклатура = Выборка.Номенклатура;
Движение.Количество = Выборка.Количество;
Движение.Стоимость = Выборка.Количество/Выборка.КоличествоОстаток * Выборка.СтоимостьОстаток;

Движение = Движения.ОстаткиТоваров.ДобавитьРасход();
Движение.Период = Дата;
Движение.Номенклатура = Выборка.Номенклатура;
Движение.Количество = Выборка.Количество;
Движение.Склад = Склад;


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4480
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15943
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4201
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 638
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7749
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 282
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal