Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2018, 05:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Доступ к реквизитам номенклатуры в форме документа  (Прочитано 767 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Disbat_77

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • 1С:Предприятие 8.3 / Розница 2.1
  • Регистрация: 2015-08-31
  • Сайт: 
  • Профессия: Программист 1С
Место действия: ПоступлениеТоваров / ФормаДокумента
В Номенклатуре добавлен числовой реквизит ВУпаковке, в форме документа колонка Упак, обработчик события для колонки выглядит так:

Процедура УпакПриИзменении(Элемент)

ТекущаяСтрока = Элементы.Товары.ТекущиеДанные;
ТекущаяНоменклатура = ТекущаяСтрока.Номенклатура;
ТекВУп = ТекущаяНоменклатура.ВУпаковке;

        ТекущаяСтрока.КоличествоУпаковок = ТекущаяСтрока.Упак * ТекВУп;
ПриИзмененииТоварыКоличестваУпаковок();

КонецПроцедуры

Выполнение приводит к ошибке
Цитировать
{Документ.ПоступлениеТоваров.Форма.ФормаДокумента.Форма(2674)}: Поле объекта не обнаружено (ВУпаковке)
   ТекВУп = ТекущаяНоменклатура.ВУпаковке;

Не могу понять как получить этот реквизит (да и вообще любые другие реквизиты в подобном случае) хотя-бы для чтения?


Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 187
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Тема уже мусолилась тысячи раз.
На клиенте недоступно ничего кроме ссылок.
Через ссылку на клиенте вы не сможете ничего получить.
Передавайте ссылку номенклатуры в серверную безконтекстную функцию и там уже получайте количество вупаковке.
Посмотрите, как это реализовано в типовых решениях.

Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
В вашем коде правим:
ТекВУп  = ПолучитьВУпак(ТекущаяНоменклатура);


Добавляем:

&НаСервере
Функция ПолучитьВУпак(Номенклатура)
   Возврат  Номенклатура.ПолучитьОбъект().ВУпаковке;
КонецФункции;
   
Как то так получим реквизит.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Добавляем:

Код: [Выделить]

&НаСервере
Функция ПолучитьВУпак(Номенклатура)
   Возврат  Номенклатура.ПолучитьОбъект().ВУпаковке;
КонецФункции;

   
Как то так получим реквизит.

Зачем получать объект? Вполне достаточно:
&НаСервереБезКонтекста
Функция ПолучитьВУпак(Номенклатура)
   Возврат  Номенклатура.ВУпаковке;
КонецФункции;


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4589
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 16220
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4319
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 747
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7873
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
99 Сообщений
AIFrame
65 Сообщений
alex0402
32 Сообщений
kiksi
26 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 117
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal