Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ЭтоВыходной(Дата)  (Прочитано 675 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AIFrame

  • ****
  • Сообщений: 293
  • РЕПУТАЦИЯ: 40
  • КПД: 14%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Ученик 1С
Пока ЧислоДней>0 Цикл
    ДатаОтсрочки = ДатаОтсрочки + 24*60*60;
    Если Не ЭтоВыходной(ДатаОтсрочки) Тогда
ЧислоДней = ЧислоДней - 1;
    КонецЕсли;
КонецЦикла;
Ситуация следующая - если в этот цикл зайти с числом дней, которое при отработке цикла перескочит на следующий год - цикл уйдет в бесконечность, т.к. начиная с 01.01.2016 все дни для 1С считаются как ЭтоВыходной(). Так задумано или это баг?
"Управление торговлей", редакция 10.3 (10.3.29.1)

Пока поставил заглушку, но причины такого поведения мне не ясны
	ТекущийГод = Год(ДатаОтсрочки);
Пока ЧислоДней>0 И ТекущийГод = Год(ДатаОтсрочки) Цикл
ДатаОтсрочки = ДатаОтсрочки + 24*60*60;
Если Не ЭтоВыходной(ДатаОтсрочки) Тогда
ЧислоДней = ЧислоДней - 1;
КонецЕсли;
КонецЦикла;
Если ЧислоДней>0 Тогда
Сообщить("Расчет отсрочки был остановлен на дате: " + ДатаОтсрочки + " для предотвращения бесконечного цикла.");
Сообщить("Число дней острочки, не обработанных циклом: " + ЧислоДней);
Сообщить("Цикл будет продолжен без учета выходных дней...");
Пока ЧислоДней>0 Цикл
ДатаОтсрочки = ДатаОтсрочки + 24*60*60;
ЧислоДней = ЧислоДней - 1;
КонецЦикла;
Сообщить("Документ отсрочки был успешно создан на дату: " + ДатаОтсрочки);
КонецЕсли;


Оффлайн Natain14

  • **
  • Сообщений: 55
  • РЕПУТАЦИЯ: 2
  • КПД: 4%
  • Регистрация: 2015-06-16
  • Сайт: 
Может надо просто заполнить производственный календарь на 2016? Никогда не работала с УТ 8.3. Но есть Регистр сведений в других конфах производственный календарь, там можно заполнить по умолчанию, пока не загружен актуальный

Оффлайн Kironten

  • *****
  • Сообщений: 900
  • РЕПУТАЦИЯ: 185
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Насколько я помню, то система считает выходными дни незаполненого года.
Т.е. нужно заполнить производственный календарь на 2016

Оффлайн AIFrame

  • ****
  • Сообщений: 293
  • РЕПУТАЦИЯ: 40
  • КПД: 14%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Ученик 1С
Может надо просто заполнить производственный календарь на 2016? Никогда не работала с УТ 8.3. Но есть Регистр сведений в других конфах производственный календарь, там можно заполнить по умолчанию, пока не загружен актуальный
Таки да. Спасибо.

2 дней
31.12.2015 16:14:51
2 дней
01.01.2016 16:14:51
2 дней
02.01.2016 16:14:51
2 дней
03.01.2016 16:14:51
2 дней
04.01.2016 16:14:51
2 дней
05.01.2016 16:14:51
1 дней
06.01.2016 16:14:51
1 дней
07.01.2016 16:14:51
0 дней
08.01.2016 16:14:51


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 323
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal