Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Июн 2018, 07:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открыть форму внешней или дополнительной обработки в управляющих формах  (Прочитано 5014 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн KazakOFF

  • **
  • Сообщений: 65
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-05
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет, пытаюсь разобраться как же открыть форму в управляющих формах.

В обычных случаях я делал так

ИмяФайла = ПолучитьИмяВременногоФайла();

Обработка = Справочники.ВнешниеОбработки.НайтиПоКоду("000000131").ХранилищеВнешнейОбработки.Получить();
Обработка.Записать(ИмяФайла);

ВнешняяОбработка = ВнешниеОбработки.Создать(ИмяФайла);
Форма = ВнешняяОбработка.ПолучитьФорму();
Форма.Открыть();

А тут и так не работает;

&НаСервере
Процедура Команда1НаСервере()
ВнешняяОбработка = ВнешниеОбработки.Создать("C:\****.epf");

ВнешняяОбработка.Открыть();


КонецПроцедуры

&НаКлиенте
Процедура Команда11(Команда)
Команда1НаСервере();

КонецПроцедуры



Что может быть не так?


Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 187
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Ну, как минимум у внешней обработки нет метода открыть().
Метод открыть есть у формы внешней обработки. Т.е. сначала получите форму.

Оффлайн KazakOFF

  • **
  • Сообщений: 65
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-05
  • Сайт: 
  • Профессия: Ученик 1С
Вы думаете я этого не пробовал? я уже все перепробовал.

Оффлайн Дмитрий@

  • *****
  • Сообщений: 759
  • РЕПУТАЦИЯ: 138
  • КПД: 18%
  • Регистрация: 2015-02-27
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    //Помещаем обработку во временном хранилище
    АдресХранилища = "";
    Результат = ПоместитьФайл(АдресХранилища, "C:\ВнешняяОбработка.epf", , Ложь);           
    ИмяОбработки = ПодключитьВнешнююОбработку(АдресХранилища);
   
    // Откроем форму подключенной внешней обработки
    ОткрытьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма");
КонецПроцедуры
&НаСервере
Функция ПодключитьВнешнююОбработку(АдресХранилища)
    Возврат ВнешниеОбработки.Подключить(АдресХранилища);
КонецФункции


Теги:
 

Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 850
Последний ответ 15 Май 2017, 08:59
от ZSS
Передача параметров из ячейки поля табличного документа в форму создания нового документа 1с 8.3

Автор Анна БахановичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 3742
Последний ответ 18 Фев 2016, 12:50
от Анна Баханович
Версия 8.3, при добавлении поля в форму списка не устанавливается вид поля - выпадающий список пустой

Автор Developer.KZРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 726
Последний ответ 22 Июн 2017, 10:50
от Developer.KZ
Как добавить внутреннюю обработку "Печать ТТН" на управляемую форму???

Автор ViktorkaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 8782
Последний ответ 11 Апр 2012, 17:14
от Vit1501
Как вывести табличный документ в форму "Печать документов"

Автор boldinovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2748
Последний ответ 03 Апр 2015, 17:50
от boldinov

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
125 Сообщений
AIFrame AIFrame
125 Сообщений
alexandr_ll
59 Сообщений
pavl_vs
50 Сообщений
alex0402
30 Сообщений
buketov.av buketov.av
27 Сообщений
ilyay ilyay
25 Сообщений
magnifico61
21 Сообщений
wise wise
20 Сообщений
trialex3
15 Сообщений

* Кто онлайн

  • Точка Гостей: 223
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal