Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 22:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отбор в динамическом списке  (Прочитано 3702 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jastreb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 1
  • КПД: 9%
  • Регистрация: 2013-07-03
  • Сайт: 
  • Профессия: Ученик 1С
В справочнике Литература, форма элемента добавлена табличная часть Авторы, для добавления нескольких авторов
в карточку книги из соответствующего справочника.
В основной форме авторы представлены в виде динамического списка Рис1.. Список формируется произвольным запросом.
Необходимо сделать так, что бы при активизации строки списка происходил отбор по автору и выводился список книг с этим автором в Списке литературы Рис1.
который также является динамическим списком, формируется произвольным запросом.

Ранее отбор происходил следующим образом, до добавления табличной части и автор указывался строго один.

&НаКлиенте
Процедура СписокАвторовПриАктивизацииСтроки(Элемент)
СделатьОтбор(Элемент, "Авторы");
КонецПроцедуры

&НаКлиенте
Процедура СделатьОтбор(Элемент, ИмяПоля);

Если НЕ Элемент.ТекущиеДанные = Неопределено Тогда
СписокЛитературы.Отбор.Элементы.Очистить();
ЭлементОтбора = СписокЛитературы.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение =Новый ПолеКомпоновкиДанных(ИмяПоля);
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСписке;
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.ПравоеЗначение = Элемент.ТекущиеДанные.Ссылка;
Иначе
СписокЛитературы.Отбор.Элементы.Очистить();
КонецЕсли;
КонецПроцедуры

Подскажите как такое реализовать, если возможно с примером кода.
Благодарю.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн jastreb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 1
  • КПД: 9%
  • Регистрация: 2013-07-03
  • Сайт: 
  • Профессия: Ученик 1С
Примерно такой и было сделано, до добавления табличной части. О чем писал выше.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
хотя тут скорее другой вариант нужен - добавить в запрос к дин.списку параметр Автор и его менять.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн jastreb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 1
  • КПД: 9%
  • Регистрация: 2013-07-03
  • Сайт: 
  • Профессия: Ученик 1С
А можно подробней? Как и что.
Вот сам запрос для формирования динамического списка
ВЫБРАТЬ
СправочникБ_Авторы.Ссылка,
СправочникБ_Авторы.ПометкаУдаления,
СправочникБ_Авторы.Код,
СправочникБ_Авторы.Наименование,
СправочникБ_Авторы.Предопределенный,
СправочникБ_Авторы.ИмяПредопределенныхДанных
ИЗ
Справочник.Б_Авторы КАК СправочникБ_Авторы

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн jastreb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 1
  • КПД: 9%
  • Регистрация: 2013-07-03
  • Сайт: 
  • Профессия: Ученик 1С
Решил следующим образом
В запросе формирующем динамический список литературы
ВЫБРАТЬ
СправочникБ_Литература.Ссылка,
СправочникБ_Литература.ПометкаУдаления,
СправочникБ_Литература.Код,
СправочникБ_Литература.Наименование,
СправочникБ_Литература.Автор,
СправочникБ_Литература.НаименованиеББК,
СправочникБ_Литература.НаименованиеУДК,
СправочникБ_Литература.Аннотация,
СправочникБ_Литература.Издательство,
СправочникБ_Литература.ГодИздания,
СправочникБ_Литература.НавигационнаяСсылкаНаОбложку,
СправочникБ_Литература.ФайлКартинки,
СправочникБ_Литература.СсылкаНаФайл,
СправочникБ_Литература.путьКФайлуЗагрузки,
СправочникБ_Литература.разделительПолей,
СправочникБ_Литература.символОграничения,
СправочникБ_Литература.Язык,
СправочникБ_Литература.Жанр,
СправочникБ_Литература.Серия,
СправочникБ_Литература.КодББК,
СправочникБ_Литература.КодУДК,
СправочникБ_Литература.Предопределенный,
СправочникБ_Литература.ИмяПредопределенныхДанных,
СправочникБ_Литература.Авторы.(
Ссылка,
НомерСтроки,
Автор
),
СправочникБ_Литература.РубрикаторыББК.(
Ссылка,
НомерСтроки,
РубрикаторББК
),
СправочникБ_Литература.РубрикаторыУДК.(
Ссылка,
НомерСтроки,
РубрикаторУДК
)
ИЗ
Справочник.Б_Литература КАК СправочникБ_Литература
ГДЕ
ВЫБОР
КОГДА &Параметр ЕСТЬ NULL
ТОГДА ИСТИНА
ИНАЧЕ ВЫБОР
КОГДА &Режим ЕСТЬ NULL
ТОГДА ИСТИНА
ИНАЧЕ ВЫБОР
КОГДА &Режим = 1
ТОГДА СправочникБ_Литература.Авторы.Автор = &Параметр
ИНАЧЕ ВЫБОР
КОГДА &Режим = 2
ТОГДА СправочникБ_Литература.РубрикаторыББК.РубрикаторББК = &Параметр
ИНАЧЕ ВЫБОР
КОГДА &Режим = 3
ТОГДА СправочникБ_Литература.РубрикаторыУДК.РубрикаторУДК = &Параметр
КОНЕЦ
КОНЕЦ
КОНЕЦ
КОНЕЦ
КОНЕЦ

И в модуле формы Обработка события При активизации строки
Процедура СписокАвторовПриАктивизацииСтроки(Элемент)

СделатьОтборАвторыРубрикаторы(Элемент, 1);

КонецПроцедуры

Процедура СделатьОтборАвторыРубрикаторы(Элемент, Режим);

Если НЕ Элемент.ТекущиеДанные = Неопределено Тогда
СписокЛитературы.Отбор.Элементы.Очистить();
СписокЛитературы.Параметры.УстановитьЗначениеПараметра("Параметр", Элемент.ТекущиеДанные.Ссылка);
СписокЛитературы.Параметры.УстановитьЗначениеПараметра("Режим", Режим);
Иначе
СписокЛитературы.Параметры.УстановитьЗначениеПараметра("Режим", Неопределено);
СписокЛитературы.Параметры.УстановитьЗначениеПараметра("Параметр", Неопределено);
КонецЕсли;

КонецПроцедуры



Теги:
 

Программный отбор в "Документы"

Автор SeolkinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4255
Последний ответ 06 Окт 2012, 18:08
от Seolkin
Отбор при "быстром выборе"

Автор Gregory78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3110
Последний ответ 15 Фев 2015, 12:13
от Gregory78
Дин.список отбор данных - не работает код при тех же данных

Автор Аля ТинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 129
Последний ответ 15 Дек 2017, 14:36
от alex0402
Отбор по номенклатуре в отчете "ВЕдомость выдачи мц"

Автор notaSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2352
Последний ответ 08 Авг 2015, 15:40
от ppkmlite
Отбор по дате проведения документа в обработке "Универсальные подбор и обработка объектов"

Автор rooflessРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2578
Последний ответ 25 Июн 2014, 15:30
от roofless

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 291
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal