Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Янв 2018, 00:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Определение процедур в общем модуле  (Прочитано 2986 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sergey_lb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-07
  • Сайт: 
  • Профессия: Программист 1С
Стал разрабатывать собственную конфигурацию. Столкнулся со странной проблемой.

&НаСервере
Процедура СостояниеСканераШтрихкодаСервер(Сост=Ложь)Экспорт
   Константы.СканерИспользуется.Установить(Сост);
КонецПроцедуры
   
&НаКлиенте
Процедура СостояниеСканераШтрихкодаКлиент(Состояние=Ложь) Экспорт
   СостояниеСканераШтрихкодаСервер(Состояние);
КонецПроцедуры

При исполнении выдает сообщение об ошибке
{ОбщийМодуль.РаботаСТорговымОборудованием.Модуль(8,2)}: Процедура или функция с указанным именем не определена (СостояниеСканераШтрихкодаСервер)
   <<?>>СостояниеСканераШтрихкодаСервер(Состояние);
Почему ???:wacko:


Оффлайн Дмитрий@

  • *****
  • Сообщений: 744
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
У общего модуля, поставьте галочку напротив свойства "Вызов сервера".
Ссылка на примеры работ https://yadi.sk/d/ksVluPMBkiRzX

Оффлайн sergey_lb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-07
  • Сайт: 
  • Профессия: Программист 1С
Галочка стоит.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Разделите ваш общий модуль на 2 с со свойствами "Клиент" и "Сервер" соответственно.

Оффлайн sergey_lb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-07
  • Сайт: 
  • Профессия: Программист 1С
Разделил. Теперь ругается на общий модуль из модуля управляемого приложения.
{МодульУправляемогоПриложения(12,4)}: Переменная не определена (РаботаСТорговымОборудованиемКлиент)
         <<?>>РаботаСТорговымОборудованиемКлиент.СостояниеСканераШтрихкодаКлиент(Истина); (Проверка: Тонкий клиент)

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Покажите как происходит вызов.

Оффлайн sergey_lb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-07
  • Сайт: 
  • Профессия: Программист 1С
Процедура ПриНачалеРаботыСистемы()
   
   Попытка
      // Загрузка внешней компоненты
      ЗагрузитьВнешнююКомпоненту("Scaner1C.dll");
      Попытка
         // Создание объекта
         Сканер = Новый("AddIn.Scaner45");
         Сканер.OldVersion = 1;
         РаботаСТорговымОборудованиемКлиент.СостояниеСканераШтрихкодаКлиент(Истина);
      Исключение
         Сообщить("Объект не найден!");
         РаботаСТорговымОборудованиемКлиент.СостояниеСканераШтрихкодаКлиент(Ложь);
      КонецПопытки;
   Исключение
      Сообщить("Внешняя компонента драйвера не найдена");
      РаботаСТорговымОборудованиемКлиент.СостояниеСканераШтрихкодаКлиент(Ложь);
   КонецПопытки;

КонецПроцедуры

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
ПриНачалеРаботыСистемы выполняется на сервере. Вызывать можно:
1) С клиента->клиент
2) С клиента->сервер
3) С сервера->сервер

С сервера клиент вызывать нельзя!

Оффлайн sergey_lb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-07
  • Сайт: 
  • Профессия: Программист 1С
Спасибо. Все Работает. Ошибка в имени общего модуля.
Добавлено: 20 Авг 2015, 12:19

Конфигуратор перестал ругаться. Но при запуске выдает сообщение об ошибке
{ОбщийМодуль.РаботаСТорговымОборудованиемКлиент.Модуль(4)}: Метод объекта не обнаружен (СостояниеСканераШтрихкодаСервер)
   РаботаСТорговымОборудованиемСервер.СостояниеСканераШтрихкодаСервер(Состояние);

Последний раз редактировалось: sergey_lb; 20 Авг 2015, 12:19. Причина: Объединение сообщений

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
У общего модуля, поставьте галочку напротив свойства "Вызов сервера".

?


Теги:
 

Вопрос по созданию ресурсной ведомости в модуле "Снабжение и склад"

Автор GrandbergРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1587
Последний ответ 18 Июл 2014, 17:28
от Grandberg
Определение текущего Пользователя в ИБ, подстановка пользователя в справочник

Автор LavrSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 999
Последний ответ 28 Апр 2016, 07:33
от LavrS
Определение среднего дневного заработка в случае, если работница находилась в декрете в расчетном периоде

Автор newsРаздел Новости

Ответов: 0
Просмотров: 772
Последний ответ 16 Дек 2015, 00:32
от news
Использование экспортных переменных в модуле объекта из модуля управляемой формы

Автор DimaArtsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 5723
Последний ответ 25 Янв 2012, 12:46
от DimaArts
Поиск стандартных процедур модуля формы из другой формы.

Автор Дамир ТлеухановРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 788
Последний ответ 18 Авг 2016, 11:50
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
93 Сообщений
AIFrame
75 Сообщений
alex0402
32 Сообщений
pavl_vs
23 Сообщений
kiksi
22 Сообщений
andron81_81
18 Сообщений
alexandr_ll
17 Сообщений
Norfolk
15 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений
Orion
12 Сообщений

* Кто онлайн

  • Точка Гостей: 264
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal