Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Июл 2017, 13:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Безналичная оплата на кассе  (Прочитано 1489 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pretender

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-25
  • Сайт: 
  • Профессия: ГлавБух
Доброго времени суток
Имеется 1С 7.7 ТиС 9.2   7.70.935, Штрих-ФР-К
Требуется внести следующие корректировки:
- при нажатии кнопки ОПЛАТА на рабочем месте продавца должно появиться окошко с выбором типа оплаты НАЛ / КАРТА ("нал" выделен по-умолчанию)
- в случае выбора оплаты по карте продаже присваивается признак безналичной оплаты (или оплаты через другой отдел)
- при снятии отчетов по завершении смены должна выводиться отдельно сумма продаж по каждому виду оплат

Всё бы ничего, но городок маленький, спецов нет, а из соседних никто приезжать к нам не хочет...

Намекните, пожалуйста, где рыть....
Начал с внешней обработки ФР fr_elves.ert


Оффлайн Pretender

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-25
  • Сайт: 
  • Профессия: ГлавБух
В настоящее время в модуле конфигурации прописано следующее по нажатию кнопки ОПЛАТА:

Процедура ОплатаНал()

    Если Чек.КоличествоСтрок()>0 тогда


если Число(Цифры)>0 Тогда
        Если Число(Цифры)<Чек.Итог("Сумма") тогда
GlobalReg.HookEnabled = 0;
Предупреждение("Сумма оплаты меньше суммы чека!");
GlobalReg.HookEnabled = 1;
Возврат;
Иначе
Нал=Число(Цифры);
КонецЕсли;
Иначе
Нал=Чек.Итог("Сумма");
    КонецЕсли;
   
Сдача=Нал-Чек.Итог("Сумма");

ВывестиСтрокуНаДисплей("Сдача:"+Формат(Сдача,"Ч14.2"),1);
ВывестиСтрокуНаДисплей("Итого:"+Формат(Чек.Итог("Сумма"),"Ч14.2"),2);

Если (Операция="Розн.продажа") или (Операция="Розн.возврат") тогда

ДокЧек = СоздатьОбъект("Документ.ЧекККМ");
ДокЧек.Новый();
ДокЧек.Автор = глПользователь;
ДокЧек.Фирма = глЗначениеПоУмолчанию("ОсновнаяФирма");
ДокЧек.Склад = глЗначениеПоУмолчанию("ОсновнойСклад");
ДокЧек.Касса = глЗначениеПоУмолчанию("ОсновнаяКасса");
ДокЧек.Валюта = глРубли;
ДокЧек.Курс = 1;
ДокЧек.Получено = Нал;
ДокЧек.ВидОперации=?(Операция="Розн.возврат",Перечисление.ВидыОперацийЧекККМ.ЧекНаВозврат,Перечисление.ВидыОперацийЧекККМ.Чек);
ДокЧек.НомерЧекаККМ="";
// ДокЧек.ЧекПробитККМ=1;
ДокЧек.Скидка=Скидка;

ДокЧек.ЗагрузитьТабличнуюЧасть(Чек);
Попытка
ДокЧек.Записать();
ДокЧек.Провести();
Исключение
// Возврат;
КонецПопытки;

Если ДокЧек.Проведен()=1 тогда

Инициализация();
Иначе

КонецЕсли

Активизировать("Оплата");
КонецПроцедуры

Оффлайн G_Re

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2011-12-17
  • Сайт: 
  • Профессия: Ученик 1С
Ну, в принципе, ты уже в целом логику и написал, осталось её перевести на язык 1С(он тоже очень похож на русский), то есть отобразить окошко, принять и проанализировать ответ, в зависимости от ответа сделать те или иные действия. Окошко можно сделать либо сз на форме, либо какими-то флажками или переключателями на форме, либо отдельной обработкой, это дело вкуса, привычки или принятым стилем интерфейса, а дальше проще, просто обработать ответ.

Оффлайн Олег2

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-19
  • Сайт: 
  • Профессия: Ученик 1С
при возникновении правовых вопросов http://kalkulyator-osago.ru/


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
92 Сообщений
oleg-x
80 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений
Dethmontt Dethmontt
22 Сообщений
xproh
21 Сообщений

* Кто онлайн

  • Точка Гостей: 897
  • Точка Скрытых: 0
  • Точка Пользователей: 16
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal