Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Веб-клиен  (Прочитано 1315 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Andrey_123

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 3
  • КПД: 4%
  • Регистрация: 2014-02-24
  • Сайт: 
  • Профессия: Программист 1С
Веб-клиен
« Первое сообщение: 19 Авг 2015, 15:33 »
Здравствуйте. Есть обработка в которой при нажатию на кнопку загружается фотография в справочник. Все нормально работает в тонком клиенте, но если выполнить нажатие на кнопку "загрузить фото" в веб-клиенте то загрузка не происходит. В чем может быть дело?


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Веб-клиен
« Ответ #1: 19 Авг 2015, 15:38 »
Наверное сделали через диалоговое окно выбора файла без использования временного хранилища.

В веб клиенте нужно использовать временное хранилище.

Оффлайн Andrey_123

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 3
  • КПД: 4%
  • Регистрация: 2014-02-24
  • Сайт: 
  • Профессия: Программист 1С
Re: Веб-клиен
« Ответ #2: 19 Авг 2015, 15:42 »
Временное хранилище есть.

&НаКлиенте
Процедура ДобавитьКартинку(Команда)
Если ММП_ПроверкаДоступностиРоли.ПроверкаДоступностиРоли("ММП_ДобавлениеФотографииВТелСпр") ИЛИ ММП_ПроверкаДоступностиРоли.ПроверкаДоступностиРоли("ПолныеПрава") Тогда
ИмяФайла = "";
ПутьКФайлу="";
ПутьФайла = "";
//Вызываем Диалоговое окно и помещаем файл Картинки из локальной файловой системы во временное хранилище
Если ПоместитьФайл(ПутьФайла, , ИмяФайла, Истина) = Истина Тогда
//в строковый реквизит ФОТО нашей формы сохраняем ссылку на Картинку во временном хранилище
АдресФото = ПутьФайла;
ПутьКФайлу = ИмяФайла;
ВыбранноеИзображение = Новый Картинка(ПутьКФайлу, Ложь);
//для создания нового элемента в Справочнике Файлы и записи Картинки в его реквизит Файл
//переходим на сервер с помощью вызова серверной процедуры
УстановитьКартинку(ВыбранноеИзображение,ПутьКФайлу);
КонецЕсли;
КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура УстановитьКартинку(ВыбранноеИзображение,ПутьКФайлу)
//создаем новый элемент в Справочнике Файлы
НовыйФайлКартинки = Справочники.ХранилищеДополнительнойИнформации.СоздатьЭлемент();
//в реквизиты СправочникаХранилищеДополнительнойИнформации помещаем выбранную ранее Картинку и заполняем остальные реквизиты
НовыйФайлКартинки.ВидДанных = Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение;
НовыйФайлКартинки.Хранилище = Новый ХранилищеЗначения(ВыбранноеИзображение, Новый СжатиеДанных);
НовыйФайлКартинки.Объект = ЭтаФорма.Параметры.Данные.ФизЛицо;
НовыйФайлКартинки.ИмяФайла = РаботаСФайлами.ПолучитьИмяФайлаИзПолногоПути(ПутьКФайлу);
НовыйФайлКартинки.Наименование = Строка(Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение) + " " + Строка(ЭтаФорма.Параметры.Данные.Сотрудник);
АдресФото = ПоместитьВоВременноеХранилище(НовыйФайлКартинки.Хранилище.Получить());
//записываем новый элемент справочника Файлы
НовыйФайлКартинки.Записать();

//Выбираем из СправочникаФизическиеЛица объект и записываем в него ссылку на справочник ХранилищеДополнительнойИнформации   
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ФизическиеЛица.Ссылка
|ИЗ
| Справочник.ФизическиеЛица КАК ФизическиеЛица
|ГДЕ
| ФизическиеЛица.Ссылка = &Ссылка";

Запрос.УстановитьПараметр("Ссылка", ЭтаФорма.Параметры.Данные.ФизЛицо);

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
ОбъектОснИз = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
ОбъектОснИз.ОсновноеИзображение = НовыйФайлКартинки.Ссылка;
ОбъектОснИз.Записать();
КонецЦикла;

ЭтаФорма.Модифицированность=Истина;
КонецПроцедуры

Последний раз редактировалось: MuI_I_Ika; 19 Авг 2015, 15:43

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Веб-клиен
« Ответ #3: 19 Авг 2015, 15:54 »
У вас действительно помещается файл во временное хранилище с адресом ПутьФайла

Но в дальнейшем вы нигде это не используете. Просто берете картинку и пытаетесь передать ее на сервер. Так не пойдет. На сервере нужно читать файл из временного хранилища.

Оффлайн Andrey_123

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 3
  • КПД: 4%
  • Регистрация: 2014-02-24
  • Сайт: 
  • Профессия: Программист 1С
Re: Веб-клиен
« Ответ #4: 19 Авг 2015, 16:00 »
В какой момент вызывать чтение из временного хранилища. Если можно кодом.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Веб-клиен
« Ответ #5: 19 Авг 2015, 16:04 »
Вот есть пример работы в временным хранилищем: http://forum-1c.ru/index.php?topic=48199.0

Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Re: Веб-клиен
« Ответ #6: 20 Авг 2015, 12:49 »
Еще есть такая тема, раньше для работы с файлами в веб клиенте, нужно было выполнить проверку на наличие библиотек работы с файлами, и в случае если они не подгружены подгрузить их. Насколько это сейчас актуально не знаю.
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн Andrey_123

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 3
  • КПД: 4%
  • Регистрация: 2014-02-24
  • Сайт: 
  • Профессия: Программист 1С
Re: Веб-клиен
« Ответ #7: 20 Авг 2015, 12:51 »
Всем спасибо, я разобрался. Сделалл через временное хранилище.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 273
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal