Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Сен 2020, 13:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: требуется помощь  (Прочитано 2031 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 556008

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-23
  • Сайт: 
Помогите, пожалуйста, реализовать следующие процедуры:

- процедура отказа проведения, если не заполнено одно из полей;
- процедура доступность (только просмотр) и видимость элементов управления формы по ролям.


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Re: требуется помощь
« Ответ #1: 23 Ноя 2010, 16:53 »
1. Как вариант - в обработке проведения добавить условие;
Если ЗначениеЗаполнено(Реквизит1) Тогда
...

2. Здесь есть варианты:
2.1 - RLS (если в двух словах, что определенной роли в конфигураторе даете право на просмотр и чтение нужного объекта)
2.2 - можно и кодом, но это не красиво.
ЭлементыФормы.ПолеВвода1.Доступность = Ложь;
ЭлементыФормы.ПолеВвода1.Видимость = Ложь;

Оффлайн 556008

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-23
  • Сайт: 
Re: требуется помощь
« Ответ #2: 23 Ноя 2010, 17:05 »
1. Как вариант - в обработке проведения добавить условие;
Если ЗначениеЗаполнено(Реквизит1) Тогда
...

необходимо, чтобы документ не проводился, когда не заполнено хотя бы одно из полей ввода.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Re: требуется помощь
« Ответ #3: 23 Ноя 2010, 17:46 »
Ну как вариант:
Функция ПроверитьЗаполнение()
Отказ = Ложь;
Если ЗначениеЗаполнено(Реквизит1) Тогда
Отказ=Истина;
КонецЕсли;
Если ЗначениеЗаполнено(Реквизит2) Тогда
Отказ=Истина;
КонецЕсли;
...
Возврат Отказ;
КонецФункции
...
...
...
Отказ = ПроверитьЗаполнение();
Если Не Отказ Тогда
...
КонецЕсли;


Теги:
 

Нужна помощь про "Отчет о смене без гашение" и "Z отчет"

Автор Serg85Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 5492
Последний ответ 23 Ноя 2014, 12:36
от дфтын
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4215
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Нужна помощь по "Управление торговлей 10.3"

Автор werstakРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2727
Последний ответ 26 Мар 2011, 12:50
от werstak
Помощь в создании бд "Путевые листы" 1с

Автор arozРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 376
Последний ответ 11 Май 2020, 17:39
от Геннадий ОбьГЭС
Нужна помощь в формировании отчета "Преобразование значения к типу Дата не может быть выполнено"

Автор STLuka1337Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3477
Последний ответ 14 Ноя 2014, 13:24
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
LexaK
34 Сообщений
oooo800
30 Сообщений
Дмитрий Джей Дмитрий Джей
27 Сообщений
antoneus antoneus
17 Сообщений
DmitriyF DmitriyF
17 Сообщений
IL2016
16 Сообщений
Ann_
16 Сообщений
SoOliateR
15 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 640
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal