Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 сен 2021, 00:10

требуется помощь

Автор 556008, 23 ноя 2010, 16:46

0 Пользователей и 1 гость просматривают эту тему.

556008

Помогите, пожалуйста, реализовать следующие процедуры:

- процедура отказа проведения, если не заполнено одно из полей;
- процедура доступность (только просмотр) и видимость элементов управления формы по ролям.

progmikon

1. Как вариант - в обработке проведения добавить условие;

Если ЗначениеЗаполнено(Реквизит1) Тогда
...


2. Здесь есть варианты:
2.1 - RLS (если в двух словах, что определенной роли в конфигураторе даете право на просмотр и чтение нужного объекта)
2.2 - можно и кодом, но это не красиво.

ЭлементыФормы.ПолеВвода1.Доступность = Ложь;
ЭлементыФормы.ПолеВвода1.Видимость = Ложь;

556008

Цитата: progmikon от 23 ноя 2010, 16:53
1. Как вариант - в обработке проведения добавить условие;

Если ЗначениеЗаполнено(Реквизит1) Тогда
...


необходимо, чтобы документ не проводился, когда не заполнено хотя бы одно из полей ввода.

progmikon

Ну как вариант:

Функция ПроверитьЗаполнение()
Отказ = Ложь;
Если ЗначениеЗаполнено(Реквизит1) Тогда
Отказ=Истина;
КонецЕсли;
Если ЗначениеЗаполнено(Реквизит2) Тогда
Отказ=Истина;
КонецЕсли;
...
Возврат Отказ;
КонецФункции
...
...
...
Отказ = ПроверитьЗаполнение();
Если Не Отказ Тогда
...
КонецЕсли;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск