Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Июл 2019, 12:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите найти ошибку  (Прочитано 8220 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
А что значит по дням?


Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Т.е нужно посчитать общую сумму за день.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Дни у вас в Периоде?

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Поместите ваши два объединенных запроса во вложенный и сделайте группировку по периоду, а затем ваши Итоги.

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
А группировку по периоду в итогах делать?

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Можно либо в итогах, либо в группировке.

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Так он выводит итог по каждой строчке. Т.е, например даты 02.03.2010 12.00.02 и 02.03.2010 12.00.09 он считает разными. А мне надо чтобы считал как одну и складывал сумму.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Как вариант можно сделать все даты на начало дня:
НАЧАЛОПЕРИОДА(ЧегоТоТам.Период, ДЕНЬ)

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Спасибо, так считает) только мне надо посчитать за день для кассы и отдельно за день для банка( я попробывала считать вовремя вывода в макет, но у меня не получается. Может вы глянете код? Буду очень благодарна.

Процедура Кнопка1Нажатие(Элемент)
   
   СформироватьТЗ();
   
   ТабДокумент = Новый ТабличныйДокумент;
   
   Макет = ПолучитьМакет("Макет");
   ОбластьШапка = Макет.ПолучитьОбласть("Шапка");   
   ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
   ОбластьСтрока2 = Макет.ПолучитьОбласть("Строка2");
   ОбластьИтогоЗаМесяцБанк = Макет.ПолучитьОбласть("ИтогоЗаМесяцБанк");
   ОбластьИтогоЗаМесяцКасса = Макет.ПолучитьОбласть("ИтогоЗаМесяцКасса");
   ОбластьИтогЗаДеньБанк = Макет.ПолучитьОбласть("ИтогЗаДеньБанк");
   ОбластьИтогЗаДеньКасса = Макет.ПолучитьОбласть("ИтогЗаДеньКасса");
      
   ТабДокумент.Вывести(ОбластьШапка);
   
   ИтогЗаДеньКасса=0;
    ИтогЗаДеньБанк=0;
   ИтогоЗаМесяцКасса=0;
   ИтогоЗаМесяцБанк=0;
   
   Если ТЗ.Количество() > 0 Тогда  //Построчный обход ТЗ         
      
      Для Счетчик = 0 По (ТЗ.Количество()-1) Цикл            
         СтрокаТЗ = ТЗ.Получить(Счетчик);
                     
         Если СтрокаТЗ.СпособВыплаты = Перечисления.СпособыВыплатыЗарплаты.ЧерезКассу Тогда
             ОбластьСтрока2.Параметры.Период = СтрокаТЗ.Период;
              ОбластьСтрока2.Параметры.Ведомость = СтрокаТЗ.Ведомость;
              ОбластьСтрока2.Параметры.СуммаВзаиморасчетов = СтрокаТЗ.СуммаВзаиморасчетов;
              ОбластьСтрока2.Параметры.Регистратор = СтрокаТЗ.Регистратор;
             ТабДокумент.Вывести(ОбластьСтрока2);
            
             ПредыдДеньКасса=СтрокаТЗ.Период;
            
             Если ПредыдДеньКасса=СтрокаТЗ.Период Тогда
                 ИтогЗаДеньКасса=ИтогЗаДеньКасса+ОбластьСтрока2.Параметры.СуммаВзаиморасчетов;
                 ОбластьИтогЗаДеньКасса.Параметры.ИтогоСуммаВзаиморасчетов = ИтогЗаДеньКасса;
              Иначе ИтогЗаДеньКасса=0;
              КонецЕсли;    
            
                  ИтогоЗаМесяцКасса = ИтогоЗаМесяцКасса +  ОбластьСтрока2.Параметры.СуммаВзаиморасчетов;                                 
                        ОбластьИтогоЗаМесяцКасса.Параметры.ИтогоСуммаВзаиморасчетов = ИтогоЗаМесяцКасса;
            
              ИначеЕсли СтрокаТЗ.СпособВыплаты = Перечисления.СпособыВыплатыЗарплаты.ЧерезБанк Тогда                                      
                       ОбластьСтрока.Параметры.Период = СтрокаТЗ.Период;
                        ОбластьСтрока.Параметры.Ведомость = СтрокаТЗ.Ведомость;
                        ОбластьСтрока.Параметры.СуммаВзаиморасчетов = СтрокаТЗ.СуммаВзаиморасчетов;
                        ОбластьСтрока.Параметры.Регистратор = СтрокаТЗ.Регистратор;
                     ТабДокумент.Вывести(ОбластьСтрока);
                     
                     ПредыдДеньБанк=СтрокаТЗ.Период;
                    
                Если ПредыдДеньБанк=СтрокаТЗ.Период Тогда
                    ИтогЗаДеньБанк= ИтогЗаДеньБанк + ОбластьСтрока.Параметры.СуммаВзаиморасчетов;
                    ОбластьИтогЗаДеньБанк.Параметры.ИтогоСуммаВзаиморасчетов = ИтогЗаДеньБанк;
                Иначе ИтогЗаДеньБанк=0;      
                КонецЕсли;

                  
                        ИтогоЗаМесяцБанк = ИтогоЗаМесяцБанк +  ОбластьСтрока.Параметры.СуммаВзаиморасчетов;                         
                     ОбластьИтогоЗаМесяцБанк.Параметры.ИтогоСуммаВзаиморасчетов = ИтогоЗаМесяцБанк;
                     
                     
                     
          КонецЕсли;
       КонецЦикла;
      
       Для СчетчикПоказателей = 0 По (ТЗ.Количество()-1) Цикл            
         СтрокаТЗ = ТЗ.Получить(Счетчик);
         
 
      
    КонецЕсли;
    ТабДокумент.Вывести(ОбластьИтогЗаДеньКасса);
    ТабДокумент.Вывести(ОбластьИтогЗаДеньБанк);
     ТабДокумент.Вывести(ОбластьИтогоЗаМесяцБанк);
    ТабДокумент.Вывести(ОбластьИтогоЗаМесяцКасса);
       
     ТабДокумент.Показать(Макет);
   
КонецПроцедуры


Теги:
 

Помогите выразить код Объект.Наименование = Объект.Подразделение + " " + Объект.Должность + " " + Объект.ФизическоеЛицо через строки.

Автор LedgikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 299
Последний ответ 05 Мар 2019, 19:28
от Ledgik
Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5315
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите правильно настроить справочник "Единицы измерения" и "Номенклатура"

Автор perminovandrРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 427
Последний ответ 23 Янв 2019, 07:21
от Геннадий ОбьГЭС
На фото демонстрируется личная карточка сотрудника, но во столбце "ЗА ЯКИЙ ПЕРІОД " не показывает ничего, как это можно решить, помогите пожалуйста

Автор cBeginnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 678
Последний ответ 26 Июл 2018, 17:44
от alex0402
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6531
Последний ответ 07 Сен 2010, 12:01
от mohock

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
73 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
60 Сообщений
LexaK
27 Сообщений
Александр Мун Александр Мун
17 Сообщений
DmitriyF DmitriyF
17 Сообщений
BuhRust
16 Сообщений
wise wise
16 Сообщений
alexandr_ll
14 Сообщений
alex0402 alex0402
8 Сообщений
MaxPoi
8 Сообщений

* Кто онлайн

  • Точка Гостей: 722
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal