Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 01:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите найти ошибку  (Прочитано 6747 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Есть следующий код. Почему выводится только шапка и все?

Процедура Кнопка1Нажатие(Элемент)
   
   СформироватьТЗ();
   
   ТабДокумент = Новый ТабличныйДокумент;
   
   Макет = ПолучитьМакет("Макет");
   ОбластьШапка = Макет.ПолучитьОбласть("Шапка");   
   ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
   ОбластьСтрока2 = Макет.ПолучитьОбласть("Строка2");
      
   ТабДокумент.Вывести(ОбластьШапка);

   
   Если ТЗ.Количество() > 0 Тогда  //Построчный обход ТЗ
      
      Для Счетчик = 0 По (ТЗ.Количество()-1) Цикл            
         СтрокаТЗ = ТЗ.Получить(Счетчик);
            
         Если СтрокаТЗ.СпособВыплаты = "Через кассу" Тогда
                 ОбластьСтрока2.Параметры.Период = СтрокаТЗ.Период;
              ОбластьСтрока2.Параметры.Ведомость = СтрокаТЗ.Ведомость;
              ОбластьСтрока2.Параметры.СуммаВзаиморасчетов = СтрокаТЗ.СуммаВзаиморасчетов;
              ОбластьСтрока2.Параметры.Регистратор = СтрокаТЗ.Регистратор;
              ТабДокумент.Вывести(ОбластьСтрока2);

      
          ИначеЕсли СтрокаТЗ.СпособВыплаты = "Через банк" Тогда                                      
                  ОбластьСтрока.Параметры.Период = СтрокаТЗ.Период;
                    ОбластьСтрока.Параметры.Ведомость = СтрокаТЗ.Ведомость;
                    ОбластьСтрока.Параметры.СуммаВзаиморасчетов = СтрокаТЗ.СуммаВзаиморасчетов;
                    ОбластьСтрока.Параметры.Регистратор = СтрокаТЗ.Регистратор;
                    ТабДокумент.Вывести(ОбластьСтрока);
          КонецЕсли;
 
      КонецЦикла;
   
   КонецЕсли;   


     ТабДокумент.Показать(Макет);

   
КонецПроцедуры



Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
В ваш цикл программа входит?

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
В цикл входит. Не входит в Если и ИначеЕсли,хотя условие выполняется.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
А способ выплаты это у вас точно строка?

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Тип: ПеречислениеСсылка.СпособыВыплатыЗарплаты

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
вот тогда так и пиши :
Если СтрокаТЗ.СпособВыплаты = ПеречислениеСсылка.СпособыВыплатыЗарплаты.ЧерезКассу Тогда

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
точенее
Если СтрокаТЗ.СпособВыплаты = Перечисления.СпособыВыплатыЗарплаты.ЧерезКассу Тогда

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Спасибо)

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
А как сделать, чтобы в этом запросе считалась СуммаВзаиморасчетов по дням?

ВЫБРАТЬ
   ВзаиморасчетыСРаботникамиОрганизаций.Период КАК Период,
   ВзаиморасчетыСРаботникамиОрганизаций.Ведомость,
   СУММА(ВзаиморасчетыСРаботникамиОрганизаций.СуммаВзаиморасчетов) КАК СуммаВзаиморасчетов,
   ВзаиморасчетыСРаботникамиОрганизаций.СпособВыплаты,
   ВзаиморасчетыСРаботникамиОрганизаций.Регистратор
ИЗ
   РегистрНакопления.ВзаиморасчетыСРаботникамиОрганизаций КАК ВзаиморасчетыСРаботникамиОрганизаций
ГДЕ
   ВзаиморасчетыСРаботникамиОрганизаций.Организация = &Организация
   И ВзаиморасчетыСРаботникамиОрганизаций.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Расход)
   И ВзаиморасчетыСРаботникамиОрганизаций.Период МЕЖДУ &НачалоПериода И КОНЕЦПЕРИОДА(&КонецПериода, ДЕНЬ)

СГРУППИРОВАТЬ ПО
   ВзаиморасчетыСРаботникамиОрганизаций.Ведомость,
   ВзаиморасчетыСРаботникамиОрганизаций.СпособВыплаты,
   ВзаиморасчетыСРаботникамиОрганизаций.Регистратор,
   ВзаиморасчетыСРаботникамиОрганизаций.Период

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
   ВзаиморасчетыСДепонентамиОрганизаций.Период,
   ВзаиморасчетыСДепонентамиОрганизаций.Ведомость,
   ВзаиморасчетыСДепонентамиОрганизаций.Сумма,
   ВзаиморасчетыСДепонентамиОрганизаций.Ведомость.СпособВыплаты,
   ВзаиморасчетыСДепонентамиОрганизаций.Регистратор
ИЗ
   РегистрНакопления.ВзаиморасчетыСДепонентамиОрганизаций КАК ВзаиморасчетыСДепонентамиОрганизаций
ГДЕ
   ВзаиморасчетыСДепонентамиОрганизаций.Организация = &Организация
   И ВзаиморасчетыСДепонентамиОрганизаций.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Расход)
   И ВзаиморасчетыСДепонентамиОрганизаций.Период МЕЖДУ &НачалоПериода И КОНЕЦПЕРИОДА(&КонецПериода, ДЕНЬ)

СГРУППИРОВАТЬ ПО
   ВзаиморасчетыСДепонентамиОрганизаций.Ведомость,
   ВзаиморасчетыСДепонентамиОрганизаций.Сумма,
   ВзаиморасчетыСДепонентамиОрганизаций.Ведомость.СпособВыплаты,
   ВзаиморасчетыСДепонентамиОрганизаций.Регистратор,
   ВзаиморасчетыСДепонентамиОрганизаций.Период
ИТОГИ
   СУММА(СуммаВзаиморасчетов)
ПО
   ОБЩИЕ

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Ну если нельзя в запросе посчитать итог за день, может тогда как-нибудь можно это сделать при выводе в макет (код в первом логе)? Подскажите, пожалуйста.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4292
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5551
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5888
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4366
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1978
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 194
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal