Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2019, 09:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите найти ошибку  (Прочитано 8103 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Есть следующий код. Почему выводится только шапка и все?

Процедура Кнопка1Нажатие(Элемент)
   
   СформироватьТЗ();
   
   ТабДокумент = Новый ТабличныйДокумент;
   
   Макет = ПолучитьМакет("Макет");
   ОбластьШапка = Макет.ПолучитьОбласть("Шапка");   
   ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
   ОбластьСтрока2 = Макет.ПолучитьОбласть("Строка2");
      
   ТабДокумент.Вывести(ОбластьШапка);

   
   Если ТЗ.Количество() > 0 Тогда  //Построчный обход ТЗ
      
      Для Счетчик = 0 По (ТЗ.Количество()-1) Цикл            
         СтрокаТЗ = ТЗ.Получить(Счетчик);
            
         Если СтрокаТЗ.СпособВыплаты = "Через кассу" Тогда
                 ОбластьСтрока2.Параметры.Период = СтрокаТЗ.Период;
              ОбластьСтрока2.Параметры.Ведомость = СтрокаТЗ.Ведомость;
              ОбластьСтрока2.Параметры.СуммаВзаиморасчетов = СтрокаТЗ.СуммаВзаиморасчетов;
              ОбластьСтрока2.Параметры.Регистратор = СтрокаТЗ.Регистратор;
              ТабДокумент.Вывести(ОбластьСтрока2);

      
          ИначеЕсли СтрокаТЗ.СпособВыплаты = "Через банк" Тогда                                      
                  ОбластьСтрока.Параметры.Период = СтрокаТЗ.Период;
                    ОбластьСтрока.Параметры.Ведомость = СтрокаТЗ.Ведомость;
                    ОбластьСтрока.Параметры.СуммаВзаиморасчетов = СтрокаТЗ.СуммаВзаиморасчетов;
                    ОбластьСтрока.Параметры.Регистратор = СтрокаТЗ.Регистратор;
                    ТабДокумент.Вывести(ОбластьСтрока);
          КонецЕсли;
 
      КонецЦикла;
   
   КонецЕсли;   


     ТабДокумент.Показать(Макет);

   
КонецПроцедуры



Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
В ваш цикл программа входит?

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
В цикл входит. Не входит в Если и ИначеЕсли,хотя условие выполняется.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
А способ выплаты это у вас точно строка?

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Тип: ПеречислениеСсылка.СпособыВыплатыЗарплаты

Оффлайн Vit1501

  • ****
  • Сообщений: 392
  • РЕПУТАЦИЯ: 65
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
вот тогда так и пиши :
Если СтрокаТЗ.СпособВыплаты = ПеречислениеСсылка.СпособыВыплатыЗарплаты.ЧерезКассу Тогда

Оффлайн Vit1501

  • ****
  • Сообщений: 392
  • РЕПУТАЦИЯ: 65
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
точенее
Если СтрокаТЗ.СпособВыплаты = Перечисления.СпособыВыплатыЗарплаты.ЧерезКассу Тогда

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Спасибо)

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
А как сделать, чтобы в этом запросе считалась СуммаВзаиморасчетов по дням?

ВЫБРАТЬ
   ВзаиморасчетыСРаботникамиОрганизаций.Период КАК Период,
   ВзаиморасчетыСРаботникамиОрганизаций.Ведомость,
   СУММА(ВзаиморасчетыСРаботникамиОрганизаций.СуммаВзаиморасчетов) КАК СуммаВзаиморасчетов,
   ВзаиморасчетыСРаботникамиОрганизаций.СпособВыплаты,
   ВзаиморасчетыСРаботникамиОрганизаций.Регистратор
ИЗ
   РегистрНакопления.ВзаиморасчетыСРаботникамиОрганизаций КАК ВзаиморасчетыСРаботникамиОрганизаций
ГДЕ
   ВзаиморасчетыСРаботникамиОрганизаций.Организация = &Организация
   И ВзаиморасчетыСРаботникамиОрганизаций.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Расход)
   И ВзаиморасчетыСРаботникамиОрганизаций.Период МЕЖДУ &НачалоПериода И КОНЕЦПЕРИОДА(&КонецПериода, ДЕНЬ)

СГРУППИРОВАТЬ ПО
   ВзаиморасчетыСРаботникамиОрганизаций.Ведомость,
   ВзаиморасчетыСРаботникамиОрганизаций.СпособВыплаты,
   ВзаиморасчетыСРаботникамиОрганизаций.Регистратор,
   ВзаиморасчетыСРаботникамиОрганизаций.Период

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
   ВзаиморасчетыСДепонентамиОрганизаций.Период,
   ВзаиморасчетыСДепонентамиОрганизаций.Ведомость,
   ВзаиморасчетыСДепонентамиОрганизаций.Сумма,
   ВзаиморасчетыСДепонентамиОрганизаций.Ведомость.СпособВыплаты,
   ВзаиморасчетыСДепонентамиОрганизаций.Регистратор
ИЗ
   РегистрНакопления.ВзаиморасчетыСДепонентамиОрганизаций КАК ВзаиморасчетыСДепонентамиОрганизаций
ГДЕ
   ВзаиморасчетыСДепонентамиОрганизаций.Организация = &Организация
   И ВзаиморасчетыСДепонентамиОрганизаций.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Расход)
   И ВзаиморасчетыСДепонентамиОрганизаций.Период МЕЖДУ &НачалоПериода И КОНЕЦПЕРИОДА(&КонецПериода, ДЕНЬ)

СГРУППИРОВАТЬ ПО
   ВзаиморасчетыСДепонентамиОрганизаций.Ведомость,
   ВзаиморасчетыСДепонентамиОрганизаций.Сумма,
   ВзаиморасчетыСДепонентамиОрганизаций.Ведомость.СпособВыплаты,
   ВзаиморасчетыСДепонентамиОрганизаций.Регистратор,
   ВзаиморасчетыСДепонентамиОрганизаций.Период
ИТОГИ
   СУММА(СуммаВзаиморасчетов)
ПО
   ОБЩИЕ

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Ну если нельзя в запросе посчитать итог за день, может тогда как-нибудь можно это сделать при выводе в макет (код в первом логе)? Подскажите, пожалуйста.


Теги:
 

Помогите выразить код Объект.Наименование = Объект.Подразделение + " " + Объект.Должность + " " + Объект.ФизическоеЛицо через строки.

Автор LedgikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 244
Последний ответ 05 Мар 2019, 19:28
от Ledgik
Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5257
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите правильно настроить справочник "Единицы измерения" и "Номенклатура"

Автор perminovandrРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 361
Последний ответ 23 Янв 2019, 07:21
от Геннадий ОбьГЭС
На фото демонстрируется личная карточка сотрудника, но во столбце "ЗА ЯКИЙ ПЕРІОД " не показывает ничего, как это можно решить, помогите пожалуйста

Автор cBeginnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 603
Последний ответ 26 Июл 2018, 17:44
от alex0402
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6478
Последний ответ 07 Сен 2010, 12:01
от mohock

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
61 Сообщений
Yamuna
50 Сообщений
LexaK
43 Сообщений
MuI_I_Ika MuI_I_Ika
28 Сообщений
alexandr_ll
21 Сообщений
wise wise
19 Сообщений
AIFrame AIFrame
18 Сообщений
alex0402 alex0402
13 Сообщений
lmlg114@bk.ru
13 Сообщений
Eugeneer Eugeneer
12 Сообщений

* Кто онлайн

  • Точка Гостей: 202
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal