Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июл 2021, 10:52

помогите найти ошибку

Автор Люсёк, 22 ноя 2010, 11:13

0 Пользователей и 1 гость просматривают эту тему.

Люсёк

Есть следующий код. Почему выводится только шапка и все?

Процедура Кнопка1Нажатие(Элемент)
   
   СформироватьТЗ();
   
   ТабДокумент = Новый ТабличныйДокумент;
   
   Макет = ПолучитьМакет("Макет");
   ОбластьШапка = Макет.ПолучитьОбласть("Шапка");   
   ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
   ОбластьСтрока2 = Макет.ПолучитьОбласть("Строка2");
      
   ТабДокумент.Вывести(ОбластьШапка);

   
   Если ТЗ.Количество() > 0 Тогда  //Построчный обход ТЗ
      
      Для Счетчик = 0 По (ТЗ.Количество()-1) Цикл            
         СтрокаТЗ = ТЗ.Получить(Счетчик);
            
         Если СтрокаТЗ.СпособВыплаты = "Через кассу" Тогда
                 ОбластьСтрока2.Параметры.Период = СтрокаТЗ.Период;
              ОбластьСтрока2.Параметры.Ведомость = СтрокаТЗ.Ведомость;
              ОбластьСтрока2.Параметры.СуммаВзаиморасчетов = СтрокаТЗ.СуммаВзаиморасчетов;
              ОбластьСтрока2.Параметры.Регистратор = СтрокаТЗ.Регистратор;
              ТабДокумент.Вывести(ОбластьСтрока2);

      
          ИначеЕсли СтрокаТЗ.СпособВыплаты = "Через банк" Тогда                                      
                  ОбластьСтрока.Параметры.Период = СтрокаТЗ.Период;
                    ОбластьСтрока.Параметры.Ведомость = СтрокаТЗ.Ведомость;
                    ОбластьСтрока.Параметры.СуммаВзаиморасчетов = СтрокаТЗ.СуммаВзаиморасчетов;
                    ОбластьСтрока.Параметры.Регистратор = СтрокаТЗ.Регистратор;
                    ТабДокумент.Вывести(ОбластьСтрока);
          КонецЕсли;

      КонецЦикла;
   
   КонецЕсли;   


     ТабДокумент.Показать(Макет);

   
КонецПроцедуры


progmikon

В ваш цикл программа входит?

Люсёк

В цикл входит. Не входит в Если и ИначеЕсли,хотя условие выполняется.

progmikon

А способ выплаты это у вас точно строка?

Люсёк

Тип: ПеречислениеСсылка.СпособыВыплатыЗарплаты

Vit1501

вот тогда так и пиши :
Если СтрокаТЗ.СпособВыплаты = ПеречислениеСсылка.СпособыВыплатыЗарплаты.ЧерезКассу Тогда

Vit1501

точенее
Если СтрокаТЗ.СпособВыплаты = Перечисления.СпособыВыплатыЗарплаты.ЧерезКассу Тогда

Люсёк


Люсёк

А как сделать, чтобы в этом запросе считалась СуммаВзаиморасчетов по дням?

ВЫБРАТЬ
   ВзаиморасчетыСРаботникамиОрганизаций.Период КАК Период,
   ВзаиморасчетыСРаботникамиОрганизаций.Ведомость,
   СУММА(ВзаиморасчетыСРаботникамиОрганизаций.СуммаВзаиморасчетов) КАК СуммаВзаиморасчетов,
   ВзаиморасчетыСРаботникамиОрганизаций.СпособВыплаты,
   ВзаиморасчетыСРаботникамиОрганизаций.Регистратор
ИЗ
   РегистрНакопления.ВзаиморасчетыСРаботникамиОрганизаций КАК ВзаиморасчетыСРаботникамиОрганизаций
ГДЕ
   ВзаиморасчетыСРаботникамиОрганизаций.Организация = &Организация
   И ВзаиморасчетыСРаботникамиОрганизаций.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Расход)
   И ВзаиморасчетыСРаботникамиОрганизаций.Период МЕЖДУ &НачалоПериода И КОНЕЦПЕРИОДА(&КонецПериода, ДЕНЬ)

СГРУППИРОВАТЬ ПО
   ВзаиморасчетыСРаботникамиОрганизаций.Ведомость,
   ВзаиморасчетыСРаботникамиОрганизаций.СпособВыплаты,
   ВзаиморасчетыСРаботникамиОрганизаций.Регистратор,
   ВзаиморасчетыСРаботникамиОрганизаций.Период

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
   ВзаиморасчетыСДепонентамиОрганизаций.Период,
   ВзаиморасчетыСДепонентамиОрганизаций.Ведомость,
   ВзаиморасчетыСДепонентамиОрганизаций.Сумма,
   ВзаиморасчетыСДепонентамиОрганизаций.Ведомость.СпособВыплаты,
   ВзаиморасчетыСДепонентамиОрганизаций.Регистратор
ИЗ
   РегистрНакопления.ВзаиморасчетыСДепонентамиОрганизаций КАК ВзаиморасчетыСДепонентамиОрганизаций
ГДЕ
   ВзаиморасчетыСДепонентамиОрганизаций.Организация = &Организация
   И ВзаиморасчетыСДепонентамиОрганизаций.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Расход)
   И ВзаиморасчетыСДепонентамиОрганизаций.Период МЕЖДУ &НачалоПериода И КОНЕЦПЕРИОДА(&КонецПериода, ДЕНЬ)

СГРУППИРОВАТЬ ПО
   ВзаиморасчетыСДепонентамиОрганизаций.Ведомость,
   ВзаиморасчетыСДепонентамиОрганизаций.Сумма,
   ВзаиморасчетыСДепонентамиОрганизаций.Ведомость.СпособВыплаты,
   ВзаиморасчетыСДепонентамиОрганизаций.Регистратор,
   ВзаиморасчетыСДепонентамиОрганизаций.Период
ИТОГИ
   СУММА(СуммаВзаиморасчетов)
ПО
   ОБЩИЕ

Люсёк

Ну если нельзя в запросе посчитать итог за день, может тогда как-нибудь можно это сделать при выводе в макет (код в первом логе)? Подскажите, пожалуйста.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск