Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2019, 15:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите разобраться с кодом!!!!  (Прочитано 2143 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн glenchikm

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-09
  • Сайт: 
Есть код, данный код расположен в модуле формы. Это опциональная аналитика. Вот не совсем могу разобраться что там написано!!! С запросом понятно, а вот начиная с ПОПЫТКА как-то не очень понятно.... или может быть кто-нибудь объяснит хоть как работает попытка.....Пожалуйста!!!!

&НаСервере
Процедура ПриИзмененииУчетаПоПреподавателям(УчетПоПреподавателям)

   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   Бухгалтерский.Ссылка,
      |   Бухгалтерский.Наименование
      |ИЗ
      |   ПланСчетов.Бухгалтерский КАК Бухгалтерский
      |ГДЕ
      |   (НЕ Бухгалтерский.ПометкаУдаления)
      |   И (НЕ Бухгалтерский.Забалансовый)
      |   И (&УчетПоПреподавателям
      |         ИЛИ Бухгалтерский.ВидыСубконто.ВидСубконто = ЗНАЧЕНИЕ(ПланВидовХарактеристик.ВидыСубконто.Преподаватели))
      |   И Бухгалтерский.ВидыСубконто.ВидСубконто = ЗНАЧЕНИЕ(ПланВидовХарактеристик.ВидыСубконто.Курсы)";

   Запрос.УстановитьПараметр("УчетПоПреподавателям", УчетПоПреподавателям);

   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл //обход результата эт понятно
      СчетСсылка = ВыборкаДетальныеЗаписи.Ссылка;   
      Попытка
         ЗаблокироватьДанныеДляРедактирования(СчетСсылка);
         СчетОбъект = СчетСсылка.ПолучитьОбъект();
         ВидыСубконтоСчета = СчетОбъект.ВидыСубконто;
         
         СубконтоПреподаватель =
                  ВидыСубконтоСчета.Найти(ПланыВидовХарактеристик.ВидыСубконто.Преподаватели);
         Если СубконтоПреподаватель = Неопределено И ВидыСубконтоСчета.Количество() < 2 Тогда
            //включаем         
            НовоеСубконто = ВидыСубконтоСчета.Добавить();
            НовоеСубконто.ВидСубконто = ПланыВидовХарактеристик.ВидыСубконто.Преподаватели;
         ИначеЕсли НЕ УчетПоПреподавателям Тогда
            //исключаем
            Если НЕ СубконтоПреподаватель.Предопределенное Тогда
               ВидыСубконтоСчета.Удалить(СубконтоПреподаватель);
            КонецЕсли;   
         КонецЕсли;   
         СчетОбъект.Записать();
         
      Исключение
         Сообщение = Новый СообщениеПользователю;
         Сообщение.Текст = "Не удалось записать счет "
                                       + ВыборкаДетальныеЗаписи.Наименование;
         Сообщение.Сообщить();                              
      КонецПопытки;   
   КонецЦикла;

КонецПроцедуры   


Оффлайн Tatitutu

а что тебя смущает ?
Попытка
//программа пытается выполнить какое то действие
Исключение
//это то что происходит если не получается у нее

если бы не было этой конструкции
то код вываливался бы у тебя с ошибкой , объект заблокирован или возникали бы какие либо коллизии

*  MAGAZKA - лучшая программа для розничного магазина (с) *


Теги:
 

Помогите выразить код Объект.Наименование = Объект.Подразделение + " " + Объект.Должность + " " + Объект.ФизическоеЛицо через строки.

Автор LedgikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 222
Последний ответ 05 Мар 2019, 19:28
от Ledgik
Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5235
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите правильно настроить справочник "Единицы измерения" и "Номенклатура"

Автор perminovandrРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 326
Последний ответ 23 Янв 2019, 07:21
от Геннадий ОбьГЭС
На фото демонстрируется личная карточка сотрудника, но во столбце "ЗА ЯКИЙ ПЕРІОД " не показывает ничего, как это можно решить, помогите пожалуйста

Автор cBeginnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 567
Последний ответ 26 Июл 2018, 17:44
от alex0402
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6451
Последний ответ 07 Сен 2010, 12:01
от mohock

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
34 Сообщений
wise wise
31 Сообщений
AIFrame AIFrame
31 Сообщений
alexandr_ll
30 Сообщений
DmitriyF DmitriyF
12 Сообщений
SGIRG SGIRG
12 Сообщений
vova-1c@xaker.ru
11 Сообщений
Shohana
11 Сообщений
Мария112689
10 Сообщений
kiksi
9 Сообщений

* Кто онлайн

  • Точка Гостей: 292
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal