Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 22:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите разобраться с кодом!!!!  (Прочитано 1849 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн glenchikm

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-09
  • Сайт: 
Есть код, данный код расположен в модуле формы. Это опциональная аналитика. Вот не совсем могу разобраться что там написано!!! С запросом понятно, а вот начиная с ПОПЫТКА как-то не очень понятно.... или может быть кто-нибудь объяснит хоть как работает попытка.....Пожалуйста!!!!

&НаСервере
Процедура ПриИзмененииУчетаПоПреподавателям(УчетПоПреподавателям)

   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   Бухгалтерский.Ссылка,
      |   Бухгалтерский.Наименование
      |ИЗ
      |   ПланСчетов.Бухгалтерский КАК Бухгалтерский
      |ГДЕ
      |   (НЕ Бухгалтерский.ПометкаУдаления)
      |   И (НЕ Бухгалтерский.Забалансовый)
      |   И (&УчетПоПреподавателям
      |         ИЛИ Бухгалтерский.ВидыСубконто.ВидСубконто = ЗНАЧЕНИЕ(ПланВидовХарактеристик.ВидыСубконто.Преподаватели))
      |   И Бухгалтерский.ВидыСубконто.ВидСубконто = ЗНАЧЕНИЕ(ПланВидовХарактеристик.ВидыСубконто.Курсы)";

   Запрос.УстановитьПараметр("УчетПоПреподавателям", УчетПоПреподавателям);

   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл //обход результата эт понятно
      СчетСсылка = ВыборкаДетальныеЗаписи.Ссылка;   
      Попытка
         ЗаблокироватьДанныеДляРедактирования(СчетСсылка);
         СчетОбъект = СчетСсылка.ПолучитьОбъект();
         ВидыСубконтоСчета = СчетОбъект.ВидыСубконто;
         
         СубконтоПреподаватель =
                  ВидыСубконтоСчета.Найти(ПланыВидовХарактеристик.ВидыСубконто.Преподаватели);
         Если СубконтоПреподаватель = Неопределено И ВидыСубконтоСчета.Количество() < 2 Тогда
            //включаем         
            НовоеСубконто = ВидыСубконтоСчета.Добавить();
            НовоеСубконто.ВидСубконто = ПланыВидовХарактеристик.ВидыСубконто.Преподаватели;
         ИначеЕсли НЕ УчетПоПреподавателям Тогда
            //исключаем
            Если НЕ СубконтоПреподаватель.Предопределенное Тогда
               ВидыСубконтоСчета.Удалить(СубконтоПреподаватель);
            КонецЕсли;   
         КонецЕсли;   
         СчетОбъект.Записать();
         
      Исключение
         Сообщение = Новый СообщениеПользователю;
         Сообщение.Текст = "Не удалось записать счет "
                                       + ВыборкаДетальныеЗаписи.Наименование;
         Сообщение.Сообщить();                              
      КонецПопытки;   
   КонецЦикла;

КонецПроцедуры   


Оффлайн Tatitutu

а что тебя смущает ?
Попытка
//программа пытается выполнить какое то действие
Исключение
//это то что происходит если не получается у нее

если бы не было этой конструкции
то код вываливался бы у тебя с ошибкой , объект заблокирован или возникали бы какие либо коллизии

*  MAGAZKA - лучшая программа для розничного магазина (с) *


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4304
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5561
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5901
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4389
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1986
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 291
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal