Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 18:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ПолучитьИдентификаторы  (Прочитано 1056 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cwiki

  • Модератор
  • *****
  • Сообщений: 8287
  • РЕПУТАЦИЯ: 12
  • КПД: 0%
  • Регистрация: 2014-08-05
  • Сайт: 
  • Профессия: Программист 8.1
Раздел:
Общие объекты
Подразделы:
Интернет
ИмяОбъекта:
ИнтернетПочта
ПодвидОбъекта:
ИнтернетПочта
ТипСтатьи:
Методы
ИнтернетПочта.ПолучитьИдентификаторы (InternetMail.GetUIDL)
ИнтернетПочта (InternetMail)
ПолучитьИдентификаторы (GetUIDL)
Синтаксис:
ПолучитьИдентификаторы(<МассивИдентификаторов>, <ПараметрыОтбора>)
Параметры:
<МассивИдентификаторов> (необязательный)
Тип: Массив.
Для получения всех идентификаторов сообщений из почтового ящика необходимо передать пустой массив. Если же надо получить идентификаторы только новых сообщений, то необходимо передать массив, заполненный ранее полученными идентификаторами (свойство Идентификатор).
<ПараметрыОтбора> (необязательный)
Тип: Структура.
В качестве ключей структуры используются названия свойств письма, по которым осуществляется отбор.
Значения могут быть выражения следующих типов: Строка, Дата, Число, Булево.
Тип значения определяется ключом. Например, если требуется отобрать письма до определённой даты, то в качестве значения необходимо использовать выражения типа Дата.
Если в качестве значения используется строка, то регистр не имеет значения.
Если заданы несколько ключей, то они применяются последовательно по логическому И.
ОтправленОтвет (Answered) - Булево. Отобрать сообщения, у которых установлен флаг – Answered;
Недавние (Recent) - Булево. Отобрать сообщения, пришедшие в рамках текущей IMAP-сессии.
СлепыеКопии (Bcc) - Строка. Отобрать сообщения, которые имеют “строка” в поле Bcc;
Копии (Cc) - Строка. Отобрать сообщения, которые имеют “строка” в поле Cc;
Получатели (To) - Строка. Отобрать сообщения, которые имеют “строка” в поле To;
ДатаОтправления (PostDating) - Дата. Отобрать сообщения, у которых значение поле Date: равно “Дата”;
Отправитель (From) - Строка. Отобрать все сообщения у которых встречается “строка”в поле From;
ДоДатыОтправления (BeforeDateOfPosting) - Дата. Отобрать сообщения, у которых значение поле Date: перед “дата”;
ПослеДатыОтправления (AfterDateOfPosting) - Дата. Отобрать сообщения, у которых значение поля Date: после значения “Дата”;
Тема (Subject) - Строка. Отобрать сообщения, в заголовке которых встречается заданная строка;
Текст (Text) - Строка. Отобрать сообщения, в любых текстовых полях которого встречается заданная строка;
ТелоСообщения (Body) - Строка. Отобрать сообщения, в теле которых встречается строка – “строка”;
Удаленные (Deleted) - Булево. Отобрать сообщения, которые должны быть удалены или не должны быть удалены;
УстановленФлаг (Flagged) - Булево. Отобрать сообщения, которые помечены флагом или не помечены флагом;
Прочитанные (Seen) - Булево. Отобрать сообщения, которые были прочитаны или не прочитаны;
Новые (New) - Булево. Отобрать новые или старые сообщения.
Пример:
ПараметрыОтбораIMAP = Новый Структура;
ПараметрыОтбораIMAP.Вставить("Новые", Истина);
ПараметрыОтбораIMAP.Вставить("Тема", "привет");
Почта.ПолучитьЗаголовки(ПараметрыОтбораIMAP);



Строковые значения критериев отбора отправляются в кодировке US-ASCII, если содержат только символы ANSI и в кодировке UTF-8 - в противном случае. Не все IMAP-серверы поддерживают UTF-8, поэтому сервер может выдать соответствующую ошибку.
Возвращаемое значение:
Тип: Массив.

Описание:
Возвращает массив, содержащий идентификаторы всех или новых сообщений, находящихся в почтовом ящике на сервере.
Внимание! Фильтрация заголовков работает только при работе по протоколу IMAP. При работе по протоколу POP3 отбор писем не выполняется - метод вернет полный массив сообщений, даже если установлены ПараметрыОтбора.

Доступность:
Тонкий клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).
Примечание:
Для IMAP протокола идентификаторы будут выбраны из IMAP почтового ящика (ТекущийПочтовыйЯщик).
Пример:
Профиль = Новый ИнтернетПочтовыйПрофиль;
ЗаполнитьПрофиль(Профиль);

Почта = Новый ИнтернетПочта;
Почта.Подключиться(Профиль);

ИДы = Новый Массив;
// Восстановим ранее сохраненные идентификаторы
ВосЗнач = ВосстановитьЗначение("ИДы");
Если ВосЗнач <> Неопределено Тогда
    ИДы = ВосЗнач
КонецЕсли;
   
// Получим идентификаторы новых сообщений
НовыеСооб = Почта.ПолучитьИдентификаторы(ИДы);

Если НовыеСооб.Количество() > 0 Тогда
   
    // Получим только новые сообщения
    Масс = Почта.Выбрать(Ложь, НовыеСооб);
   
Иначе
   
    Сообщить("Новых сообщений нет");
    Почта.Отключиться();
    Возврат;
   
КонецЕсли;       

Для Каждого Письмо Из Масс Цикл
   
    // Сохраним идентификатор полученного
    // сообщения для дальнейшего использования
    ИДы.Добавить(Письмо.Идентификатор[0]);
    Сообщить(Письмо.Идентификатор[0]);
   
    // ...
   
КонецЦикла;

СохранитьЗначение("ИДы", ИДы);

Почта.Отключиться();


См. также:
ИнтернетПочтовоеСообщение, свойство Идентификатор



     


Теги:
 


* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 480
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal