Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 15:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ОбъединитьЧастичные  (Прочитано 339 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cwiki

  • Модератор
  • *****
  • Сообщений: 8287
  • РЕПУТАЦИЯ: 14
  • КПД: 0%
  • Регистрация: 2014-08-05
  • Сайт: 
  • Профессия: Программист 8.1
Раздел:
Общие объекты
Подразделы:
Интернет
ИмяОбъекта:
ИнтернетПочта
ПодвидОбъекта:
ИнтернетПочта
ТипСтатьи:
Методы
ИнтернетПочта.ОбъединитьЧастичные (InternetMail.CombinePartial)
ИнтернетПочта (InternetMail)
ОбъединитьЧастичные (CombinePartial)
Синтаксис:
ОбъединитьЧастичные(<МассивСообщений>)
Параметры:
<МассивСообщений> (обязательный)
Тип: Массив.
Массив, содержащий частичные сообщения для объединения.
Возвращаемое значение:
Тип: Массив.
Массив объектов типа ИнтернетПочтовоеСообщение.
Описание:
Объединяет частичные сообщения. Если в переданном массиве находятся не все части, то сообщение не объединяется. В передаваемом массиве могут находится части нескольких сообщений. После объединения они возвратятся в массиве. У каждого объединенного сообщения свойство Идентификатор будет содержать несколько значений, соответствующих взятым из частичных сообщений при объединении.

Доступность:
Тонкий клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).
Пример:
Профиль = Новый ИнтернетПочтовыйПрофиль;
ЗаполнитьПрофиль(Профиль);

Почта = Новый ИнтернетПочта;
Почта.Подключиться(Профиль);

Масс = Почта.Выбрать(Ложь);

МассЧ = Новый Массив;
Для Ин = 0 По Масс.Количество() - 1 Цикл
   
    Если Масс[Ин].Частичное Тогда
       
        МассЧ.Добавить(Масс[Ин]);
       
    КонецЕсли;
       
КонецЦикла;

Сообщения = Почта.ОбъединитьЧастичные(МассЧ);
Сообщить(" **************************************** ");
Для Инд = 0 По Сообщения.Количество() - 1 Цикл
   
    Для Каждого Идентификатор Из Сообщения[Инд].Идентификатор Цикл
        Сообщить("Серверный идентификатор " + Строка(Инд) + ": " + Идентификатор);
    КонецЦикла;
   
КонецЦикла;

Почта.Отключиться();


См. также:
ИнтернетПочтовоеСообщение, свойство Частичное



     


Теги:
 


* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
alex0402
75 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
43 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
Alter
32 Сообщений

* Кто онлайн

  • Точка Гостей: 631
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal