Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Апр 2019, 23:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Колонка с долгом в списке документов "Реализация товаров и услуг" в УТ 8.1  (Прочитано 2698 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн benoev

  • ***
  • Сообщений: 158
  • РЕПУТАЦИЯ: 8
  • КПД: 5%
  • Регистрация: 2010-10-05
  • Сайт: 
  • Профессия: Бухгалтер
Люди кто-нибудь помогите, в конфигурации Уравление торговлей 8.1 мне нужно вывести колонку с долгом по документу в список документов "Реализация товаров и услуг", может у кого нибудь есть уже готовая исправленная форма списка, может скините.
Заранее спасибо!  :mellow:


Оффлайн Lexius

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 16
  • КПД: 44%
  • Регистрация: 2010-11-10
  • Сайт: 
Событие формы списка "ПриПолученииДанных()" с запросом по долгам контрагентов тебе в помощь.

Оффлайн benoev

  • ***
  • Сообщений: 158
  • РЕПУТАЦИЯ: 8
  • КПД: 5%
  • Регистрация: 2010-10-05
  • Сайт: 
  • Профессия: Бухгалтер

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
На форме списка добавляем новую колонку. Имя - НОВАЯКОЛОНКА. ЭлементУправления - ПолеВвода
Запрос по долгу - я писать не буду.
Процедура СправочникСписокПриПолученииДанных(Элемент, ОформленияСтрок)
 Для Каждого Строка Из ОформленияСтрок Цикл
  Если НЕ Строка.ДанныеСтроки.Комментарий = "1" Тогда
   Строка.Ячейки.НОВАЯКОЛОНКА.УстановитьТекст("215,52");
  Иначе
   Строка.Ячейки.НОВАЯКОЛОНКА.УстановитьТекст("0");
  КонецЕсли;
 КонецЦикла
КонецПроцедуры

Если есть вопросы - задавайте, не стесняйтесь :)


Теги:
 

В 1с предприятие 8.3 управление торговлей 11.1 как изменить цену на несколько товаров с одним и тем же артиклем на последнюю введенную цену с помощью загрузки обработки или как это сделать в 1с с помощью программирования? прилагаю полный текст обработки

Автор сергей123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 137
Последний ответ 11 Фев 2019, 15:15
от сергей123
при загрузке цен в 1с предприятие управление торговлей 11.1 возникают дубли товаров разной цены, т.e. новый товар при загрузке не суммируется с уже загруженным. как можно объединять при загрузке товары с последней загруженной ценой товара? Есть ли такая о

Автор сергей123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 160
Последний ответ 06 Фев 2019, 15:56
от antoneus
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 882
Последний ответ 14 Ноя 2017, 10:43
от oleg-x
Отсутствие документов помеченных на удаление в обработке удаления помеченных

Автор ak47Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3165
Последний ответ 06 Июн 2013, 11:47
от Совёнок
Ввод разных документов на основании разных табличных частей

Автор Andrio48Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2045
Последний ответ 14 Апр 2014, 17:09
от Andrio48

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
89 Сообщений
AIFrame AIFrame
46 Сообщений
alexandr_ll
40 Сообщений
alex0402
30 Сообщений
wise wise
19 Сообщений
BuhRust
15 Сообщений
byte777
14 Сообщений
LexaK
14 Сообщений
pavl_vs
13 Сообщений
Weidermail
13 Сообщений

* Кто онлайн

  • Точка Гостей: 244
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal