Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Ноя 2018, 05:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Колонка с долгом в списке документов "Реализация товаров и услуг" в УТ 8.1  (Прочитано 2584 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн benoev

  • ***
  • Сообщений: 158
  • РЕПУТАЦИЯ: 8
  • КПД: 5%
  • Регистрация: 2010-10-05
  • Сайт: 
  • Профессия: Бухгалтер
Люди кто-нибудь помогите, в конфигурации Уравление торговлей 8.1 мне нужно вывести колонку с долгом по документу в список документов "Реализация товаров и услуг", может у кого нибудь есть уже готовая исправленная форма списка, может скините.
Заранее спасибо!  :mellow:


Оффлайн Lexius

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 16
  • КПД: 44%
  • Регистрация: 2010-11-10
  • Сайт: 
Событие формы списка "ПриПолученииДанных()" с запросом по долгам контрагентов тебе в помощь.

Оффлайн benoev

  • ***
  • Сообщений: 158
  • РЕПУТАЦИЯ: 8
  • КПД: 5%
  • Регистрация: 2010-10-05
  • Сайт: 
  • Профессия: Бухгалтер

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
На форме списка добавляем новую колонку. Имя - НОВАЯКОЛОНКА. ЭлементУправления - ПолеВвода
Запрос по долгу - я писать не буду.
Процедура СправочникСписокПриПолученииДанных(Элемент, ОформленияСтрок)
 Для Каждого Строка Из ОформленияСтрок Цикл
  Если НЕ Строка.ДанныеСтроки.Комментарий = "1" Тогда
   Строка.Ячейки.НОВАЯКОЛОНКА.УстановитьТекст("215,52");
  Иначе
   Строка.Ячейки.НОВАЯКОЛОНКА.УстановитьТекст("0");
  КонецЕсли;
 КонецЦикла
КонецПроцедуры

Если есть вопросы - задавайте, не стесняйтесь :)


Теги:
 

готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 675
Последний ответ 14 Ноя 2017, 10:43
от oleg-x
Отсутствие документов помеченных на удаление в обработке удаления помеченных

Автор ak47Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3012
Последний ответ 06 Июн 2013, 11:47
от Совёнок
Ввод разных документов на основании разных табличных частей

Автор Andrio48Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1943
Последний ответ 14 Апр 2014, 17:09
от Andrio48
Автоматизация удаления модулей документов и модулей обычных форм.

Автор VorkosiganРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1153
Последний ответ 19 Фев 2016, 17:17
от Vorkosigan
можно ли в журнале документов создать каталог и в определённый каталог записывать нужные документы

Автор Андрей СобольРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1554
Последний ответ 01 Сен 2016, 07:52
от Vladimir_Sh

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
64 Сообщений
wise wise
58 Сообщений
AIFrame AIFrame
50 Сообщений
alexandr_ll
46 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
43 Сообщений
alex0402
41 Сообщений
LexaK
32 Сообщений
BuhRust
28 Сообщений
andron81_81
24 Сообщений
MuI_I_Ika MuI_I_Ika
22 Сообщений

* Кто онлайн

  • Точка Гостей: 212
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal