Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Сен 2020, 02:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Документ поступления  (Прочитано 2402 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 

Процедура Печать(Элемент)
   //{{_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ(Печать)
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   ТабДок = Новый ТабличныйДокумент;
   Макет = Документы.Поступление.ПолучитьМакет("Печать");
   // Заголовок
   Область = Макет.ПолучитьОбласть("Заголовок");
   ТабДок.Вывести(Область);
   // Шапка
   Шапка = Макет.ПолучитьОбласть("Шапка");
   Шапка.Параметры.Заполнить(ЭтотОбъект);
   ТабДок.Вывести(Шапка);
   // Список
   Область = Макет.ПолучитьОбласть("СписокШапка");
   ТабДок.Вывести(Область);
   ОбластьСписок = Макет.ПолучитьОбласть("Список");
   Для Каждого ТекСтрокаСписок Из Список Цикл
      ОбластьСписок.Параметры.Заполнить(ТекСтрокаСписок);
      ТабДок.Вывести(ОбластьСписок);
   КонецЦикла;

   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Ложь;
   ТабДок.ТолькоПросмотр = Ложь;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать();
   //}}_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ
КонецПроцедуры


Сделал форму печати документа конструктором подскажите что означает вот
тот фрагмент кода.Я так онима заполняется табличная часть
Для Каждого ТекСтрокаСписок Из Список Цикл
      ОбластьСписок.Параметры.Заполнить(ТекСтрокаСписок);
      ТабДок.Вывести(ОбластьСписок);
   КонецЦикла;


Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 

     

ОбластьСписок.Параметры.Заполнить(ТекСтрокаСписок);
Что значит вот эта строка ?

Оффлайн Lexius

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 16
  • КПД: 44%
  • Регистрация: 2010-11-10
  • Сайт: 
Какая именно строка? Их тут несколько.

Оффлайн Lexius

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 16
  • КПД: 44%
  • Регистрация: 2010-11-10
  • Сайт: 
Означает, это то, что если среди параметров области печати "ОбластьСписок" найдутся одноименные параметры структуры "ТекСтрокаСписок", то они будут заполненны из неё.

Допустим у "ОбластьСписок" есть параметры: Товар, Количество, Цена, Сумма.
а у "ТекСтрокаСписок": Товар, Количество и цена.

Чтобы не писать:
 ОбластьСписок.Параметры.Товар = ТекСтрокаСписок.Товар;
 ..... и тд по полям
 есть такой оператор..
 
Его налог системная процедура "ЗаполнитьЗначенияСвойств(<приёмник>, <источник>);

Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 
Спасибо разобрался :)


Теги:
 

не находить контрагента (Выбрать * Из Документ ГДЕ контрагент = "имя контрагента")

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1535
Последний ответ 23 Окт 2017, 23:14
от Ivan94
УТ 10.3 При провеедении реализации выходит ошибка "состояние договора отличается от "договор есть, документы есть", документ подсвечивается серым цветом

Автор MilaZzerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 881
Последний ответ 25 Сен 2018, 13:32
от MilaZzerber
Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 5747
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 15561
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 7769
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
oooo800
39 Сообщений
LexaK
31 Сообщений
Дмитрий Джей Дмитрий Джей
29 Сообщений
IL2016
28 Сообщений
antoneus antoneus
24 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
illiona
10 Сообщений

* Кто онлайн

  • Точка Гостей: 203
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal