Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 12:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Установка PostgreSQL  (Прочитано 7507 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн OldViy

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 1
  • КПД: 50%
  • Регистрация: 2015-08-16
  • Сайт: 
Попытался установить PostgreSQL 9.4 (взятый с сайта 1С) на сервер CentOS 7 (x64)

С первыми тремя пакетами справился с горем пополам:
postgresql94-libs-9.4.2-1.1C.x86_64.rpm                сделал линки и установилось
postgresql94-9.4.2-1.1C.x86_64.rpm
postgresql94-server-9.4.2-1.1C.x86_64.rpm

а вот четвертый пакет никак
postgresql94-contrib-9.4.2-1.1C.x86_64.rpm

....
Ошибка: Пакет: postgresql94-contrib-9.4.2-1.1C.x86_64 (/postgresql94-contrib-9.4.2-1.1C.x86_64)
            Необходимо: libicui18n.so.36()(64bit)
Ошибка: Пакет: postgresql94-contrib-9.4.2-1.1C.x86_64 (/postgresql94-contrib-9.4.2-1.1C.x86_64)
            Необходимо: libicuuc.so.36()(64bit)
.....

причем есть линк с libicui18n.so.50  с именем libicui18n.so.36 в каталоге /usr/lib64  и линк в корне /lib64

кто подскажет решение ?



Оффлайн ordosgreen

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-13
  • Сайт: 
  • Профессия: Программист 1С
Re: Установка PostgreSQL
« Ответ #1: 21 Авг 2015, 09:47 »
у меня другая беда, в упор не видит readline, хотя он установлен, хоть и более свежей 6-й версии. как Вы эту беду победили?

Оффлайн OldViy

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 1
  • КПД: 50%
  • Регистрация: 2015-08-16
  • Сайт: 
Re: Установка PostgreSQL
« Ответ #2: 22 Авг 2015, 15:12 »
ln -s /lib64/libreadline.so.6 /lib64/libreadline.so.5
как то так

Оффлайн PunKHS

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-25
  • Сайт: 
  • Профессия: Ученик 1С
Re: Установка PostgreSQL
« Ответ #3: 25 Авг 2015, 04:34 »
При установке postgresql94-contrib-9.4.2-1.1C.i386.rpm на CentOS 6.7 аналогичная проблема
Необходимо: libicui18n.so.36, libicuuc.so.36

rpm -ql libicu | egrep '(icudata|icui18|icuuc)' возвращает следующее:
/usr/lib/libicudata.so.42
/usr/lib/libicudata.so.42.1
/usr/lib/libicui18n.so.42
/usr/lib/libicui18n.so.42.1
/usr/lib/libicuuc.so.42
/usr/lib/libicuuc.so.42.1

Делал ссылки:
ln -s /usr/lib/libicui18n.so.42.1 /usr/local/lib/libicui18n.so.36
ln -s /usr/lib/libicudata.so.42.1 /usr/local/lib/libicudata.so.36
ln -s /usr/lib/libicuuc.so.42.1 /usr/local/lib/libicuuc.so.36

Результата нет...
Добавлено: 25 Авг 2015, 05:52

Так же пробовал:
ln -s /usr/lib/libicui18n.so.42.1 /lib/libicui18n.so.36
ln -s /usr/lib/libicudata.so.42.1 /lib/libicudata.so.36
ln -s /usr/lib/libicuuc.so.42.1 /lib/libicuuc.so.36
и
ln -s /usr/lib/libicui18n.so.42.1 /usr/lib/libicui18n.so.36
ln -s /usr/lib/libicudata.so.42.1 /usr/lib/libicudata.so.36
ln -s /usr/lib/libicuuc.so.42.1 /usr/lib/libicuuc.so.36
и
ln -s /usr/lib/libicui18n.so.42.1 /usr/pgsql-9.4/lib/libicui18n.so.36
ln -s /usr/lib/libicudata.so.42.1 /usr/pgsql-9.4/lib/libicudata.so.36
ln -s /usr/lib/libicuuc.so.42.1 /usr/pgsql-9.4/lib/libicuuc.so.36

Ошибка сохраняется...

Последний раз редактировалось: PunKHS; 25 Авг 2015, 05:52. Причина: Объединение сообщений

Оффлайн ordosgreen

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-13
  • Сайт: 
  • Профессия: Программист 1С
Re: Установка PostgreSQL
« Ответ #4: 25 Авг 2015, 08:40 »
Была та же беда, и centos 7 и на 6.7, с разрешением зависимости postgresql94-contrib-9.4.2-1.1C.x86_64, не хватало libicui18n.so.36()(64bit), нашел вот тут http://rpmfind.net/linux/rpm2html/search.php?query=libicui18n.so.36()(64bit) ,мне помогло

Оффлайн __guest__

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-03
  • Сайт: 
  • Профессия: Программист 8.1
Re: Установка PostgreSQL
« Ответ #5: 25 Сен 2015, 12:00 »
Была та же беда, и centos 7 и на 6.7, с разрешением зависимости postgresql94-contrib-9.4.2-1.1C.x86_64, не хватало libicui18n.so.36()(64bit), нашел вот тут http://rpmfind.net/linux/rpm2html/search.php?query=libicui18n.so.36()(64bit) ,мне помогло
Доброе время суток. Столкнулся с такой же проблемой. Решения пока не нашел. Перехожу по ссылке что в предыдущем посте - но там этого пакета уже нет.
Поиск в интернете так же не помог (не нашел).
Как можно решить проблему?

Оффлайн vag37

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-09-29
  • Сайт: 
Re: Установка PostgreSQL
« Ответ #6: 29 Сен 2015, 15:40 »
Была та же беда, и centos 7 и на 6.7, с разрешением зависимости postgresql94-contrib-9.4.2-1.1C.x86_64, не хватало libicui18n.so.36()(64bit), нашел вот тут http://rpmfind.net/linux/rpm2html/search.php?query=libicui18n.so.36()(64bit) ,мне помогло
Доброе время суток. Столкнулся с такой же проблемой. Решения пока не нашел. Перехожу по ссылке что в предыдущем посте - но там этого пакета уже нет.
Поиск в интернете так же не помог (не нашел).
Как можно решить проблему?
http://pkgs.org/centos-5/centos-x86_64/libicu-3.6-5.16.1.x86_64.rpm.html я сейчас отсюда скачал, установилась предварительно обругав что уже есть новее из elrepo.
9.4.2 установился, но  обругав про задвоение пакетов
И еще о напрочь не ставятся из addons два пакета
 Package postgresql94-plperl.x86_64 postgresql94-plpython-9.4.2-1.1C.x86_64
С 9.3 вообще проблем не было, установилась ни разу не чирикнув, с 8 сентября  работает с 8.3.2999. Centos 6.4 на виртуалке для тестов и 6.5 на рабочем сервере.
Честно говоря все и без аддонов раньше работало, но под 9.3 они просто взяли и установились, а тут затык.
Еще вопрос - у кого нибудь себестоимость в УПП под postgres считает? 


Теги: postgresql CentOS 7 
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 272
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal