Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 02:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Метод срез последних  (Прочитано 1824 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 
Есть справочник основные средства в этом справочнике форма списка и процедура печать - ее создал конструктором. Но необходимо печатать и табличную часть. Использую метод срез послдних.
Процедура Печать(Элемент)
   //{{_КОНСТРУКТОР_ПЕЧАТИ_СПИСОК(Печать)
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   ТаблицаСреза=РегистрыСведений.ДанныеОС.СрезПоследних(РабочаяДата);
   ТабДок = Новый ТабличныйДокумент;
   Макет = Справочники.ОсновныеСредства.ПолучитьМакет("Печать");
   // Заголовок
   Область = Макет.ПолучитьОбласть("Заголовок");
   ТабДок.Вывести(Область);
   // Шапка
   Область = Макет.ПолучитьОбласть("Шапка");
   ТабДок.Вывести(Область);
   Выборка = Справочники.ОсновныеСредства.ВыбратьИерархически();
   Группа = Макет.ПолучитьОбласть("Группа");
   Элемент = Макет.ПолучитьОбласть("Элемент");
   
   
   Пока Выборка.Следующий() Цикл
      Если Выборка.ЭтоГруппа Тогда
         Группа.Параметры.Заполнить(Выборка);
         ТабДок.Вывести(Группа);
      Иначе
         
         Элемент.Параметры.Заполнить(Выборка);
         ТабДок.Вывести(Элемент);
         Секция = Макет.ПолучитьОбласть("Элемент");
Секция.Параметры.Код = Элемент.Код;
Секция.Параметры.Наименование =Элемент.Наименование;
Секция.Параметры.Фирма = Элемент.Фирма;
Секция.Параметры.ГруппаОС = Элемент.ГруппаОС;
Секция.Параметры.ДатаВвода = Элемент.ДатаВвода;
Секция.Параметры.ДатаСписания = Элемент.ДатаСписания;
// Найдем строку содержащую ОС в таблице значений
СтрокаСреза = ТаблицаСреза.Найти(Элемент.Ссылка, "ОС");
Если СтрокаСреза<>Неопределено Тогда
    Секция.Параметры.БалансоваяСтоимость = СтрокаСреза.БалансоваяСтоимость;
    Секция.Параметры.РыночнаяСтоимость = СтрокаСреза.РыночнаяСтоимость;
    Секция.Параметры.Подразделение = СтрокаСреза.Подразделение;
КонецЕсли;
ТабДок.Вывести(Секция);

      КонецЕсли;
      КонецЦикла;

   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Ложь;
   ТабДок.ТолькоПросмотр = Ложь;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать();
   //}}_КОНСТРУКТОР_ПЕЧАТИ_СПИСОК
КонецПроцедуры


Выдает ошибку {Справочник.ОсновныеСредства.Форма.ОсновнаяФормаСписка(29)}: Поле объекта не обнаружено (Код)
Секция.Параметры.Код = Элемент.Код;

Поле код вроде есть, делаю задания по сквозному примеру вот не могу разобраться



Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 
Все получилось просто не указал выборку.Тема закрыта

Процедура Печать(Элемент)
   //{{_КОНСТРУКТОР_ПЕЧАТИ_СПИСОК(Печать)
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   ТаблицаСреза=РегистрыСведений.ДанныеОС.СрезПоследних(РабочаяДата);
   ТабДок = Новый ТабличныйДокумент;
   Макет = Справочники.ОсновныеСредства.ПолучитьМакет("Печать");
   // Заголовок
   Область = Макет.ПолучитьОбласть("Заголовок");
   ТабДок.Вывести(Область);
   // Шапка
   Область = Макет.ПолучитьОбласть("Шапка");
   ТабДок.Вывести(Область);
   Выборка = Справочники.ОсновныеСредства.ВыбратьИерархически();
   Группа = Макет.ПолучитьОбласть("Группа");
   Элемент = Макет.ПолучитьОбласть("Элемент");
   
   
   Пока Выборка.Следующий() Цикл
      Если Выборка.ЭтоГруппа Тогда
         Группа.Параметры.Заполнить(Выборка);
         ТабДок.Вывести(Группа);
      Иначе
         
         Элемент.Параметры.Заполнить(Выборка);
         ТабДок.Вывести(Элемент);
         Секция = Макет.ПолучитьОбласть("Элемент");
Секция.Параметры.Код = Выборка.Код;
Секция.Параметры.Наименование =Выборка.Наименование;
Секция.Параметры.Фирма = Выборка.Фирмы;
Секция.Параметры.ГруппаОС = Выборка.ГруппаОС;
Секция.Параметры.ДатаВвода = Выборка.ДатаВвода;
Секция.Параметры.ДатаСписания = Выборка.ДатаСписания;
// Найдем строку содержащую ОС в таблице значений
СтрокаСреза = ТаблицаСреза.Найти(Выборка.Ссылка, "ОС");
Если СтрокаСреза<>Неопределено Тогда
    Секция.Параметры.БалансоваяСтоимость = СтрокаСреза.БалансоваяСтоимость;
    Секция.Параметры.РыночнаяСтоимость = СтрокаСреза.РыночнаяСтоимость;
    Секция.Параметры.Подразделение = СтрокаСреза.Подразделение;
КонецЕсли;
ТабДок.Вывести(Секция);

      КонецЕсли;
      КонецЦикла;

   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Ложь;
   ТабДок.ТолькоПросмотр = Ложь;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать();
   //}}_КОНСТРУКТОР_ПЕЧАТИ_СПИСОК
КонецПроцедуры


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 301
Последний ответ 21 Сен 2017, 10:33
от Insider
Метод "ВыбратьЭлемент"

Автор GunnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1765
Последний ответ 24 Ноя 2015, 11:29
от Kironten
(Метод "Свойство" у структуры)

Автор GanG031Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1776
Последний ответ 05 Мар 2016, 13:30
от vitasw
"Свой метод" типа Свернуть

Автор beztrudРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 4410
Последний ответ 17 Окт 2014, 12:44
от beztrud
Проблема "Метод объекта не обнаружен"

Автор aleks159Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2319
Последний ответ 13 Дек 2016, 16:34
от aleks159

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 160
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal