Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 16:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сохранение печатной формы в файл XLS  (Прочитано 12619 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
Нужно при нажатии на кнопку сохранить печатную форму в файл XLS, добился того чтобы форма открылась из другого документа, а что дальше незнаю.... Буду благодарен любой помощи и советам  :mellow:
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/


Оффлайн Tatitutu

ТП.Записать("ВашеНазваниеФайла",'XLS'');


Записать(<?>,);
Write(<?>,);
Синтаксис:
Записать(<ИмяФайла>,<ТипФайла>)
Назначение:
Записать таблицу в файл.
Параметры:
<ИмяФайла> - имя файла.
<ТипФайла> - необязательный параметр. Числовое или строковое выражение, определяющее тип файла:
· отсутствует, 0 или ''MXL'' - формат 1C;
· 1 или ''XLS'' - формат Ms Excel;
· 2 или ''HTM'' или ''HTML'' - формат HTML;
· 3 или ''TXT'' - формат TXT.
Замечание:
Метод может использоваться при работе с таблицей в режиме ввода данных.

*  MAGAZKA - лучшая программа для розничного магазина (с) *

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
создаёт файл с печатным документом, но нужно каждый раз сформировать новое имя документа
Флаг=Флаг+1;
Таб.Записать("Документ"+Флаг,"XLS");

пытаюсь сделать "Документ1", "Документ2"... чтобы не затирал предыдущее сохранение. Помоги с реализацией  :nhsrm:
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн DenPlus

  • ***
  • Сообщений: 106
  • РЕПУТАЦИЯ: 64
  • КПД: 60%
  • Регистрация: 2010-10-27
  • Компания: www.cosmocat.ru
пытаюсь сделать "Документ1", "Документ2"... чтобы не затирал предыдущее сохранение. Помоги с реализацией  :nhsrm:
   //Имена файлов: Документ+флаг
   ФС.УстТекКаталог("<строка с именем текущего каталога>");
   времИмяФайла = ИмяФайла;                       
   нн = 1;
   Пока нн = 1 Цикл
    Если ФС.СуществуетФайл(времИмяФайла) = 1 Тогда
      флаг = флаг+1
      времИмяФайла = Сред(времИмяФайла,1,8)+флаг;
    Иначе
      ИмяФайла = времИмяФайла;
      Прервать;
    КонецЕсли;
   КонецЦикла;   

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
пытаюсь сделать "Документ1", "Документ2"... чтобы не затирал предыдущее сохранение. Помоги с реализацией  :nhsrm:
   //Имена файлов: Документ+флаг
   ФС.УстТекКаталог("<строка с именем текущего каталога>");
   времИмяФайла = ИмяФайла;                       
   нн = 1;
   Пока нн = 1 Цикл
    Если ФС.СуществуетФайл(времИмяФайла) = 1 Тогда
      флаг = флаг+1
      времИмяФайла = Сред(времИмяФайла,1,8)+флаг;
    Иначе
      ИмяФайла = времИмяФайла;
      Прервать;
    КонецЕсли;
   КонецЦикла;   


не понял ничего)
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
разобрался немного, но всё же
Сред(времИмяФайла,1,8) - для чего?
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн DenPlus

  • ***
  • Сообщений: 106
  • РЕПУТАЦИЯ: 64
  • КПД: 60%
  • Регистрация: 2010-10-27
  • Компания: www.cosmocat.ru
Вот вы писали "Документ"+Флаг, значи это вы понимаете.

//Так вот:
ИмяФайла = "Документ"+Флаг;
//Далее по тексту:
//Имена файлов: Документ+флаг
   ФС.УстТекКаталог("<строка с именем текущего каталога>");// установили каталог с которым будем работать
   времИмяФайла = ИмяФайла; //Передали текущее имя файла во временную переменную                      
   нн = 1;
   Пока нн = 1 Цикл // Цикл прервется после того как в рабочем каталоге не будет найдено очередного файла с именем "Документ"+флаг
    Если ФС.СуществуетФайл(времИмяФайла) = 1 Тогда
      флаг = флаг+1//пока проверяем, что файл с таким именем существует, "накручиваем" флаг
      времИмяФайла = Сред(времИмяФайла,1,8)+флаг;
    Иначе
      ИмяФайла = времИмяФайла;// новое имя файла получено - вылетаем из цикла
      Прервать;
    КонецЕсли;
   КонецЦикла;  

Оффлайн DenPlus

  • ***
  • Сообщений: 106
  • РЕПУТАЦИЯ: 64
  • КПД: 60%
  • Регистрация: 2010-10-27
  • Компания: www.cosmocat.ru
разобрался немного, но всё же
Сред(времИмяФайла,1,8) - для чего?
Тоже самое что и Лев(значение,8)
(в слове документ - 8 букв)

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
Мб что не так? но файл создаётся только один (перезаписывается) и в стартовом каталоге (вместо того чтобы создать файл в папке XLS)  :(

	ИмяФайла="Документ"+Флаг;
ФС.УстТекКаталог("C:\Documents and Settings\Admin\Рабочий стол\Avtosalon_work\XLS");
времИмяФайла=ИмяФайла;
нн=1;
Пока нн=1 Цикл
Если ФС.СуществуетФайл(времИмяФайла)=1 Тогда
Флаг=Флаг+1;
времИмяФайла=Сред(времИмяФайла,1,8)+Флаг;
Иначе
ИмяФайла=времИмяФайла;
Прервать;
КонецЕсли;
КонецЦикла;                     

Таб.Записать(ИмяФайла+Флаг,"XLS");
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн DenPlus

  • ***
  • Сообщений: 106
  • РЕПУТАЦИЯ: 64
  • КПД: 60%
  • Регистрация: 2010-10-27
  • Компания: www.cosmocat.ru
[quote author=Gendelf link=topic=5432.msg16497#msg16497 date=1289558168]
Таб.Записать(ИмяФайла+Флаг,"XLS");
[/quote]
Должно быть так:
Таб.Записать(ФС.ТекКаталог()+ИмяФайла,"XLS");

Семерки нет под рукой. Посмотрите в отладчике что возвращает "ФС.ТекКаталог()+ИмяФайла". Допускаю, что м.б. еще "/" надо будет вставить.

Обратите внимание что по задумке записывается не "ИмяФайла+Флаг", а просто ИмяФайла. Оно уже с новой цифрой в конце.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal