Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 23:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите новичку! Знающему раз плюнуть...  (Прочитано 4335 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alexx2007

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 1
  • КПД: 25%
  • Регистрация: 2010-11-11
  • Сайт: 
Помогите новичку, не могу понять как сделать.

У меня есть внешняя обработка ert.

На определенном этапе мне надо получить дату последнего изменения цены товара.

Товары перебираются так

СпрТМЦ=СоздатьОбъект ("Справочник.Номенклатура");
СпрЦена=СоздатьОбъект ("Справочник.Цены");
РегТовары = СоздатьОбъект("Регистр.ОстаткиТМЦ");

ТекстЗапросаОстатков = "
      |Номенклатура   = Регистр.ОстаткиТМЦ.Номенклатура;
      |Количество      = Регистр.ОстаткиТМЦ.Количество;
      |Функция КоличествоКонОст = КонОст(Количество);
      |Группировка Номенклатура;";

ЗапросПоОстаткам = СоздатьОбъект("Запрос");
Если ЗапросПоОстаткам.Выполнить(ТекстЗапросаОстатков) = 0 Тогда
   Возврат;
КонецЕсли;

Пока ЗапросПоОстаткам.Группировка(1) = 1 Цикл

.....   тут все основное.....

Вот в этом месте надо получить, к примеру в переменную "Дата", дату последнего изменения цены на товар. Ее можно посмотреть в самой 1С в Сведениях о номенклатуре - Справочники - Цены - История, а как тут сделать - ну не программист я.....


КонецЦикла;

Помогите люди добрые. Обработка самописная.


Оффлайн DenPlus

  • ***
  • Сообщений: 106
  • РЕПУТАЦИЯ: 64
  • КПД: 60%
  • Регистрация: 2010-10-27
  • Компания: www.cosmocat.ru
.....   тут все основное.....
Ист = СоздатьОбъект("Исторический");
Ист.ИспользоватьОбъект(<"НапишиИмяПериодическогоРеквизита">, Запрос.Номенклатура);

НужнаяДата = Ист.ДатаЗнач;

Ну как то так. Нет "семерки под рукой", чтобы проверить.

Оффлайн DenPlus

  • ***
  • Сообщений: 106
  • РЕПУТАЦИЯ: 64
  • КПД: 60%
  • Регистрация: 2010-10-27
  • Компания: www.cosmocat.ru
Сорри. СоздатьОбъект("Периодический")

Оффлайн DenPlus

  • ***
  • Сообщений: 106
  • РЕПУТАЦИЯ: 64
  • КПД: 60%
  • Регистрация: 2010-10-27
  • Компания: www.cosmocat.ru
Ист = СоздатьОбъект("Периодический");
Ист.ИспользоватьОбъект("УкажиПериодическийРеквизитНоменклатуры", Запрос.Номенклатура);
//Забыл добавить
Ист.ОбратныйПорядок();
Ист.ВыбратьЗначения();   
Пока  Ист.ПолучитьЗначение() = 1 Цикл
   Прервать;
КонецЦикла;   
      
НужнаяДата = Ист.ДатаЗнач;

Оффлайн alexx2007

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 1
  • КПД: 25%
  • Регистрация: 2010-11-11
  • Сайт: 
Ист = СоздатьОбъект("Периодический");
Ист.ИспользоватьОбъект("УкажиПериодическийРеквизитНоменклатуры", Запрос.Номенклатура);
//Забыл добавить
Ист.ОбратныйПорядок();
Ист.ВыбратьЗначения();   
Пока  Ист.ПолучитьЗначение() = 1 Цикл
   Прервать;
КонецЦикла;   
      
НужнаяДата = Ист.ДатаЗнач;

Спасибо за ответ, пятой точкой чую - где-то рядом уже решение :)
Код твой матерится на

Ист.ИспользоватьОбъект("УкажиПериодическийРеквизитНоменклатуры", Запрос.Номенклатура);

пишет: переменная не определена (Запрос)

Я не знаю, че мне тут прописать

Оффлайн Tatitutu

это если следовать этой теме, но можно подругому

Ист = СоздатьОбъект("Периодический");
СпрТМЦ=СоздатьОбъект ("Справочник.Номенклатура");
СпрЦена=СоздатьОбъект ("Справочник.Цены");
РегТовары = СоздатьОбъект("Регистр.ОстаткиТМЦ");

ТекстЗапросаОстатков = "
      |Номенклатура   = Регистр.ОстаткиТМЦ.Номенклатура;
      |Количество      = Регистр.ОстаткиТМЦ.Количество;
      |Функция КоличествоКонОст = КонОст(Количество);
      |Группировка Номенклатура;";

ЗапросПоОстаткам = СоздатьОбъект("Запрос");
Если ЗапросПоОстаткам.Выполнить(ТекстЗапросаОстатков) = 0 Тогда
   Возврат;
КонецЕсли;

Пока ЗапросПоОстаткам.Группировка(1) = 1 Цикл


Ист.ИспользоватьОбъект("УкажиПериодическийРеквизитНоменклатуры", ЗапросПоОстаткам.Номенклатура);
//Забыл добавить
Ист.ОбратныйПорядок();
Ист.ВыбратьЗначения();   
Пока  Ист.ПолучитьЗначение() = 1 Цикл
   Прервать;
КонецЦикла;   
     
НужнаяДата = Ист.ДатаЗнач;

*  MAGAZKA - лучшая программа для розничного магазина (с) *

Оффлайн DenPlus

  • ***
  • Сообщений: 106
  • РЕПУТАЦИЯ: 64
  • КПД: 60%
  • Регистрация: 2010-10-27
  • Компания: www.cosmocat.ru
Цитировать
Код твой матерится на

Ист.ИспользоватьОбъект("УкажиПериодическийРеквизитНоменклатуры", Запрос.Номенклатура);

пишет: переменная не определена (Запрос)

Я не знаю, че мне тут прописать
Конечно же в данном случае не "Запрос.Номенклатура", а "ЗапросПоОстаткам.Номенклатура"
Ист.ИспользоватьОбъект("УкажиПериодическийРеквизитНоменклатуры", ЗапросПоОстаткам.Номенклатура);

Оффлайн alexx2007

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 1
  • КПД: 25%
  • Регистрация: 2010-11-11
  • Сайт: 
Цитировать
Код твой матерится на

Ист.ИспользоватьОбъект("УкажиПериодическийРеквизитНоменклатуры", Запрос.Номенклатура);

пишет: переменная не определена (Запрос)

Я не знаю, че мне тут прописать
Конечно же в данном случае не "Запрос.Номенклатура", а "ЗапросПоОстаткам.Номенклатура"
Ист.ИспользоватьОбъект("УкажиПериодическийРеквизитНоменклатуры", ЗапросПоОстаткам.Номенклатура);

Спасибо за отклик, это хорошо все, только :) у меня еще вопрос:

УкажиПериодическийРеквизитНоменклатуры - сюда ваще что нужно сунуть, если мне надо дату последнего изменения цены на товар? Может я конечно не правильно как-то выражаюсь?
Парни, вы меня не пинайте, я почти нифига не понимаю в 1С, но сделать некому. Роюсь в инете, но ничего понять по этим реквизитам не могу, все так путано...


Оффлайн Tatitutu

"УкажиПериодическийРеквизитНоменклатуры"  замени на "Цена"
Ист.ИспользоватьОбъект("Цена", ЗапросПоОстаткам.Номенклатура);

*  MAGAZKA - лучшая программа для розничного магазина (с) *

Оффлайн DenPlus

  • ***
  • Сообщений: 106
  • РЕПУТАЦИЯ: 64
  • КПД: 60%
  • Регистрация: 2010-10-27
  • Компания: www.cosmocat.ru
"УкажиПериодическийРеквизитНоменклатуры"  замени на "Цена"
Ист.ИспользоватьОбъект("Цена", ЗапросПоОстаткам.Номенклатура);

Та не. Там другая история оказалась (в личке все порешали). Оказалось, что "Цена" не является периодическим реквизитом справочника Номенклатура, а является периодическим реквизитом справочника Цены, который подчинен справочнику Номенклатура, имеющему в свою очередь, дополнительный реквизит "типЦены" (закупочная, оптовая и т.д.). Типовая ТиС в общем оказалась. :)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 260
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal