Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 08:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Общий вопрос от новичка  (Прочитано 4074 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн odity

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 1
  • КПД: 7%
  • Регистрация: 2010-11-10
  • Сайт: 
Здравствуйте Уважаемые форумчане. Сейчас прохожу курсы 1С конфигурирование и мало еще понимаю в программирование1С. помогите!? Не нашел на данном форуме ветки для чайников-вот и пишу тут:
1) подскажите что вы читали ,чтобы стать такими асами в этой области (сам програмер и дмин со стажем, но даттая среда меня просто в ступор ставит)
2) понимаю что все познается в опыте. вот вопрос.
Есть справочник машина. в ней есть реквизит (типо что в машине едет водитель и 2 работника) водитель, работник 1, работник 2. Есть справочник служащие у которых есть реквизиты: ФИО , видработы. Вид работы - это перечисление,которое я жестко прописал и поставил на выбор в "Конфигурация. Перечисления". вот теперь мне нужно на форме Машина в строке "водитель" выбрать работников,которые имеют вид работы - водитель
Я пишу что строка водитель имеет ссылку на Справочники.Служащие ...а как из этих служащих вытащить поле видработы? или помогите правильно структурировать мою базу...хотя бы на уровне какие таблицы и справочники нужно создавать и как их привязать.
Заранее большое спасибо


Оффлайн odity

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 1
  • КПД: 7%
  • Регистрация: 2010-11-10
  • Сайт: 
пишу

С = Справочники.Сотрудники.ПолучитьСсылку();//или Выбрать()
Водитель = С.ФИО;

но не правильно. почему нету Справочники.Сотрудники.Текущее(что то там))

Оффлайн Lexius

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 16
  • КПД: 44%
  • Регистрация: 2010-11-10
  • Сайт: 
Потому что надо четко говорить, что хочешь получить. Ибо работа в 1С идет с конкретными "Объектами БД" - т.е. документами, записями справочника, итд...

Как можно найти элемент справочника:

// Методом "НайтиПоКоду("<типа код искомого эл-та справочника>")"
например: Сотрудник = Справочники.Сотрудники.НайтиПоКоду("000001");
Водитель = Сотрудник.Фио;
..............
// Методом "НайтиПоНаименованию("<Наименование искомого эл-та справочника>")"
например: Сотрудник = Справочники.Сотрудники.НайтиПоНаименованию("Казюлькин Вася Сигизмундович");
Водитель = Сотрудник.Фио;
..............

Обход справочника через Выборку справочника
ВыборкаСотрудников = Справочники.Сотрудники.Выбрать();
// В цикле.
Пока ВыборкаСотрудников.Следующий() Цикл
Водитель = Сотрудник.Фио;
..............
КонецЦикла;

Оффлайн odity

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 1
  • КПД: 7%
  • Регистрация: 2010-11-10
  • Сайт: 
Хм...уяснил. А еще один глупый вопрос:
Вот я привязал что текстовое поле по Объекту будет Справочники.Сотрудники. а у сотрудника есть реквизит какой то определенный. и как,вот я кликаю по полю и мне выдает список всех сотрудников. а как сразу отсеять этот список вот по этому реквизит определенному? почитал по запросам - более-менее понятно, но не ясно как выпадаемое поле вывести уже отсортированное

Оффлайн odity

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 1
  • КПД: 7%
  • Регистрация: 2010-11-10
  • Сайт: 
И все равно:


Процедура ВодительПриИзменении(Элемент)
   С = Справочники.Водители.Выбрать();
   пока С.Следующий() цикл
      Водитель = С.ФИО;
   КонецЦикла;
КонецПроцедуры


Поле после перебора остается пустым,хотя в отладчике видно что на "С" в поле ФИО есть имена. на поле лежит у меня поле Водитель...почему не присваивается ему ничего?:(((( либо пристваиваются просто "<>"

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Вам нужно, чтобы в форме выбора был отбор по реквизиту?

Оффлайн Lexius

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 16
  • КПД: 44%
  • Регистрация: 2010-11-10
  • Сайт: 
"Текстовое поле"
 Поле/реквизит у справочника/документа/итп может быть либо текстовым(простой тип данных), т.е. иметь тип "Строка"("Число", "Булево"), либо(сложным) ссылочным, т.е. иметь тип "Документ","Справочник", итд.

Понятно: Надо выбрать из списка сотр-ов тех, которые являются водителями.

 ФормаВыбора = Справочник.Служащие.ПолучитьФормуВыбора(,Форма,); //Получаем форму выбора
 ФормаВыбора.СправочникСписок.Отбор.ВидРаботы.Установить(Перечисления.ВидыРабот.Водила); //Ставим критерий отбора

 ВыбранныйВодитель = ФормаВыбора.Открыть(); // открываем форму выбора

Оффлайн odity

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 1
  • КПД: 7%
  • Регистрация: 2010-11-10
  • Сайт: 
Вам нужно, чтобы в форме выбора был отбор по реквизиту?
Да, конечно! По реквизиту...и,если вам не сложно то и по табличной части тоже приведите пример

Оффлайн odity

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 1
  • КПД: 7%
  • Регистрация: 2010-11-10
  • Сайт: 
Ну что такое. я не понимаю различий между (когда пишу код):
1)Справочники (почему я через них не могу напрямую дойти до реквизита как в С++???)
2)СправочникОБъект - что с ним делать и что я от него могу получить?

У меня есть справочники:
сотрудник:
   -ФИО
   -Профессия(ссылка на перечисление (работник, пассажир))
Машина:
   -НомерМашины
   -Водитель (привязан по типу к справочнику сотрудник. нужно при открытии отсортировать справочник и показать только водителей и потом в это поле вписать ФИО)
   -Пассажир(тоже самое как с водителем)

Я путаюсь во всех этив методах и типах...почему по Справочники.Сотрудник.(ТекущееПоложение - почему такого нету тут?)
или мне нужно не в реквизиты а в табличную часть записывать поле Водитель и Пассажир?

Оффлайн Slin

  • Глобальный модератор
  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
И все равно:


Процедура ВодительПриИзменении(Элемент)
   С = Справочники.Водители.Выбрать();
   пока С.Следующий() цикл
      Водитель = С.ФИО;
   КонецЦикла;
КонецПроцедуры


Поле после перебора остается пустым,хотя в отладчике видно что на "С" в поле ФИО есть имена. на поле лежит у меня поле Водитель...почему не присваивается ему ничего?:(((( либо пристваиваются просто "<>"

С помощью метода Выбрать() создается объект типа СправочникВыборка. Он доступен только для чтения.
skype: slin-dev


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9211
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Вопрос по РИБ "ПоОрганизации"

Автор andi_xРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5843
Последний ответ 15 Мар 2013, 21:38
от Besart
Вопрос по "Отчеты о Розничных продажах".

Автор GerCerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3289
Последний ответ 26 Июл 2010, 16:06
от crow1983
Вопрос о действии кнопки "Записать"

Автор jenya1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3436
Последний ответ 06 Окт 2014, 15:23
от jenya1111
Вопрос по отчету "Материалы в эксплуатации".

Автор mitauskasРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2363
Последний ответ 04 Мар 2015, 11:07
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 183
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal