Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Май 2019, 20:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Грабли: Как работать со справочником из модуля формы?  (Прочитано 2151 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sofabeat

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-09
  • Сайт: 
Хочу в табличной части документа, чтобы ПриИзменении (Выборе) Услуги соответственно отображалась Цена услуги. Изменяю реквизит ТабЧасти (СправочникСсылка.Услуги). В этом же справочники содержится нужная мне цена.

 ФормаДокумента
&НаКлиенте
Процедура УслугаПриИзменении(Элемент)
     СтрокаТабЧасти = Элементы.Услуги.ТекущиеДанные;
     Усл = СтрокаТабЧасти.Услуга;
     Цена = ОбщийМодуль.УзнатьЦену(Усл);
КонецПроцедуры

ОбщийМодуль - Модуль Глобальный
&НаКлиентеНасервере
Функция
     Для каждого Услуга из Справочники.Услуги Цикл
           если Услуга = Усл тогда
           возврат Справочники.Услуги.Цена;
           конецесли;
           конеццикла;
КонецФункции

Натыкаюсь либо на то, что Справочники не знает клиент, либо на то, что функцию не знает клиент. Как это сделать по-человечески?


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
&НаКлиенте
Процедура УслугаПриИзменении(Элемент)
     СтрокаТабЧасти = Элементы.Услуги.ТекущиеДанные;
     Усл = СтрокаТабЧасти.Услуга;
     Цена = ВозвратЦены(Усл);
КонецПроцедуры

&НаСервере
Функция ВозвратЦены(Номенклатура)
      Возврат Номенклатура.Цена;
КонецФункции


Теги:
 

Элемент формы СписокЗначений с типом СписокЗначений

Автор Людмила КиреенковаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 196
Последний ответ 20 Мар 2019, 10:20
от AIFrame
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 547
Последний ответ 10 Апр 2018, 14:00
от Св Ч
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5706
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4139
Последний ответ 12 Июл 2013, 15:35
от mikel10
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1123
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
36 Сообщений
AIFrame AIFrame
31 Сообщений
wise wise
31 Сообщений
alexandr_ll
29 Сообщений
DmitriyF DmitriyF
13 Сообщений
vova-1c@xaker.ru
11 Сообщений
Мария112689
9 Сообщений
Eugeneer Eugeneer
9 Сообщений
Yamuna
8 Сообщений
kiksi
8 Сообщений

* Кто онлайн

  • Точка Гостей: 184
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal