Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 03:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Общие модули  (Прочитано 5601 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tpekep

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-21
  • Сайт: 
Создал в общем модуле процедуру с именем РаботаСДокументами

Процедура РассчитатьСумму(СтрокаТабличнойЧасти)Экспорт
   СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Количество * СтрокаТабличнойЧасти.Цена;
КонецПроцедуры


В документе ПриходнаяНакладная в табличной части в поле Количество  написал модуль который считает сумму из процедуры, находящейся в Общие модули

Процедура ПереченьНоменклатурыКоличествоПриИзменении(Элемент)
   СтрокаТабличнойЧасти = ЭлементыФормы.Материалы.ТекущиеДанные;
   РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры

На что он говорит что не найдена данная функцияч или процедура:
{Документ.ОказаниеУслуги.Форма.ФормаДокумента(4,2)}: Процедура или функция с указанным именем не определена (РассчитатьСумму)
   <<?>>РассчитатьСумму(СтрокаТабличнойЧасти);

Вопрос в том, почему он ее не видет? Ошибка появляется только во время компиляции документа приходной накладной. Процедура из общих модулей ошибки не показывает.


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Re: Общие модули
« Ответ #1: 07 Ноя 2010, 19:44 »
Обращаться к вашей процедуре нужно РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти)

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Re: Общие модули
« Ответ #2: 07 Ноя 2010, 19:44 »
РаботаСДокументами - я так понял имя модуля.

Оффлайн DenPlus

  • ***
  • Сообщений: 106
  • РЕПУТАЦИЯ: 64
  • КПД: 60%
  • Регистрация: 2010-10-27
  • Компания: www.cosmocat.ru
Re: Общие модули
« Ответ #3: 09 Ноя 2010, 00:07 »
В приходной накладной:
Процедура ПереченьНоменклатурыКоличествоПриИзменении(Элемент)
   СтрокаТабличнойЧасти = ЭлементыФормы.Материалы.ТекущиеДанные;
   РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры

На те же грабли наткнетесь когда, читая Радченко, создадите общий модуль РаботаСоСправочниками.

И дело, видимо, не в "книжной ошибке"..., просто книжка выпущена достаточно давно.

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
Re: Общие модули
« Ответ #4: 09 Ноя 2010, 09:59 »
А может это глобальный модуль должен быть, чтоб напрямую обращаться к функциям?

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Re: Общие модули
« Ответ #5: 09 Ноя 2010, 10:23 »
А может это глобальный модуль должен быть, чтоб напрямую обращаться к функциям?

Да. Такое тоже возможно.

Оффлайн Тиль

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 4
  • КПД: 57%
  • Регистрация: 2010-11-10
  • Сайт: 
Re: Общие модули
« Ответ #6: 10 Ноя 2010, 12:35 »
Процедура ПереченьНоменклатурыКоличествоПриИзменении(Элемент)
   СтрокаТабличнойЧасти = ЭлементыФормы.Материалы.ТекущиеДанные;
   РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры

Оффлайн Тиль

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 4
  • КПД: 57%
  • Регистрация: 2010-11-10
  • Сайт: 
Re: Общие модули
« Ответ #7: 10 Ноя 2010, 12:35 »
У Радченко написано для 8.0. А ты скорее всего используешь 8.1

Оффлайн Tpekep

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-21
  • Сайт: 
Re: Общие модули
« Ответ #8: 10 Ноя 2010, 14:18 »
Да. Все правильно.
Я надеялся что в 1С язык программирования отличается только между 7.х и 8.x
Потому что говорят переход от одной версии к другой как небо и земля.

Оффлайн Slin

  • Глобальный модератор
  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
Re: Общие модули
« Ответ #9: 10 Ноя 2010, 15:01 »
у версий 8.x язык различается очень незначительно
скорее изменился контекст применения, особенно с версией 8.2
и конечно это наложило свой отпечаток
skype: slin-dev


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 183
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal