Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 00:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: СКД 8.2_Расшифровка...Помогите пожалуйста  (Прочитано 6791 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн anyut_ka

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-31
  • Сайт: 
Есть Отчет, сформированный с помощью СКД. В отчете есть группировки, вот наглядный пример

Бюджет
Район Задолженность
Договор

Федеральный 360
Вологда 200
э705-45 200
Сокол 160
нк34-90 160

Т.е. здесь группировки - Бюджет, Район

ГРУППИРОВКИ формируются программным путем, например:
Если РазвернутьПоРайонам Тогда
Гр = ТиповыеОтчеты.ДобавитьГруппировку(ОтчетОбъект.КомпоновщикНастроек, "Район");
КонецЕсли;

Необходимо при нажатии на любую ячейку отчета сделать расшифровку, передав в качестве параметра Договор

В процедуре делаю обработку расшифровки

Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
СтандартнаяОбработка=Ложь;
ОбработкаРасшифровки= Новый ОбработкаРасшифровкиКомпоновкиданных(ДанныеРасшифровки,Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));

Данные = ДанныеРасшифровки;
Поля = Данные.Элементы.Получить(Расшифровка).ПолучитьПоля();
ПолеДоговор = Поля.Найти("Договор");
Если ПолеДоговор=Неопределено Тогда
ПолеДоговор = Неопределено;
Иначе
ПолеДоговор = ПолеДоговор.Значение;
Отчет = Отчеты.КарточкаСчета.Создать();

Отчет.Счет = ПланыСчетов.Хозрасчетный.РасчетыСПокупателями;
Отчет.НачалоПериода = НачалоГода(ТекущаяДата());
Отчет.КонецПериода = КонецМесяца(ТекущаяДата());
Отчет.Настроить();
Отчет.РежимРасшифровки = Истина;
Отчет.СохранятьНастройкуОтчета = Ложь;
Отб1 = Отчет.КомпоновщикНастроек.Настройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
Отб1.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
Отб1.Использование = Истина;
Отб1.Представление = "";
Отб1.Применение = ТипПримененияОтбораКомпоновкиДанных.Элементы;
Отб1.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.БыстрыйДоступ;
Отб1.ЛевоеЗначение = Отчет.КомпоновщикНастроек.Настройки.ДоступныеПоляОтбора.Элементы.Найти("Субконто1").Поле;
Отб1.ПравоеЗначение = ПоляГруппировок;

Форма = Отчет.ПолучитьФорму("ФормаОтчета");
Форма.Открыть();
Форма.ЭлементыФормы.ДействияФормыДополнительные.Кнопки.ПанельПользователя.Пометка = Ложь;
СтандартныеОтчеты.УправлениеОтображениемПанелиПользователя(Форма);

Форма.ОбновитьОтчет();



КонецЕсли;

КонецПроцедуры;

ПРОБЛЕМА в том, что не используя группировок все замечательно выводится, но при их использовании пишет поле Договор не должно входить в группировку Принадлежность Бюджету и так со всеми группировками

В СКД на вкладке макеты создаю макет поля, параметр Задолженность Расшифровка (Договор)
В принципе понятно, почему так происходит, если опять на примере

нельзя расшифровать сумму задолженности группировки (360) по договору, так как в ее составе несколько договоров...

Думаю, что в макете необходимо либо какое-то условие написать через конструкцию ВЫБОР либо как-то с макетом группировки колдовать

ПОДСКАЖИТЕ ПОЖАЛУЙСТА, КАК РЕШИТЬ ПРОБЛЕМУ!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4304
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5562
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5901
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4389
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1987
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 191
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal