Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Сен 2020, 06:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: СКД 8.2_Расшифровка...Помогите пожалуйста  (Прочитано 7688 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн anyut_ka

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-31
  • Сайт: 
Есть Отчет, сформированный с помощью СКД. В отчете есть группировки, вот наглядный пример

Бюджет
Район Задолженность
Договор

Федеральный 360
Вологда 200
э705-45 200
Сокол 160
нк34-90 160

Т.е. здесь группировки - Бюджет, Район

ГРУППИРОВКИ формируются программным путем, например:
Если РазвернутьПоРайонам Тогда
Гр = ТиповыеОтчеты.ДобавитьГруппировку(ОтчетОбъект.КомпоновщикНастроек, "Район");
КонецЕсли;

Необходимо при нажатии на любую ячейку отчета сделать расшифровку, передав в качестве параметра Договор

В процедуре делаю обработку расшифровки

Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
СтандартнаяОбработка=Ложь;
ОбработкаРасшифровки= Новый ОбработкаРасшифровкиКомпоновкиданных(ДанныеРасшифровки,Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));

Данные = ДанныеРасшифровки;
Поля = Данные.Элементы.Получить(Расшифровка).ПолучитьПоля();
ПолеДоговор = Поля.Найти("Договор");
Если ПолеДоговор=Неопределено Тогда
ПолеДоговор = Неопределено;
Иначе
ПолеДоговор = ПолеДоговор.Значение;
Отчет = Отчеты.КарточкаСчета.Создать();

Отчет.Счет = ПланыСчетов.Хозрасчетный.РасчетыСПокупателями;
Отчет.НачалоПериода = НачалоГода(ТекущаяДата());
Отчет.КонецПериода = КонецМесяца(ТекущаяДата());
Отчет.Настроить();
Отчет.РежимРасшифровки = Истина;
Отчет.СохранятьНастройкуОтчета = Ложь;
Отб1 = Отчет.КомпоновщикНастроек.Настройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
Отб1.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
Отб1.Использование = Истина;
Отб1.Представление = "";
Отб1.Применение = ТипПримененияОтбораКомпоновкиДанных.Элементы;
Отб1.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.БыстрыйДоступ;
Отб1.ЛевоеЗначение = Отчет.КомпоновщикНастроек.Настройки.ДоступныеПоляОтбора.Элементы.Найти("Субконто1").Поле;
Отб1.ПравоеЗначение = ПоляГруппировок;

Форма = Отчет.ПолучитьФорму("ФормаОтчета");
Форма.Открыть();
Форма.ЭлементыФормы.ДействияФормыДополнительные.Кнопки.ПанельПользователя.Пометка = Ложь;
СтандартныеОтчеты.УправлениеОтображениемПанелиПользователя(Форма);

Форма.ОбновитьОтчет();



КонецЕсли;

КонецПроцедуры;

ПРОБЛЕМА в том, что не используя группировок все замечательно выводится, но при их использовании пишет поле Договор не должно входить в группировку Принадлежность Бюджету и так со всеми группировками

В СКД на вкладке макеты создаю макет поля, параметр Задолженность Расшифровка (Договор)
В принципе понятно, почему так происходит, если опять на примере

нельзя расшифровать сумму задолженности группировки (360) по договору, так как в ее составе несколько договоров...

Думаю, что в макете необходимо либо какое-то условие написать через конструкцию ВЫБОР либо как-то с макетом группировки колдовать

ПОДСКАЖИТЕ ПОЖАЛУЙСТА, КАК РЕШИТЬ ПРОБЛЕМУ!


Теги:
 

Помогите выразить код Объект.Наименование = Объект.Подразделение + " " + Объект.Должность + " " + Объект.ФизическоеЛицо через строки.

Автор LedgikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1134
Последний ответ 05 Мар 2019, 19:28
от Ledgik
Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6812
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите правильно настроить справочник "Единицы измерения" и "Номенклатура"

Автор perminovandrРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1336
Последний ответ 23 Янв 2019, 07:21
от Геннадий ОбьГЭС
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7228
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 7301
Последний ответ 28 Мар 2012, 13:02
от chum710

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
71 Сообщений
oooo800
34 Сообщений
LexaK
32 Сообщений
Дмитрий Джей Дмитрий Джей
28 Сообщений
IL2016
25 Сообщений
antoneus antoneus
21 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
SoOliateR
13 Сообщений

* Кто онлайн

  • Точка Гостей: 198
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal