Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 15:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ПрочитатьАтрибут  (Прочитано 567 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cwiki

  • Модератор
  • *****
  • Сообщений: 8287
  • РЕПУТАЦИЯ: 12
  • КПД: 0%
  • Регистрация: 2014-08-05
  • Сайт: 
  • Профессия: Программист 8.1
Раздел:
Общие объекты
Подразделы:
XML
ИмяОбъекта:
ЧтениеXML
ТипСтатьи:
Методы
ЧтениеXML.ПрочитатьАтрибут (XMLReader.ReadAttribute)
ЧтениеXML (XMLReader)
ПрочитатьАтрибут (ReadAttribute)
Синтаксис:
ПрочитатьАтрибут()
Возвращаемое значение:
Тип: Булево.
Истина - очередной атрибут прочитан; Ложь - атрибутов больше нет.
Описание:
Считывает очередной атрибут элемента XML. После прочтения с помощью метода ЧтениеXML.Прочитать очередного узла, имеющего тип НачалоЭлемента, можно получить доступ к атрибутам данного элемента. Каждый вызов данного метода позволяет прочитать очередной атрибут. После прочтения очередного атрибута свойствам ЧтениеXML.ТипУзла, ЧтениеXML.Имя, ЧтениеXML.ЛокальноеИмя, ЧтениеXML.Префикс, ЧтениеXML.URIПространстваИмен и ЧтениеXML.Значение присваиваются значения в соответствии с прочитанным атрибутом.

Доступность:
Тонкий клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).
Пример:
Чтение.ОткрытьФайл("c:/docs/data.xml");
Пока Чтение.Прочитать() Цикл
    Если Чтение.КоличествоАтрибутов() > 0 Тогда
        Пока Чтение.ПрочитатьАтрибут() Цикл
            // Обработка атрибута
        КонецЦикла
    КонецЕсли
КонецЦикла




     


Теги:
 

ПрочитатьАтрибут

Автор 1cwikiРаздел Синтаксис

Ответов: 0
Просмотров: 564
Последний ответ 13 Авг 2015, 00:00
от 1cwiki
ПрочитатьАтрибут

Автор 1cwikiРаздел Синтаксис

Ответов: 0
Просмотров: 385
Последний ответ 16 Авг 2015, 22:59
от 1cwiki

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
136 Сообщений
AIFrame
69 Сообщений
ilyay ilyay
65 Сообщений
alex0402
51 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 821
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal