Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 20:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: КоличествоАтрибутов  (Прочитано 425 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cwiki

  • Модератор
  • *****
  • Сообщений: 8287
  • РЕПУТАЦИЯ: 14
  • КПД: 0%
  • Регистрация: 2014-08-05
  • Сайт: 
  • Профессия: Программист 8.1
Раздел:
Общие объекты
Подразделы:
XML
ИмяОбъекта:
ЧтениеXML
ТипСтатьи:
Методы
ЧтениеXML.КоличествоАтрибутов (XMLReader.AttributeCount)
ЧтениеXML (XMLReader)
КоличествоАтрибутов (AttributeCount)
Синтаксис:
КоличествоАтрибутов()
Возвращаемое значение:
Тип: Число.

Описание:
Получает количество атрибутов у последнего прочитанного узла XML. Так как атрибуты могут быть только у элемента XML, доступ к ним может осуществляться только при прочтении узла, имеющего тип НачалоЭлемента.

Доступность:
Тонкий клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).
Пример:
Чтение.ОткрытьФайл("c:/docs/data.xml");
Пока Чтение.Прочитать() Цикл
    Если Чтение.КоличествоАтрибутов() > 0 Тогда
        Пока Чтение.ПрочитатьАтрибут() Цикл
            // Обработка атрибута
        КонецЦикла
    КонецЕсли
КонецЦикла




     


Теги:
 

КоличествоАтрибутов

Автор 1cwikiРаздел Синтаксис

Ответов: 0
Просмотров: 286
Последний ответ 12 Авг 2015, 23:59
от 1cwiki
КоличествоАтрибутов

Автор 1cwikiРаздел Синтаксис

Ответов: 0
Просмотров: 281
Последний ответ 16 Авг 2015, 22:58
от 1cwiki

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
173 Сообщений
alex0402
75 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
43 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
Alter
32 Сообщений

* Кто онлайн

  • Точка Гостей: 226
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal