Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 18:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя обработка, создание связанных объектов  (Прочитано 2885 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн golovina

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-31
  • Сайт: 
Здравствуйте, подскажите, пожалуйста! Во внешней обработке создаю Заказ поставщику на основании Заказа клиента. При этом в табличную часть Заказа поставщику заполняю основными вариантами комплектации товаров, которые содержаться в Заказе клиенту. На данный момент 2 проблемы.
1. Табличная часть заполняется без ошибок, но при попытке провести созданный документ говорит, что "Обнаружено нулевое количество при пересчете в единицу хранения в строке n списка "Товары" и так по каждой строке... Само поле Кол-во (которое на самом деле КоличествоУпаковок заполнено).
Для каждого СтрокаТЧ из Основание.Товары Цикл 

    ЗапросВариантаКомплектации = Новый Запрос();
    ЗапросВариантаКомплектации.Текст =
    "ВЫБРАТЬ
    | ВариантыКомплектацииНоменклатуры.Номенклатура.Ссылка КАК Номенклатура,
    |   ВариантыКомплектацииНоменклатуры.Количество КАК Количество,
    |   ВариантыКомплектацииНоменклатуры.Упаковка КАК Упаковка,
    |   ВариантыКомплектацииНоменклатуры.КоличествоУпаковок КАК КоличествоУпаковок
    |
    |ИЗ
    | Справочник.ВариантыКомплектацииНоменклатуры.Товары КАК ВариантыКомплектацииНоменклатуры
    |ГДЕ
    | ВариантыКомплектацииНоменклатуры.Ссылка.Владелец = &Ссылка
    |   И ВариантыКомплектацииНоменклатуры.Ссылка.Основной
    |УПОРЯДОЧИТЬ ПО
    | ВариантыКомплектацииНоменклатуры.НомерСтроки";
   
    ЗапросВариантаКомплектации.УстановитьПараметр("Ссылка", СтрокаТЧ.Номенклатура);
    Выборка = ЗапросВариантаКомплектации.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
   
    НоваяСтрока = НовыйОбъект.Товары.Добавить();
    НоваяСтрока.Номенклатура = Выборка.Номенклатура;
НоваяСтрока.КоличествоУпаковок = Выборка.Количество * СтрокаТЧ.Количество;
НоваяСтрока.Количество = Выборка.Количество * СтрокаТЧ.Количество;

    КонецЦикла;

КонецЦикла;

2. Пытаюсь указать ссылку на документ основание таким способом
Процедура СоздатьНовыйДокумент(Элемент, НовыйОбъект)

    Основание = Элемент.Ссылка;

    НовыйОбъект.Дата = ТекущаяДата();
    НовыйОбъект.Организация = Основание.Организация;
    НовыйОбъект.Склад = "";
    НовыйОбъект.ДокументОснование = Основание;\
    ...
КонецПроцедуры
но ничего не заполняется...

Буду очень благодарна за советы!


Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Может это связано с тем, что нет информации о том сколько в упаковке количества товара.
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн golovina

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-31
  • Сайт: 
Добавила строку при заполнении
НоваяСтрока.Упаковка = Выборка.Упаковка;
Не спасло.
Причем ошибка уходит если руками перевыбрать позицию номенклатуры или количество.
Добавлено: 12 Авг 2015, 15:52

С первой проблемой разобралась, осталась 2-ая

Последний раз редактировалось: golovina; 12 Авг 2015, 15:52. Причина: Объединение сообщений

Онлайн Kironten

  • *****
  • Сообщений: 902
  • РЕПУТАЦИЯ: 185
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С

С первой проблемой разобралась, осталась 2-ая

Если значение в "Основание" заполнено, то проверяйте типы. Возможно несовпадение в них.

Оффлайн golovina

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-31
  • Сайт: 
Я вот тоже думала про несовпадение типов.
Тип ДокументОснование - ДокументСсылка.ЗаказКлиента
а элемент - это ЗаказКлиента. В процессе выполнения Элемент.Ссылка принимает значение "Заказ клиента ОМТ-00001 от 07.08.2015 12:40:48" вроде бы все норм... это же значение имеет и ДокументОснование после строки присваивания.
Поэтому я в тупике.
Добавлено: 14 Авг 2015, 10:19

Ситуация прояснилась. Судя по структуре подчиненности поле заполняется корректно.
В процедуре ПриСозданииНаСервере есть строка
ОбщегоНазначенияУТКлиентСервер.УстановитьСвойствоЭлементаФормы(Элементы, "ГруппаОснование", "Видимость", ЗначениеЗаполнено(Объект.ДокументОснование));
Она то и делает невидимым ГруппуОснование.... странно конечно
Всем спасибо!

Последний раз редактировалось: golovina; 14 Авг 2015, 10:19. Причина: Объединение сообщений


Теги:
 

Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8560
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Обработка "ПодборНоменклатуры"

Автор BigAnnРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2964
Последний ответ 18 Апр 2012, 20:38
от Dethmontt
Обработка "СогласованиеЗаявок"

Автор Денис АндрушкоРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 801
Последний ответ 24 Сен 2016, 00:37
от Денис Андрушко
Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4470
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Автоматическое создание " Заполнение" документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4441
Последний ответ 06 Мар 2014, 14:48
от mashencev_anton

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 586
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal