Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 07:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: процедура приИзменении  (Прочитано 8583 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SW

  • **
  • Сообщений: 77
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-10-30
  • Сайт: 
Помогите пожалуйста написать процедуру, при которой выполняется следущее:
есть поля: Фамилия, Имя, Отчество. Так же есть поле Наименование, которое должно заполняться автоматически при внесении информации в три предыдущих поля. как это граммотно и рационально реализовать?

есть такой вариант:

Процедура ФамилияПриИзменении(Элемент)

Наименование = Фамилия + " " + Имя + " " + Отчество;
КонецПроцедуры

Процедура ИмяПриИзменении(Элемент)
Наименование = Фамилия + " " + Имя + " " + Отчество; 
КонецПроцедуры

Процедура ОтчествоПриИзменении(Элемент)
Наименование = Фамилия + " " + Имя + " " + Отчество;
КонецПроцедуры

Есть другие варианты процедуры???


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Сделать процедуру
Процедура СформироватьНаименование()
Наименование = Фамилия + " " + Имя + " " + Отчество;
КонецПроцедуры
И обращаться к ней из процедур при изменении:
Процедура ФамилияПриИзменении(Элемент)
СформироватьНаименование();
КонецПроцедуры
и т.п.

Оффлайн SW

  • **
  • Сообщений: 77
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-10-30
  • Сайт: 
Спасибо )

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Пожалуйста, пишите снова :)

Оффлайн SW

  • **
  • Сообщений: 77
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-10-30
  • Сайт: 
и снова вопрос ))

Есть справочник Комната, в котором есть поля: Номер, Тип, Доп.информация. Есть документ с полем Номер Комнаты и табличная часть с реквизитами Тип, Доп.информация.

ЗАДАЧА: нужно при внесении информации в поле Тип в документе, чтоб в табличную часть заносилась информация из справочника Комната автоматически.

Оффлайн SW

  • **
  • Сообщений: 77
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-10-30
  • Сайт: 
ПОПРАВКА!!!
и снова вопрос ))

Есть справочник Комната, в котором есть поля: Номер, Тип, Доп.информация. Есть документ с полем Номер Комнаты и табличная часть с реквизитами Тип, Доп.информация.

ЗАДАЧА: нужно при внесении информации в поле Номер комнаты в документе, чтоб в табличную часть заносилась информация из справочника Комната автоматически.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
А зачем вы эти реквизиты храните в табличной части документа? Если в справочнике это простые поля, какой смысл делать их в документе таблицей? Опишите, чего вы хотите добиться, чтоб нам придумать оптимальное решение.

Оффлайн SW

  • **
  • Сообщений: 77
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-10-30
  • Сайт: 
делаю документ, вношу номер выбором из справочника и ниже в таблице должна отображаться вся информация о данном номер автоматически. Наглядно и удобно получается.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Согласен, разумно, но почему эта информация должна отображаться в табличной части, а например, не просто текстовыми полями?

Оффлайн SW

  • **
  • Сообщений: 77
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-10-30
  • Сайт: 
Это информация удобней воспринимается таблицей, и меньше места занимает на окне.


Теги:
 

Процедура "ОбработкаПроведения"

Автор demon3Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1267
Последний ответ 22 Июн 2016, 14:46
от demon3
Процедура "Подсчет площади"

Автор Seregin63Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2614
Последний ответ 28 Ноя 2013, 13:00
от Seregin63
1c 8.2: как называется процедура/функция, которая вызывается при вводе значения в поле на форме?

Автор jhd235Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1570
Последний ответ 08 Сен 2014, 08:28
от cska-fanat-kz
Процедура госрегистрации ИП и юрлиц будет проходить в течение трех дней

Автор newsРаздел Новости

Ответов: 0
Просмотров: 749
Последний ответ 03 Апр 2014, 15:16
от news
Процедура Инициализации при создании внешней обработки таб. частей

Автор crow1983Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 11691
Последний ответ 23 Авг 2010, 16:51
от crow1983

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 360
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal