Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1C 8.2 Получение данных из РегистраСведений  (Прочитано 2238 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mauar

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-29
  • Сайт: 
Есть документ с договорами у него есть значение состояние договора (отложенный, важный, зеленый, красный и т.д ) данное состояние находится в справочнике состояние, нужно сделать так:

Для выбранного пользователя запретить отображать документ с определенным состоянием например "Отложенный". То есть для примера: пользователь "Вася Пупкин" не должен видеть договора у которых стоит состояние "Отложенный".

Но мне нужно сперва сделать так чтобы получить этого пользователя из РегистраСведений и сравнить его с запущенным пользователем.

Я делаю так, создал документ у которого есть выбор пользователя и выбор состояния, данному документу я делаю движения по региструсведений и сохраняю там Васю Пупкина и Состяние.

Мне нужно сравнить ПараметровСеанса.ТекущийПользователь() с пользователем который записан в РегистреСведений,
то есть если пользователь Вася Пупкин записан в этот регистр сведений и он запускает 1С то только этому пользователю делаем определенное действия, например просто вывести ему сообщение,
делаю так:

Процедура НайтиПользователя() Экспорт
     
Польз=ПараметрыСеанса.ТекущийПользователь;     
     
ПользовательРег = РегистрыСведений.СостояниеРегистр;
НаборПользователей = ПользовательРег.СоздатьНаборЗаписей();
ВыбранныйПольз = Справочники.Пользователи.НайтиПоНаименованию(Польз);
НаборПользователей.Отбор.Пользователь.Установить(ВыбранныйПольз);
НаборПользователей.Прочитать();

Если НаборПользователей=Польз тогда
    сообщить("Получилось");
КонецЕсли;     
КонецПроцедуры

Далее эту процедуру вставляю в модуль управляемого приложения конфигурации в процедуру ПриНачалеРаботыСистемы.


Оффлайн mdv

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 2
  • КПД: 13%
  • Регистрация: 2010-10-29
  • Сайт: 
Если НаборПользователей.Пользователь = Польз тогда
    сообщить("Получилось");
КонецЕсли;

Оффлайн mauar

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-29
  • Сайт: 
Я уже решил проблему спасибо, сделал запросом! Тема закрыта!


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7429
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3881
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2111
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7319
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6946
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 340
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal