Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 23:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поиск документа с помощью НайтиПоНомеру. СписокЗначений.  (Прочитано 2311 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DeSjeT

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2010-10-11
  • Сайт: 
  • Профессия: Программист 8.1
Не могу Выбрать() нужный мне документ, словно отказывается искать по коду нужный мне документ.
Сделал запросом (второй способ - закомментированный), всё работает корректно, но т.к. я передаю из базы в базу через COM соединение, то мне нужный первый способ (который написал в коде), не работает!

Док =  Документы.НДФЛиЕСНДоходыИНалоги.Выбрать();

СписокЗначений = Новый СписокЗначений;

Пока Док.Следующий() Цикл

СписокЗначений.Добавить(Док.Номер,Док.Ссылка);

КонецЦикла;

ВыбратьЗначение = СписокЗначений.ВыбратьЭлемент("Выберите документ");
Номер = ВыбратьЗначение.Значение;

//Первый способ, нужный мне - не работает
НужныйДокумент = Документы.НДФЛиЕСНДоходыИНалоги.НайтиПоНомеру(Номер);

//Второй способ - работает корректно
//ЗапросДокумента = Новый Запрос;
//
//ЗапросДокумента.Текст = "ВЫБРАТЬ
// | НДФЛиЕСНДоходыИНалоги.Ссылка
// |ИЗ
// | Документ.НДФЛиЕСНДоходыИНалоги КАК НДФЛиЕСНДоходыИНалоги
// |ГДЕ
// | НДФЛиЕСНДоходыИНалоги.Номер = &Номер";
//ЗапросДокумента.УстановитьПараметр("Номер",Номер);
//Выбор = ЗапросДокумента.Выполнить().Выбрать();

//Пока Выбор.Следующий() Цикл
//
// НужныйДокумент = Выбор.Ссылка;
Сообщить(НужныйДокумент);
//
//КонецЦикла;

//Поиск выбранного НужногоДокумента и просмотр его
Док =  Документы.НДФЛиЕСНДоходыИНалоги.Выбрать();

Пока Док.Следующий() Цикл

Если Док.Ссылка = НужныйДокумент Тогда
Сообщить(док.НалоговыйПериод);
КонецЕсли;

КонецЦикла;

Возможно можно переделать запрос для COM соединения?


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Все правильно.
Вам помимо номера нужно вторым параметром передать дату.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Обратите внимание, у большинства документов нумерация в пределах года. Поэтому в базе может быть несколько документов с одним и тем же номером, но разной датой.

Оффлайн DeSjeT

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2010-10-11
  • Сайт: 
  • Профессия: Программист 8.1
В синтаксис-помощнике сказано, что Дата не обязательный параметр который нужен указать для поиска. Все же мне придётся его использовать как ключевой элемент для поиска?

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Да использовать его все же придется.


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4491
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15972
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4215
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 650
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7764
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 297
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal