Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 07:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Схема компоновки средствами встроенного языка  (Прочитано 6079 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
Есть схема компоновки данных, хочу поменять поле (Конечное сальдо), как сделать средствами встроенного языка?

есть такой цикл, может в нем как то добавляется это поле

Для каждого ЭлементОтбора из МассивОтборов Цикл
Если ТипЗнч(ЭлементОтбора) = Тип("ГруппаЭлементовОтбораКомпоновкиДанных") тогда
Продолжить;
КонецЕсли;
Если ЭлементОтбора.Использование
   и ЭлементОтбора.ВидСравнения    = ВидСравненияКомпоновкиДанных.Равно
   и (ЭлементОтбора.ПравоеЗначение = Новый ПолеКомпоновкиДанных("ИмяВидаРасчета") или ЭлементОтбора.ПравоеЗначение = "Конечное сальдо" или ЭлементОтбора.ПравоеЗначение = "Начальное сальдо")
   и (ЭлементОтбора.ЛевоеЗначение  = Новый ПолеКомпоновкиДанных("ИмяВидаРасчета") или ЭлементОтбора.ЛевоеЗначение = "Конечное сальдо" или ЭлементОтбора.ЛевоеЗначение = "Начальное сальдо")
    тогда
ТиповыеОтчеты.УстановитьПараметрВывода(КомпоновщикНастроек, "VerticalOverallPlacement", РасположениеИтоговКомпоновкиДанных.Нет);
КонецЕсли;
КонецЦикла;


Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
как программно удалить поле вывода отчета?

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 

Оффлайн veslav

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 7
  • КПД: 27%
  • Регистрация: 2010-04-30
  • Сайт: 
что-то типа этого:

СхемаКД = ЭтотОбъект.СхемаКомпоновкиДанных;
НаборДанныхЗапрос = СхемаКД.НаборыДанных.Найти("НаборДанных1");
ИмяПоля="ПериодНачала";
ПолеНабораДанных = НаборДанныхЗапрос.Поля.Добавить(Тип("ПолеНабораДанныхСхемыКомпоновкиДанных"));
ПолеНабораДанных.ПутьКДанным = ИмяПоля;
ПолеНабораДанных.Поле = ИмяПоля;
ПолеНабораДанных.Заголовок = ИмяПоля;   

НаборДанныхЗапрос.Поля.Удалить(ПолеНабораДанных);

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
это удалить? как сделать чтобы можно было изменить,добавить новое поле

Оффлайн veslav

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 7
  • КПД: 27%
  • Регистрация: 2010-04-30
  • Сайт: 
добавить новое поле так:

ПолеНабораДанных = НаборДанныхЗапрос.Поля.Добавить(Тип("ПолеНабораДанныхСхемыКомпоновкиДанных"));
    ПолеНабораДанных.ПутьКДанным = ИмяПоля;
    ПолеНабораДанных.Поле = ИмяПоля;
    ПолеНабораДанных.Заголовок = "Заголовок";

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
veslav тебя не затруднит, объяснить мне как попадают данные в поле "Конечное сальдо", вот файл объясни пожалуйста, уже 2 недели борюсь не могу справиться, не знаю даже какую часть кода скинуть, чтобы объяснили

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 

Оффлайн veslav

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 7
  • КПД: 27%
  • Регистрация: 2010-04-30
  • Сайт: 
При открытии скд выдает ошибку:

Ошибка получения информации набора данных
по причине:
Ошибка в запросе набора данных
по причине:
{(89, 23)}: Поле не найдено "БУОсновныеНачисления.СтатьяФинансирования"
БУОсновныеНачисления.<<?>>СтатьяФинансирования,

Что за конфа, платформа?

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
1С:Предприятие 8.1 (8.1.15.14)
Зарплата и кадры бюджетного учреждения, редакция 1.0 (1.0.16.5)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
176 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
41 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 331
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal