Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Сен 2020, 01:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Схема компоновки средствами встроенного языка  (Прочитано 8793 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
Есть схема компоновки данных, хочу поменять поле (Конечное сальдо), как сделать средствами встроенного языка?

есть такой цикл, может в нем как то добавляется это поле

Для каждого ЭлементОтбора из МассивОтборов Цикл
Если ТипЗнч(ЭлементОтбора) = Тип("ГруппаЭлементовОтбораКомпоновкиДанных") тогда
Продолжить;
КонецЕсли;
Если ЭлементОтбора.Использование
   и ЭлементОтбора.ВидСравнения    = ВидСравненияКомпоновкиДанных.Равно
   и (ЭлементОтбора.ПравоеЗначение = Новый ПолеКомпоновкиДанных("ИмяВидаРасчета") или ЭлементОтбора.ПравоеЗначение = "Конечное сальдо" или ЭлементОтбора.ПравоеЗначение = "Начальное сальдо")
   и (ЭлементОтбора.ЛевоеЗначение  = Новый ПолеКомпоновкиДанных("ИмяВидаРасчета") или ЭлементОтбора.ЛевоеЗначение = "Конечное сальдо" или ЭлементОтбора.ЛевоеЗначение = "Начальное сальдо")
    тогда
ТиповыеОтчеты.УстановитьПараметрВывода(КомпоновщикНастроек, "VerticalOverallPlacement", РасположениеИтоговКомпоновкиДанных.Нет);
КонецЕсли;
КонецЦикла;


Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
как программно удалить поле вывода отчета?

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 

Оффлайн veslav

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 7
  • КПД: 27%
  • Регистрация: 2010-04-30
  • Сайт: 
что-то типа этого:

СхемаКД = ЭтотОбъект.СхемаКомпоновкиДанных;
НаборДанныхЗапрос = СхемаКД.НаборыДанных.Найти("НаборДанных1");
ИмяПоля="ПериодНачала";
ПолеНабораДанных = НаборДанныхЗапрос.Поля.Добавить(Тип("ПолеНабораДанныхСхемыКомпоновкиДанных"));
ПолеНабораДанных.ПутьКДанным = ИмяПоля;
ПолеНабораДанных.Поле = ИмяПоля;
ПолеНабораДанных.Заголовок = ИмяПоля;   

НаборДанныхЗапрос.Поля.Удалить(ПолеНабораДанных);

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
это удалить? как сделать чтобы можно было изменить,добавить новое поле

Оффлайн veslav

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 7
  • КПД: 27%
  • Регистрация: 2010-04-30
  • Сайт: 
добавить новое поле так:

ПолеНабораДанных = НаборДанныхЗапрос.Поля.Добавить(Тип("ПолеНабораДанныхСхемыКомпоновкиДанных"));
    ПолеНабораДанных.ПутьКДанным = ИмяПоля;
    ПолеНабораДанных.Поле = ИмяПоля;
    ПолеНабораДанных.Заголовок = "Заголовок";

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
veslav тебя не затруднит, объяснить мне как попадают данные в поле "Конечное сальдо", вот файл объясни пожалуйста, уже 2 недели борюсь не могу справиться, не знаю даже какую часть кода скинуть, чтобы объяснили

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 

Оффлайн veslav

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 7
  • КПД: 27%
  • Регистрация: 2010-04-30
  • Сайт: 
При открытии скд выдает ошибку:

Ошибка получения информации набора данных
по причине:
Ошибка в запросе набора данных
по причине:
{(89, 23)}: Поле не найдено "БУОсновныеНачисления.СтатьяФинансирования"
БУОсновныеНачисления.<<?>>СтатьяФинансирования,

Что за конфа, платформа?

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
1С:Предприятие 8.1 (8.1.15.14)
Зарплата и кадры бюджетного учреждения, редакция 1.0 (1.0.16.5)


Теги:
 

Неясна схема создания документов в "1С: ERP УП 2.1".

Автор РексарычРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3509
Последний ответ 29 Июн 2016, 12:04
от Sandi
Помогите найти "Консоль системы компоновки данных" 8.2

Автор SvenSoftРаздел Закрытые темы

Ответов: 1
Просмотров: 4868
Последний ответ 15 Янв 2012, 06:12
от SvenSoft
Что такое "Форма" с точки зрения языка программирования?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 2986
Последний ответ 13 Мар 2017, 12:38
от Kironten
Система компоновки данных – как в макете реализовать сложение(вычитание) ячеек?

Автор sapravkaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4983
Последний ответ 14 Фев 2013, 22:34
от sapravka
Ошибка создания источника доступных настроек компоновки данных

Автор MuI_I_IkaРаздел Ошибки 1С:Предприятия

Ответов: 0
Просмотров: 8556
Последний ответ 16 Июл 2014, 11:59
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
oooo800
39 Сообщений
LexaK
31 Сообщений
Дмитрий Джей Дмитрий Джей
29 Сообщений
IL2016
28 Сообщений
antoneus antoneus
24 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
alexandr_ll
10 Сообщений

* Кто онлайн

  • Точка Гостей: 189
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal