Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 15:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Копирование данных из одного регистра сведений в другой  (Прочитано 15119 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ahmeda

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-18
  • Сайт: 
Здравствуйте!
Подскажите пожалуйста, как скопировать содержимое регистра сведений в идентичный регистр той же базы (8.1).
Пробывал по аналогии со справочниками: выгрузить в XML получилось, а как залить (измерения, регистры) не пойму.
Измерения: Наименование, ЕдИзм;
Реквизит: Цена

Спасибо


Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
попробуйте обработку создать по загрузке из файла

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
попробуйте обработку создать по загрузке из файла


Кстати, вариант.

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
в ЗиУП есть типовая обработка "Загрузка данных из табличного документа", регистров и табличных частей. Удобная очень.

Оффлайн ahmeda

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-18
  • Сайт: 
попробуйте обработку создать по загрузке из файла


да я и пытаюсь, только с кодом не получается

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
попробуйте обработку создать по загрузке из файла


да я и пытаюсь, только с кодом не получается
Посмотрите, пожалуйста тему http://forum-1c.ru/index.php?topic=5135.0. Там пример есть.

Если что-то не понятно - спрашивайте.

Оффлайн ahmeda

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-18
  • Сайт: 
ДанныеXML = Новый ЧтениеXML;
ДанныеXML.ОткрытьФайл("Z:\kontragenty.xml");
Пока ДанныеXML.Прочитать() Цикл
   Пока ДанныеXML.Прочитать() Цикл
      Пока ДанныеXML.Прочитать() Цикл
         Если ВозможностьЧтенияXML(ДанныеXML) Тогда
            НовыйОбъект = ПрочитатьXML(ДанныеXML);
            НовыйОбъект.Записать();
         КонецЕсли;
      КонецЦикла;
   КонецЦикла;
КонецЦикла;
ДанныеXML.Закрыть();

Это код загрузки. А как указать что данные должны загрузиться в РегистрСведений.ОтпускныеЦены?
Я не объяснил свою схему: На общей форме я создал две кнопки:Кнопка1-выгрузка (работает), Кнопка2-загрузка (не работает)

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С

Оффлайн ahmeda

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-18
  • Сайт: 
Код выгрузки какой?

Вот:

Процедура Кнопка3Нажатие(Элемент)
   Текст=Новый ТекстовыйДокумент;
    Выборка=РегистрыСведений.УстановкаЦен.Выбрать();
   Пока Выборка.Следующий() Цикл
    Стр=СтрЗаменить(Выборка.Номенклатура,Символ(34),"%квч%");
   ЕИ=Строка(Выборка.ЕдиницаИзмерения)+Символ(34);
   //Цена=Строка(Выборка.Цена)+Символ(34);
   Текст.ДобавитьСтроку(Стр+ЕИ);
    
КонецЦикла;
Текст.Записать("C:\11\текст.txt");
КонецПроцедуры

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Так вы выгружали в текстовый файл?


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7446
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3888
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2120
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7352
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6961
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
alex0402
52 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal