Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Сен 2020, 12:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: перебор полей документа word  (Прочитано 3896 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн RuslanYol

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-23
  • Сайт: 
При переборе полей документа word созданного из шаблона, 1c выдает ошибку
Если Документ.FormFields.Item(х).Name="НомерДоговора" Тогда
{Документ.МастерДоговор.Форма.Модуль(2052)}: Microsoft Word: Запрашиваемый номер семейства не существует.       

в чем может быть проблема?

текст процедуры:
Процедура СоздатьДокументИзШаблона()
   Если Список.ПолучитьЗначение(Список.ТекущаяСтрока())<>"без договора" Тогда
      СписокШаблонов = СоздатьОбъект("Справочник.Шаблоны");                   
      Если СписокШаблонов.ВыбратьЭлементы()=1 Тогда
          Пока СписокШаблонов.ПолучитьЭлемент()=1 Цикл
             Если СокрЛП(СписокШаблонов.Наименование)=Список.ПолучитьЗначение(Список.ТекущаяСтрока()) Тогда
                ФайлШаблона=глКаталогШаблонов+СокрЛП(СписокШаблонов.ФайлШаблона);   
               Прервать;               
             КонецЕсли;
         КонецЦикла;          
      КонецЕсли;            
      Если (ПустоеЗначение(ФайлШаблона)=0) И (ФС.СуществуетФайл(ФайлШаблона)=1) Тогда
         //--создание файла из образа шаблона   
         Попытка
            Word = СоздатьОбъект("Word.Application");
            Word.Caption="Договор №"+СокрЛП(НомерДог)+ " от "+Строка(ДатаПодписания);
            Word.Visible = 0;
            Документ=Word.Documents.Add(ФайлШаблона);      
         Исключение
            Предупреждение("Ошибка при открытии документа");
            СтатусВозврата(0);
         КонецПопытки;     
         
         СтрокаДата="""___""___________"+"20___г.";         
         
         //--перебор всех полей шаблона
         Если Документ.FormFields.Count>0 Тогда       
            //--перебор полей word            
            Для х=1 По Документ.FormFields.Count Цикл                  
               Если Документ.FormFields.Item(х).Name="НомерДоговора" Тогда
                  Если ПустоеЗначение(НомерДог)=0 Тогда
                     Документ.FormFields.Item(х).Result = СокрЛП(НомерДог);      
                  Иначе   
                     Документ.FormFields.Item(х).Result = "________";
                  КонецЕсли;
                  Продолжить;
               КонецЕсли;     
               
               //--------------------------
            КонецЦикла; 
         КонецЕсли;
      КонецЕсли;
   КонецЕсли;
КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
oooo800
39 Сообщений
LexaK
31 Сообщений
Дмитрий Джей Дмитрий Джей
29 Сообщений
IL2016
28 Сообщений
antoneus antoneus
24 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
ToryFree ToryFree
10 Сообщений

* Кто онлайн

  • Точка Гостей: 243
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal