Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Сен 2020, 21:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: пустые строки в оборотно-сальдовой ведомости  (Прочитано 10833 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Людмила Р.

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-21
  • Сайт: 
Всем добрый день!

Проблема в том, что очень надо сделать так что бы в оборотно-сальдовой ведомости (ОСВ) выходили все счета, даже те что не имеют сальдо на начало и конец периода и оборотов по периоду. Необходимость появилась потому что бухгалтер после формирования ОСВ в 1С импортирует её в эксель и используя формулу сравнивает с данными имеющими такую же структуру. (для чего не знаю) Пересмотрела весь модуль ОСВ нашла несколько условий похожих на удаление пустых строк, но закоментив их результат не получился. 


Спасибо за ответы ) 


Оффлайн Людмила Р.

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-21
  • Сайт: 
Думала что написала  :nhsrm:
1С Предприятие 7.7 (сетевая версия)
Бухгалтерский учет для Казахстана (7.7)

Оффлайн prog1c7.7

  • *****
  • Сообщений: 793
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Даже те что не имеют оборотов между счетами?

Оффлайн Людмила Р.

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-21
  • Сайт: 
Даже те что не имеют оборотов между счетами?

Получается нужны все какие только возможны, порядок и группировку счетов уже получилось изменить на нужный, а вот что бы все выходили не получается.

Оффлайн prog1c7.7

  • *****
  • Сообщений: 793
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
в цикле выборки итогов  есть  проверка на  СНД СКК ДО КО и прочее
например:
Если ИтогиНеРавныНулю(РазвСальдоИт, 1) = 0 Тогда
    Продолжить;
КонецЕсли;
Помоему так если не ошибаюсь

Оффлайн Людмила Р.

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-21
  • Сайт: 
в цикле выборки итогов  есть  проверка на  СНД СКК ДО КО и прочее
например:
Если ИтогиНеРавныНулю(РазвСальдоИт, 1) = 0 Тогда
    Продолжить;
КонецЕсли;
Помоему так если не ошибаюсь

Что нибудь подобное не нашла  :fdbsdfbsd:


По моему это где то тут?
   Пока Субсчета.ПолучитьСчет(0) = 1 Цикл
         // Выберем итоги по текущему субсчету
         Если Ит.ПолучитьСчет(, Субсчета.ТекущийСчет()) = 1 Тогда
            НайденоПоСчету = 1;
            Если ПарамВалюта <> ПолучитьПустоеЗначение() Тогда
               // Выберем итоги по уаказанной валюте
               НайденоПоСчету = Ит.ПолучитьВалюту(, ПарамВалюта);
            КонецЕсли;
            Если НайденоПоСчету = 1 Тогда
               Если СальдоПолучить(Субсчета.ТекущийСчет(), ВремСНД, ВремСНК, ВремСКД, ВремСКК, ТипСуммы, ПарамВалюта) = 1 Тогда
                  Найдено = 1;
                  СНД = СНД + ВремСНД;
                  СНК = СНК + ВремСНК;
                  СКД = СКД + ВремСКД;
                  СКК = СКК + ВремСКК;
               КонецЕсли;
            КонецЕсли;
         КонецЕсли;
      КонецЦикла;

Оффлайн prog1c7.7

  • *****
  • Сообщений: 793
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
это ОСВ или ОСВ по счету?
Модуль оборотки на мыло кинь.

Оффлайн Людмила Р.

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-21
  • Сайт: 
это ОСВ или ОСВ по счету?
Модуль оборотки на мыло кинь.

Это стандартная оборотно-сальдовая ведомость. )

Оффлайн prog1c7.7

  • *****
  • Сообщений: 793
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
все равно модуль выложи

Оффлайн Людмила Р.

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-21
  • Сайт: 


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
33 Сообщений
oooo800
32 Сообщений
Дмитрий Джей Дмитрий Джей
28 Сообщений
IL2016
25 Сообщений
antoneus antoneus
21 Сообщений
DmitriyF DmitriyF
18 Сообщений
Ann_
16 Сообщений
SoOliateR
15 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 219
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal