Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 04:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как получить значение ячейки??  (Прочитано 8521 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1С-Ученик

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-21
  • Сайт: 
Есть документ Поступление товаров и услуг, в этом документе есть табличная часть товары.

Как получить конкретное значение ячейки в колоке Цена, т.е. нужно при активизации конкрентной ячейки получить ее значение

Код предполагаю писать в следующие процедуры:
Процедура ТоварыПриАктивизацииСтроки(Элемент)
Процедура ТоварыПриАктивизацииЯчейки(Элемент)

Но вот какой код - для меня это загадка.
Пробовал вот так:
ЭлементыФормы.Товары.Колонки.Цена.Данные
Не подходит.

Господа профи подскажите как быть?


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Попробуйте так:
Процедура ТабличнаяЧасть1ПриАктивизацииСтроки(Элемент)
      ТекущиеДанные = ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные;
        Сообщить(ТекущиеДанные.Реквизит1);
КонецПроцедуры

Оффлайн 1С-Ученик

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-21
  • Сайт: 
Попробуйте так:
Процедура ТабличнаяЧасть1ПриАктивизацииСтроки(Элемент)
      ТекущиеДанные = ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные;
        Сообщить(ТекущиеДанные.Реквизит1);
КонецПроцедуры


Браво!!! Все работает!!!!!  :zebzdr: :zebzdr: :zebzdr:

 :befhbt:А теперь вот еще задачка - продолжение предыдущей:

Нужно чтобы при открытии документа Поступление товаров и услуг (документ проведен) запретить изменять ячейку в колоке цена, если значение НЕ пустое (т.е. цена есть)
Я делаю:
ПриОткрытии()
ЭлементыФормы.Товары.Колонки.Цена.Доступность = Ложь;
Тем самы я блокирую всю колонку Цена

А затем в этот же документ если добавить новую строку, то то колонака Цена будет заблокирована и не помогает такой код:
Процедура ТоварыПередНачаломДобавления(Элемент, Отказ, Копирование)
ЭлементыФормы.Товары.Колонки.Цена.Доступность = Истина;
КонецПроцедуры

В этом случае разблокируется вся колонка Цена, а нужно чтобы можно было добавить новое значение, если ячейка пустая
Как так сделать?

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Интересная задачка. :) Что-то сходу оптимального решения не придумаю.
Но подход можно и такой выбрать:
Перем ТекРеквизит;

Процедура ТабличнаяЧасть1ПриАктивизацииСтроки(Элемент)
ТекущиеДанные = ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные;
ТекРеквизит = ТекущиеДанные.Реквизит1;
КонецПроцедуры

Процедура ТабличнаяЧасть1Реквизит1ПриИзменении(Элемент)
ТекущиеДанные = ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные;
Если ЗначениеЗаполнено(ТекРеквизит) Тогда
Сообщить("НЕЛЬЗЯ!");
ТекущиеДанные.Реквизит1 = ТекРеквизит;
КонецЕсли;
КонецПроцедуры

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
То есть проверяем был ли пустой реквизит и если был то все ОК, если нет, то меняем на старое значение.

Оффлайн 1С-Ученик

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-21
  • Сайт: 
Увы...не работает. Цену все равно можно редактировать, закрыв табло. А при выделении курсором ячейки, ее значение становить нулевым...
Я уже весь мосг сломал над этой задаче, а решения увы так и не нашел

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Что значит закрыв табло?

Оффлайн 1С-Ученик

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-21
  • Сайт: 
Заработало!!!
Процедура ТоварыПередНачаломИзменения(Элемент, Отказ)
//fortis
ТекущиеДанные = ЭлементыФормы.Товары.ТекущиеДанные;
Если ЗначениеЗаполнено(ТекущиеДанные.Цена) Тогда
ЭлементыФормы.Товары.Колонки.Цена.Доступность = ложь;
Сообщить ("Цена Есть");
иначе
Сообщить ("Цены НЕТ");
ЭлементыФормы.Товары.Колонки.Цена.Доступность = истина;


КонецЕсли;


КонецПроцедуры

Все ок!
Но! При добавлении новой строки в табличную часть, ячейка новой строки в колонке цена не редактируется - также как и все остальные ячейки в этой колонки. Для того чтобы вписать цену в ячейку новой строки нужно щелкнуить на соседнию ячейку в этой строке и тогда ячейка в колонке цена будет активна!!
Чудеса, хотя их не бывает...


Теги:
 

Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6884
Последний ответ 24 Ноя 2014, 12:21
от gigson
Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 4154
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3247
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 975
Последний ответ 23 Ноя 2016, 12:53
от sertak
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8561
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 160
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal