Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Сен 2020, 14:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Загрузка/Выгрузка в XML  (Прочитано 31729 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
Объясните пожалуйста, как вручную выгрузить справочник Контрагенты с договорами из одной базы и загрузить в другую через XML-документ. Конфигурация у баз одинаковая.


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
"универсальный обмен данными xml"?

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
да, только вручную, программно внешней обработкой, не обращаясь к универсальному обмену данными

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Простейший вариант выгрузки
ФXML = Новый ЗаписьXML;
ФXML.ОткрытьФайл("Z:\kontragenty.xml");
ФXML.ЗаписатьНачалоЭлемента("Главный");
Выборка = Справочники.Контрагенты.Выбрать();
Пока Выборка.Следующий() Цикл
ЗаписатьXML(ФXML, Выборка.ПолучитьОбъект());
КонецЦикла;
 ФXML.ЗаписатьКонецЭлемента();
 ФXML.Закрыть();

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
И он целиком выгрузится со всеми реквизитами  в виде дерева или только наименования в столбик?

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Со всеми реквизитами. Там где в реквизитах тип значения ссылочный выгрузится внутренний идентификатор объекта

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
Хорошо, а обратно как загрузить в другую базу? Со всеми реквизитами

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
то есть изначально я должна создать чистый файл с расширенbем XML, чтобы потом выбрать?

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
Документ сам создался))

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Вот готовый комплект:
Выгрузка:
Файл = Новый ЗаписьXML;
Файл.ОткрытьФайл("Z:\kontragenty.xml");
Файл.ЗаписатьНачалоЭлемента("Главный");
Выборка = Справочники.Контрагенты.Выбрать();
Пока Выборка.Следующий() Цикл
Файл.ЗаписатьНачалоЭлемента("Элемент");
ЗаписатьXML(Файл, Выборка.ПолучитьОбъект());
Файл.ЗаписатьКонецЭлемента();
КонецЦикла;
Файл.ЗаписатьКонецЭлемента();
Файл.Закрыть();
и загрузка
ДанныеXML = Новый ЧтениеXML;
ДанныеXML.ОткрытьФайл("Z:\kontragenty.xml");
Пока ДанныеXML.Прочитать() Цикл
Пока ДанныеXML.Прочитать() Цикл
Пока ДанныеXML.Прочитать() Цикл
Если ВозможностьЧтенияXML(ДанныеXML) Тогда
НовыйОбъект = ПрочитатьXML(ДанныеXML);
НовыйОбъект.Записать();
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецЦикла;
ДанныеXML.Закрыть();


Теги:
 

выгрузка из "Платежные документы" выборочно в "Бухгалтерию предприятия"

Автор hkvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 7132
Последний ответ 09 Окт 2014, 15:58
от дфтын
Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4352
Последний ответ 10 Ноя 2015, 16:20
от vitasw
выгрузка в УПП через Конвертацию "Проведение документа: Платежное поручение исходящее Не совпадают сумма документа и ее расшифровка"

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1235
Последний ответ 03 Янв 2019, 00:00
от Св Ч
Модуль "выгрузка в банк"

Автор Dima IgnatovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1955
Последний ответ 11 Май 2016, 13:23
от Rasty
загрузка из "клиента банка"

Автор miximlРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3870
Последний ответ 19 Июн 2012, 09:49
от miximl

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
34 Сообщений
oooo800
30 Сообщений
Дмитрий Джей Дмитрий Джей
27 Сообщений
antoneus antoneus
18 Сообщений
DmitriyF DmitriyF
17 Сообщений
IL2016
16 Сообщений
Ann_
16 Сообщений
SoOliateR
15 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 598
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal