Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 18:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с выборкой  (Прочитано 9997 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mult_ru

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-20
  • Сайт: 
Подскажите как можно реализовать данный алгоритм.
В справочнике "контрагенты" есть реквизит менеджер. который принимает значение пользователя 1С.
Необходимо сделать выборку контрагентов закрепленных за конкретным менеджером.

Я так понимаю что делать надо примерно так
   ТабКонтр = СоздатьОбъект("Справочник.Контрагенты");
   ТабКонтр.ВыбратьЭлементы();
   Пока ТабКонтр.ПолучитьЭлемент() > 0 Цикл
      Если Табконтр.НайтиПоРеквизиту("Менеджер", Менеджер) = 1 тогда
                 .....
      КонецЕсли;
   КонецЦикла;

Подскажите более подробно ибо в таком изложении мне выдает ошибку
Если Табконтр.НайтиПоРеквизиту("Менеджер", Менеджер) = 1 тогда
Недостаточное число параметров передано при вызове функции/процедуры объекта

Значение Менеджер ывбирается из диалогового окна.
Если есть сссылка на более конкретный разбор подобной информации буду благодарен


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
В данном случае можно написать так:
 ТабКонтр = СоздатьОбъект("Справочник.Контрагенты");
   ТабКонтр.ВыбратьЭлементы();
   Пока ТабКонтр.ПолучитьЭлемент() > 0 Цикл
      Если Табконтр.Менеджер = Менеджер тогда
                 .....
      КонецЕсли;
   КонецЦикла;


Оффлайн mult_ru

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-20
  • Сайт: 
У меня данной реквизит имеет тип значения "Справочник.пользователи"
И в отладчике когда я проверяю выдает след информацию

ТабКонтр = Агро-Инвест
ТабКонтр.ПолнНаименование = "ООО "Агро-Инвест""
ТабКонтр.Менеджер = НеизвестныйОбъект

Подскажите как быть в таком случае?

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
для данного контрагента у вас заполнен менеджер?

Оффлайн mult_ru

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-20
  • Сайт: 
Да конечно...

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
А что отладчик говорит про такую строчку?
ТабКонтр.Менеджер.Ссылка

Оффлайн mult_ru

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-20
  • Сайт: 
ТабКонтр.Менеджер = НеизвестныйОбъект

Оффлайн mult_ru

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-20
  • Сайт: 
ТабКонтр.Менеджер.Ссылка = Ошибка в выражении!

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Вообще странно...

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
менеджер - периодический?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 301
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal