Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 05:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: добавление троки  (Прочитано 1686 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AxOn

  • **
  • Сообщений: 82
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-04
  • Сайт: 
Есть цикл, добавление номера строки в макет. Немогли бы вы мне помочь, как сделать чтобы номера каждой строки выводились в соответствующей - следующей строке. Ну как обычная таблица в общем) Заранее спасибо
 :btbzdb:
 Данные = Макет.ПолучитьОбласть("Таблица");
      
       ТекТаб = ЭлементыФормы.ТабНоменклатура.ТекущаяСтрока;
      
       Для Каждого ТекТаб Из ТабНоменклатура Цикл

       Номер = ТекТаб.НомерСтроки;
      
      
             Сообщить(Номер);
            Данные.Параметры.Номер = Номер;

                     КонецЦикла;
ТабДок.Вывести(Данные);

   ТабДок.Показать();





Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
Re: добавление троки
« Ответ #1: 20 Окт 2010, 00:20 »

Данные = Макет.ПолучитьОбласть("Таблица"); //Строка, куда выводится номенклатура
Ном = 0;     //обнуляем номер
      // ТекТаб = ЭлементыФормы.ТабНоменклатура.ТекущаяСтрока; //ненужная
      
Для Каждого ТекТаб Из ТабНоменклатура Цикл   //перебираем строки таблицы ТабНоменклатура
      Ном = Ном +1;                                 //увеличиваем текущий номер на единицу
                    // Номер = ТекТаб.НомерСтроки; 
              //Сообщить(Номер);
      Данные.Параметры.Номер = Ном;      // присваиваем следующий по порядку номер
      ТабДок.Вывести(Данные);  ///выводим текущую строку
 КонецЦикла;

ТабДок.Показать();  // показываем табличный документ


Вот примерно так

Оффлайн AxOn

  • **
  • Сообщений: 82
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-04
  • Сайт: 
Re: добавление троки
« Ответ #2: 20 Окт 2010, 00:38 »
наверное вы непоняли. у меня в документе в таблице допустим добавленно 5 товаров и при нажатии на печать в макете формируется таблица из этих товаров. На примере вывожу один номер, только он выводится всё время в одной и тойже ячеке т.е последние номер остаётся

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
Re: добавление троки
« Ответ #3: 20 Окт 2010, 00:56 »
да, не поняла немножко. В Вашем примере вы перебираете цикл, в котором сообщаете по порядку номера, а выводите вы только строку с последним номером, потому что  ТабДок.Вывести(Данные) находится  после цикла. Быть может стоит  внести её  в цикл?

Оффлайн Slin

  • Глобальный модератор
  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
Re: добавление троки
« Ответ #4: 20 Окт 2010, 06:21 »
наверное вы непоняли. у меня в документе в таблице допустим добавленно 5 товаров и при нажатии на печать в макете формируется таблица из этих товаров. На примере вывожу один номер, только он выводится всё время в одной и тойже ячеке т.е последние номер остаётся
Все правильно. Что написали, то и выводится

Объясните подробнее что необходимо
если можно, то с примером
skype: slin-dev

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
Re: добавление троки
« Ответ #5: 20 Окт 2010, 08:23 »
Данные = Макет.ПолучитьОбласть("Таблица");
     
       ТекТаб = ЭлементыФормы.ТабНоменклатура.ТекущаяСтрока;
     
       Для Каждого ТекТаб Из ТабНоменклатура Цикл

       Номер = ТекТаб.НомерСтроки;
     
     
             Сообщить(Номер);
            Данные.Параметры.Номер = Номер;
ТабДок.Вывести(Данные);  // поле вывода строки перенесено в цикл
                     КонецЦикла;


   ТабДок.Показать();


попробуйте так


Теги:
 

Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7734
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Добавление столбца "РРЦ" в отчёт "Валовая прибыли по поставщикам"

Автор kuzmich110Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1776
Последний ответ 17 Мар 2016, 15:23
от kuzmich110
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 286
Последний ответ 25 Сен 2017, 09:00
от Св Ч
Добавление пункта в меню "печать"

Автор FlamencoРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 953
Последний ответ 30 Авг 2016, 07:46
от alex0402
Добавление выбора аналитики в отчет "Закупки"

Автор ValentusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6009
Последний ответ 31 Май 2010, 15:55
от Valentus

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 222
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal