Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 18:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выпадающий список в ячейке строки таблицы. Управляемы формы  (Прочитано 2820 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Артур С

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-06
  • Сайт: 
  • Профессия: Ученик 1С
Формирую список значений для выпадающего списка. В таблице на форме, в определенном поле (по столбцу) сделал выпадающий список из сформированного заранее списка. При заходе в нужное поле - всё хорошо. Список видно, но при уходе с этого поля, последнее остается пустым. По событию "Начало выбора" сделал следующую процедуру:

&НаКлиенте
Процедура НаименованиеКлассификатораНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
СтандартнаяОбработка=Ложь;
ЗагрузитьКлассификаторы();
Выбор = ВыбратьИзСписка(СписокКлассификаторов, ЭтаФорма.Элементы.НаименованиеКлассификатора);
Если Выбор <> Неопределено Тогда
    НаименованиеКлассификатора = Выбор.Значение;
КонецЕсли;
КонецПроцедуры

Как решить проблему с занесением данных в нужное поле из выпадающего списка?


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Вообще непонятно зачем какой-то код выбора. Устанавливаете пометку разрешения выбора из списка и пишите в обработке начала выбора из списка (в качестве примера):
Процедура ТоварыНоменклатураНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)  	
Элемент.СписокВыбора.Добавить(Справочники.Номенклатура.НайтиПоКоду("00000107"));
КонецПроцедуры
Дальше платформа сама отработает.
Упс. Не заметил, что управляемое приложение. Щас гляну как в управляемом
Добавлено: 06 Авг 2015, 16:43

Н-да, задачка. А интерфейс какой? такси или просто управляемое?

Последний раз редактировалось: vitasw; 06 Авг 2015, 16:43. Причина: Объединение сообщений

Оффлайн Артур С

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-06
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Вообще конечно в управляемых формах так не принято извращаться, но попробуйте:
....
Если Выбор <> Неопределено Тогда
    ТекСтрока=Элементы.<ТаблицаФормы>.ТекущиеДанные;
    ТекСтрока.НаименованиеКлассификатора = Выбор.Значение;
КонецЕсли;

Оффлайн Артур С

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-06
  • Сайт: 
  • Профессия: Ученик 1С
Большое спасибо! Всё получилось


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 633
Последний ответ 21 Сен 2017, 10:33
от Insider
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 155
Последний ответ 10 Апр 2018, 14:00
от Св Ч
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5257
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3798
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5792
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
165 Сообщений
alex0402
78 Сообщений
oleg-x
69 Сообщений
AIFrame AIFrame
63 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
39 Сообщений
KOI8-R
36 Сообщений
Анюта17
33 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 316
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal