Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 12:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сохранять из табличной части формы добавленной программно в Регистр сведений.  (Прочитано 1200 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн art93

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-03
  • Сайт: 
  • Профессия: Программист 1С
Создал регистр сведений СопровождаемыеПродукты. Нужно чтобы оттуда подтягивалась информация в табличную часть добавленную программно на форму справочника контрагенты. В итоге табличную часть добавил но инфа не подтягивается и не записывается. Помогите пожалуйста

Модуль объекта(спр Контрагенты)

+ Code
Процедура ПриЗаписи(Отказ)
   
    ЗаписатьПереченьСопровождаемыхПрограмм(мПереченьСопровождаемыхПрограмм, Ссылка, Отказ);
   
КонецПроцедуры

Процедура  ЗаписатьПереченьСопровождаемыхПрограмм(ПереченьСопровождаемыхПрограмм, Ссылка, Отказ)
    Если НЕ Отказ Тогда
   
        // Сравним наборы записей

        ЭталонныйНабор = РегистрыСведений.СопровождаемыеПрограммыКонтрагентов.СоздатьНаборЗаписей();
        Если ТипЗнч(Ссылка) = Тип("СправочникСсылка.Контрагенты") Тогда
            ЭталонныйНабор.Отбор.Контрагент.Значение = Ссылка;
            ЭталонныйНабор.Отбор.Контрагент.Использование = Истина;
        КонецЕсли;
        ЭталонныйНабор.Прочитать();
       
        Для каждого ЗаписьНабора Из ПереченьСопровождаемыхПрограмм Цикл
            ЗаписьНабора.Контрагент = Ссылка;
        КонецЦикла;
           
        //Если НЕ КонтрагентыОбщегоНазначенияСервер.СравнитьТаблицыНаборовЗаписей(ЭталонныйНабор.Выгрузить(), ПереченьСопровождаемыхПрограмм.Выгрузить()) Тогда

       
            ПереченьСопровождаемыхПрограмм.Отбор.Контрагент.Значение = Ссылка;
                       
            //Попытка

                ПереченьСопровождаемыхПрограмм.Записать();
            //Исключение

            //    Сообщить("Элемент """ + СокрЛП(Ссылка) + """ не записан. Ошибка в списке сопровождаемых программ.");

            //    Отказ = Истина;

            //    Возврат;

            //КонецПопытки;

           
            ПрочитатьПереченьСопровождаемыхПрограмм(ПереченьСопровождаемыхПрограмм, Ссылка);

        //КонецЕсли;

   
    КонецЕсли;
КонецПроцедуры
   
Процедура ПрочитатьПереченьСопровождаемыхПрограмм(ПереченьСопровождаемыхПрограмм, Ссылка) Экспорт

    // Снимем все отборы

    Для каждого Отбор Из ПереченьСопровождаемыхПрограмм.Отбор Цикл
        Отбор.Использование = Ложь;
    КонецЦикла;
   
    Если НЕ ЗначениеЗаполнено(Ссылка) Тогда
        Возврат;
    КонецЕсли;
   
    Если ТипЗнч(Ссылка) = Тип("СправочникСсылка.Контрагенты") Тогда
        ПереченьСопровождаемыхПрограмм.Отбор.Контрагент.Значение = Ссылка;
        ПереченьСопровождаемыхПрограмм.Отбор.Контрагент.Использование = Истина;
    КонецЕсли;
    ПереченьСопровождаемыхПрограмм.Прочитать();
   
КонецПроцедуры

мПереченьСопровождаемыхПрограмм = РегистрыСведений.СопровождаемыеПрограммыКонтрагентов.СоздатьНаборЗаписей();
Если НЕ Ссылка.Пустая() Тогда
    ПрочитатьПереченьСопровождаемыхПрограмм(мПереченьСопровождаемыхПрограмм, Ссылка);
КонецЕсли;

Модуль формы

&НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)
   
    ПараметрыЗаписи.Вставить("Партнер", Объект.Партнер);
    Оповестить("Запись_Контрагенты", ПараметрыЗаписи, Объект.Ссылка);

    СопровождаемыеПрограммы.Отбор.Контрагент.Значение       = Объект.Ссылка;
    СопровождаемыеПрограммы.Отбор.Контрагент.Использование  = Истина;

   
КонецПроцедуры

Процедура СопровождаемыеПрограммыПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
   
    ОбновитьДатуИзменения = Истина;
   
КонецПроцедуры
 
//СопровождаемыеПрограммы   = мПереченьСопровождаемыхПрограмм;
(не видит почему то мПереченьСопровождаемыхПрограмм

подскажите идеи пожалуйста, очень нужно

Последний раз редактировалось: MuI_I_Ika; 06 Авг 2015, 11:15


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Откуда вызывается это
ПрочитатьПереченьСопровождаемыхПрограмм
?

Оффлайн art93

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-03
  • Сайт: 
  • Профессия: Программист 1С
Извиняюсь.Не понял вопроса.
Процедура в модуле объекта и вызывается видно где.
Уточните пожалуйста вопрос

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Процедура в модуле объекта и вызывается видно где.
Нет, не видно, поэтому и спрашиваю.


Оффлайн Sergio199

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-01
  • Сайт: 
Процедура в модуле объекта и вызывается видно где.
Нет, не видно, поэтому и спрашиваю.



Согласен. Перенёс текст в обработчик и сразу видно - у вас ошибки в написании модуля.


Теги:
 

Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4812
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3407
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4984
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 582
Последний ответ 10 Мар 2017, 21:00
от Жанна
Как записать в поле ввода "Единица Измерения", которое заполняется через выбор из формы.

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 274
Последний ответ 12 Окт 2017, 14:30
от Ivan94

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 789
  • Точка Скрытых: 0
  • Точка Пользователей: 16
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal