Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Ноя 2018, 00:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Схема компоновки данных  (Прочитано 2818 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
Как обратиться к вычисляемым полям схемы компоновки, точнее к результату вычисляемых полей?


Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
ЭлементыФормы.Результат.Очистить();
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, КомпоновщикНастроек.Настройки, ДанныеРасшифровки);
    МассивЭлементовРезультата = Новый Массив;
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, ,ДанныеРасшифровки, Истина);
    Пока Истина Цикл
        ЭлементРезультата = ПроцессорКомпоновки.Следующий();
        Если ЭлементРезультата = Неопределено Тогда
            Прервать;
        Иначе
            МассивЭлементовРезультата.Добавить(ЭлементРезультата);
        КонецЕсли;
    КонецЦикла;
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ЭлементыФормы.Результат);
    ПроцессорВывода.НачатьВывод();
    Для Каждого ЭлементРезультата Из МассивЭлементовРезультата Цикл
        ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
    КонецЦикла;
    ПроцессорВывода.ЗакончитьВывод();
   
    ЭлементыФормы.Результат.ФиксацияСверху = 6;
    ЭлементыФормы.Результат.ПоказатьУровеньГруппировокСтрок(1);

вот этот код выводит поля схемы компоновки, без вычисляемых полей, как их добавить?

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
я хочу перекинуть в Табличный документ поля из схемы компоновки, эти поля вычисляются в вычисляемых полях, как к ним обратиться?


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8447
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4325
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3036
Последний ответ 26 Апр 2018, 06:45
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 9106
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 8193
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
63 Сообщений
AIFrame AIFrame
57 Сообщений
wise wise
55 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
46 Сообщений
alexandr_ll
45 Сообщений
alex0402
44 Сообщений
BuhRust
30 Сообщений
LexaK
26 Сообщений
andron81_81
24 Сообщений
byte777
21 Сообщений

* Кто онлайн

  • Точка Гостей: 178
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal