Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Июн 2018, 10:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вопрос по разработке кофигурации  (Прочитано 3527 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nastuska_V

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-31
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте!
Я молодой специалист! Снова столкнулась с очередной задачей.
платформа 1с 8.2.

Мне нужно исправить ошибку.

Итак начну сначала, при создании документа я ввожу инфу о Клиенте. Я хотела, чтоб при вводе инфы она записывалась сразу в справочник. С этим я справилась, но при вводе телефона клиента (выбор из справочника Клиенты сделан по телефону) если его нет в базе выскакивает окно с кнопками "Выбрать из списка", "Отменить ввод", "Продолжить ввод", но сохранить при этом мне новый телефон не дает, а только в самом справочнике при кнопке создать.
Пыталась исправить и сделала событие "ОкончаниеВводаТекста", окно с кнопками пропадает, но опять же не дает сохранить телефон и просто очищает строку.

Помогите пожалуйста разобраться! :nhsrm:


Оффлайн Дмитрий@

  • *****
  • Сообщений: 759
  • РЕПУТАЦИЯ: 138
  • КПД: 18%
  • Регистрация: 2015-02-27
  • Сайт: 
  • Профессия: Программист 1С
Это надо конфигурацию смотреть, так сложно сказать что там у вас в коде.

Оффлайн dimalf

  • **
  • Сообщений: 62
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-13
  • Сайт: 
  • Профессия: Программист 1С
Добрый день!

Скорее всего Вам надо написать процедуру, которая при вводе телефона будет автоматически записывать его и в Наименование. Тогда запись будет произведена.

Оффлайн Nastuska_V

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-31
  • Сайт: 
  • Профессия: Программист 8.1
 вот код:
Процедура ОбработкаПроведения(Отказ, Режим)

 //добавление новой записи в справочник Клиенты
СпрКл = Справочники.Клиенты.СоздатьЭлемент();
СпрКл.Наименование = Телефон;
СпрКл.Карта = Карта;
СпрКл.ИмяЗаказчика = Заказчик;
СпрКл.Город = Город;
СпрКл.Улица = Улица;
СпрКл.Дом = Дом;
СпрКл.Корпус = Корпус;     
СпрКл.Квартира = Квартира;
СпрКл.Подъезд = Подъезд;
СпрКл.Этаж = Этаж;
СпрКл.Записать();

КонецПроцедуры


вот второй:

&НаКлиенте
Процедура ТелефонОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
Если Не ЗначениеЗаполнено(Объект.Телефон) Тогда
     Список = Новый СписокЗначений;
     Список.Добавить(ПредопределенноеЗначение("Справочник.Клиенты.ПустаяСсылка"));     
ДанныеВыбора = Список;
Иначе
      Список = Новый СписокЗначений;
     Список.Добавить(Объект.Телефон);
      ДанныеВыбора = Список;
КонецЕсли;
КонецПроцедуры
Добавлено: 02 Авг 2015, 22:06

вот код:
Процедура ОбработкаПроведения(Отказ, Режим)

 //добавление новой записи в справочник Клиенты
СпрКл = Справочники.Клиенты.СоздатьЭлемент();
СпрКл.Наименование = Телефон;
СпрКл.Карта = Карта;
СпрКл.ИмяЗаказчика = Заказчик;
СпрКл.Город = Город;
СпрКл.Улица = Улица;
СпрКл.Дом = Дом;
СпрКл.Корпус = Корпус;     
СпрКл.Квартира = Квартира;
СпрКл.Подъезд = Подъезд;
СпрКл.Этаж = Этаж;
СпрКл.Записать();

КонецПроцедуры


вот второй:

&НаКлиенте
Процедура ТелефонОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
Если Не ЗначениеЗаполнено(Объект.Телефон) Тогда
     Список = Новый СписокЗначений;
     Список.Добавить(ПредопределенноеЗначение("Справочник.Клиенты.ПустаяСсылка"));     
ДанныеВыбора = Список;
Иначе
      Список = Новый СписокЗначений;
     Список.Добавить(Объект.Телефон);
      ДанныеВыбора = Список;
КонецЕсли;
КонецПроцедуры



может так понятнее будет. может я не правильно излагаю суть проблемы((((

При выборе телефона у меня заполняются автоматически поля адреса, имени и номер карты. это все хорошо работает, я даже сделала, чтоб все данные из документа записывались в справочник Клиенты, но телефон не записывается, даже не дает задать новый телефон, а только лишь предлагает отменить ввод и выбрать из справочника Клиенты. Вот это я как раз и хочу решить, чтоб он просто давал сохранить телефон.

Последний раз редактировалось: Nastuska_V; 02 Авг 2015, 22:06. Причина: Объединение сообщений

Оффлайн Дмитрий@

  • *****
  • Сообщений: 759
  • РЕПУТАЦИЯ: 138
  • КПД: 18%
  • Регистрация: 2015-02-27
  • Сайт: 
  • Профессия: Программист 1С
Здесь ошибка связана скорей всего с несовместимостью типов.
Но где именно она у вас нужно смотреть конфигурацию. Потому что мне непонятно после какого события или команды она возникает.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. при N перепроведений создастся N клиентов?
2. зачем эти выкрутасы? у документа реквизит Клиент типа СправочникСсылка.Клиенты, юзверь встает в это поле и набирает номер телефона (наименование клиента = номер телефона - ваще жесть! :trhregerhg: ), если такой клиент есть он находится, если нет - юзверь проваливается в справочник и создает нового клиента со всеми его телефонами, адресами и прочее. Просто это стандартная работа с 1С, многие юзвери так привыкли...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Nastuska_V

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-31
  • Сайт: 
  • Профессия: Программист 8.1
1. при N перепроведений создастся N клиентов?
2. зачем эти выкрутасы? у документа реквизит Клиент типа СправочникСсылка.Клиенты, юзверь встает в это поле и набирает номер телефона (наименование клиента = номер телефона - ваще жесть! :trhregerhg: ), если такой клиент есть он находится, если нет - юзверь проваливается в справочник и создает нового клиента со всеми его телефонами, адресами и прочее. Просто это стандартная работа с 1С, многие юзвери так привыкли...

я понимаю. это удобно, только когда в базе нет этого телефона я хотела чтоб он сразу сохранялся из документа в справочник.....вот :dfbbdrfb:

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
я понимаю. это удобно, только когда в базе нет этого телефона я хотела чтоб он сразу сохранялся из документа в справочник

сами откроют форму списка справочника Клиенты и нажмут кнопку "Добавить" - делов то...
тем более если это на последних платформах, то если не находится подбором текста - кнопка с "+" прямо под рукой выпадает.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Nastuska_V

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-31
  • Сайт: 
  • Профессия: Программист 8.1
я понимаю. это удобно, только когда в базе нет этого телефона я хотела чтоб он сразу сохранялся из документа в справочник

сами откроют форму списка справочника Клиенты и нажмут кнопку "Добавить" - делов то...
тем более если это на последних платформах, то если не находится подбором текста - кнопка с "+" прямо под рукой выпадает.

дак сейчас так и есть, просто хотела улучшить. просто это нужно заходить и создавать, а это служба доставки, поэтому думала чтоб быстрее было создавать в самом документе и сохранять в справочник.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ладно, не суть.
опишите еще раз что делаете сейчас, что не получается и что надо добиться?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 10996
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Вопрос по РИБ "ПоОрганизации"

Автор andi_xРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6392
Последний ответ 15 Мар 2013, 21:38
от Besart
Вопрос по "Отчеты о Розничных продажах".

Автор GerCerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3569
Последний ответ 26 Июл 2010, 16:06
от crow1983
Вопрос о действии кнопки "Записать"

Автор jenya1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4087
Последний ответ 06 Окт 2014, 15:23
от jenya1111
Вопрос по отчету "Материалы в эксплуатации".

Автор mitauskasРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2779
Последний ответ 04 Мар 2015, 11:07
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
130 Сообщений
AIFrame AIFrame
118 Сообщений
alexandr_ll
57 Сообщений
alex0402
47 Сообщений
pavl_vs
47 Сообщений
buketov.av buketov.av
40 Сообщений
ilyay ilyay
36 Сообщений
trialex3
24 Сообщений
magnifico61
21 Сообщений
wise wise
15 Сообщений

* Кто онлайн

  • Точка Гостей: 766
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal