Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 16:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Какой нужен признак для отбора свойств из ПВХ?  (Прочитано 1475 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dart909

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-09
  • Сайт: 
  • Профессия: Разработчик 1С
Добрый день вопрос такой. Есть два справочника Сотрудники и Транспорт. Есть ПВХ Свойства со след. наимен: ЦветАвто, ГодВыпуска, ВозрастСотрудника, СтажСотрудника. Вопрос такой, как сделать чтобы при открытии формы элемента справочника Сотрудника вывелись только свойства касающиеся Сотрудника и аналогично при открытии Транспорт вывелись свойства для Транспорт. Какой признак должен быть?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
осталось только съясновидеть как связаны ПВХ и справочники...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн dart909

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-09
  • Сайт: 
  • Профессия: Разработчик 1С
осталось только съясновидеть как связаны ПВХ и справочники...

Вот код:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   ПолучитьСведенияПоТранспортномуСредству() ;
   МояТаблица = Таблица.Выгрузить();
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |  СвойстваТС.Ссылка КАК Ссылка,
   |  ЗначенияСвойствТранспортногоСредства.Значение КАК ТипЗ
   |ИЗ
   |  РегистрСведений.ЗначенияСвойствТранспортногоСредства КАК ЗначенияСвойствТранспортногоСредства
   |
   |ПРАВОЕ СОЕДИНЕНИЕ
   |     ПланВидовХарактеристик.СвойстваТС КАК СвойстваТС
   |ПО СвойстваТС.Ссылка = ЗначенияСвойствТранспортногоСредства.ВидСвойства И
   |  ЗначенияСвойствТранспортногоСредства.ТранспортноеСредство = &ТранспортноеСредство
   |";
   Запрос.УстановитьПараметр("ТранспортноеСредство",Объект.Ссылка);
   
   РезультатЗапроса = Запрос.Выполнить();
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выгрузить();
   Для каждого Строка из ВыборкаДетальныеЗаписи Цикл
       НоваяСтрока = Таблица.Добавить();
       НоваяСтрока.МоеЗначение =  Строка.ТипЗ;
       НоваяСтрока.Свойство = Строка.Ссылка;   
   КонецЦикла;
КонецПроцедуры

&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
   Для Каждого СтрокаТаблицы ИЗ Таблица Цикл

   Набор = РегистрыСведений.ЗначенияСвойствТранспортногоСредства.СоздатьНаборЗаписей();
   Набор.Отбор.ВидСвойства.Установить(СтрокаТаблицы.Свойство);
   Набор.Отбор.ТранспортноеСредство.Установить(Объект.Ссылка);
      НоваяЗапись = Набор.Добавить();   
      НоваяЗапись.ВидСвойства = СтрокаТаблицы.Свойство;
      НоваяЗапись.Значение = СтрокаТаблицы.МоеЗначение;
      НоваяЗапись.ТранспортноеСредство = Объект.Ссылка;
      Набор.Записать();
   КонецЦикла;
      
   Набор.Записать();

КонецПроцедуры

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
у вас есть отдельный регистр сведений ЗначенияСвойствТранспортногоСредства
и отдельный регистр ЗначенияСвойствСотрудника?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн dart909

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-09
  • Сайт: 
  • Профессия: Разработчик 1С
у вас есть отдельный регистр сведений ЗначенияСвойствТранспортногоСредства
и отдельный регистр ЗначенияСвойствСотрудника?

Нет у меня только один регистр сведений ЗначенияСвойствТранспортногоСредства с измерением Транспортноесредство у него составной тип (СправочникСсылкаюТранспортныСредства и СправочникСсылка.Сотрдуники) Просто изначально работало только для Транспортного средства, а теперь хочу сдлеать и для Сотрудника еще не успел переименовать(

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
тогда проверяете на тип значение измерения ТранспортноеСредство
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4293
Последний ответ 24 Дек 2015, 15:34
от дфтын
Нужен совет в подключении к системе спутникового мониторинга "renault-trucks(Optifleet)", через web-сервис!

Автор snoop82Раздел Беседка

Ответов: 0
Просмотров: 790
Последний ответ 11 Дек 2015, 06:56
от snoop82
В какой валюте можно оформлять документ "Заказ покупателя"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3048
Последний ответ 25 Ноя 2008, 11:10
от DDD
Какой нынче курс у валюты "Спасибо сайта forum-1c"?

Автор AntonBРаздел Беседка

Ответов: 5
Просмотров: 3097
Последний ответ 06 Дек 2011, 00:56
от AntonB
Продажа нежилого помещения, которое ранее сдавалось в аренду: какой налог должен заплатить ИП — «упрощенщик»

Автор newsРаздел Новости

Ответов: 0
Просмотров: 642
Последний ответ 19 Июл 2016, 11:58
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 715
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal