Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Май 2019, 19:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как избавиться от дублей в таблице  (Прочитано 2920 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ogo

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-30
  • Сайт: 
Подскажите,пожлуйста,что неправильно в процедуре?мне надо чтобы при вводе данных пользователем в таблицу в колонку Этап,если этот этап уже есть,выдавалось сообщение.Вот процедура:
Процедура СрокиЭтаповЭтапПриИзменении(Элемент)
ПараметрыОтбора = Новый Структура;
ПараметрыОтбора.Вставить("Этап", ТекущийЭлемент);

НайденныеСтроки= Объект.СрокиЭтапов.НайтиСтроки(ПараметрыОтбора);
Если НайденныеСтроки.Количество()>1 Тогда
Сообщить("Дубль");
КонецЕсли;

КонецПроцедуры


Оффлайн mohock

  • ***
  • Сообщений: 170
  • РЕПУТАЦИЯ: 50
  • КПД: 29%
  • Регистрация: 2010-08-12
  • Сайт: 
  • Профессия: Программист 8.1
Подскажите,пожлуйста,что неправильно в процедуре?мне надо чтобы при вводе данных пользователем в таблицу в колонку Этап,если этот этап уже есть,выдавалось сообщение.Вот процедура:
Процедура СрокиЭтаповЭтапПриИзменении(Элемент)
ПараметрыОтбора = Новый Структура;
ПараметрыОтбора.Вставить("Этап", ТекущийЭлемент);

НайденныеСтроки= Объект.СрокиЭтапов.НайтиСтроки(ПараметрыОтбора);
Если НайденныеСтроки.Количество()>1 Тогда
Сообщить("Дубль");
КонецЕсли;

КонецПроцедуры


Самое неправильное в этой процедуре это, то, что ты ошибся событием.
Эта работает:

Процедура СрокиЭтаповЭтапОкончаниеВводаТекста(Элемент, Текст, Значение, СтандартнаяОбработка)
   // Вставить содержимое обработчика.
   к=0;
   ДубльЭтап = Неопределено;
   Для Каждого Строчка Из СрокиЭтапов Цикл
      Если Строчка.Этап = Элемент.Значение Тогда
         к=к+1;
         ДубльЭтап = Элемент.Значение;
      КонецЕсли;      
   КонецЦикла;
   Если к>0 Тогда
      к=к+1;
      Сообщить("Для этапа "+ДубльЭтап+": "+к+" повторов");   
   КонецЕсли;

КонецПроцедуры


Теги:
 

Запрос к виртуальной таблице регистра накопления: что писать в "Произвольном Выражении"?

Автор Светлана РождественскаяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 549
Последний ответ 27 Окт 2017, 21:02
от MuI_I_Ika
Как правильно сделать запрос и получить количество повторяющихся элементов в таблице (временная)?

Автор Владислав КлишинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2848
Последний ответ 18 Янв 2016, 13:38
от Дмитрий@
Сохранение сгенерированных колонок и данных их ячеек в таблице значений документа

Автор LonerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2548
Последний ответ 06 Мар 2014, 07:48
от sdilshod
Нельзя обращаться к вложенной таблице через поле составного типа

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2379
Последний ответ 04 Авг 2015, 15:20
от ferrari314
Как Табличный документ (полученный Exсel) отобразить в Таблице УпрФормы

Автор leotomРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 6726
Последний ответ 02 Фев 2014, 23:27
от LordWizard

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
36 Сообщений
wise wise
31 Сообщений
AIFrame AIFrame
31 Сообщений
alexandr_ll
29 Сообщений
DmitriyF DmitriyF
13 Сообщений
vova-1c@xaker.ru
11 Сообщений
Eugeneer Eugeneer
9 Сообщений
Мария112689
9 Сообщений
Yamuna
8 Сообщений
kiksi
8 Сообщений

* Кто онлайн

  • Точка Гостей: 227
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal