Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2018, 23:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как избавиться от дублей в таблице  (Прочитано 2768 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ogo

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-30
  • Сайт: 
Подскажите,пожлуйста,что неправильно в процедуре?мне надо чтобы при вводе данных пользователем в таблицу в колонку Этап,если этот этап уже есть,выдавалось сообщение.Вот процедура:
Процедура СрокиЭтаповЭтапПриИзменении(Элемент)
ПараметрыОтбора = Новый Структура;
ПараметрыОтбора.Вставить("Этап", ТекущийЭлемент);

НайденныеСтроки= Объект.СрокиЭтапов.НайтиСтроки(ПараметрыОтбора);
Если НайденныеСтроки.Количество()>1 Тогда
Сообщить("Дубль");
КонецЕсли;

КонецПроцедуры


Оффлайн mohock

  • ***
  • Сообщений: 170
  • РЕПУТАЦИЯ: 50
  • КПД: 29%
  • Регистрация: 2010-08-12
  • Сайт: 
  • Профессия: Программист 8.1
Подскажите,пожлуйста,что неправильно в процедуре?мне надо чтобы при вводе данных пользователем в таблицу в колонку Этап,если этот этап уже есть,выдавалось сообщение.Вот процедура:
Процедура СрокиЭтаповЭтапПриИзменении(Элемент)
ПараметрыОтбора = Новый Структура;
ПараметрыОтбора.Вставить("Этап", ТекущийЭлемент);

НайденныеСтроки= Объект.СрокиЭтапов.НайтиСтроки(ПараметрыОтбора);
Если НайденныеСтроки.Количество()>1 Тогда
Сообщить("Дубль");
КонецЕсли;

КонецПроцедуры


Самое неправильное в этой процедуре это, то, что ты ошибся событием.
Эта работает:

Процедура СрокиЭтаповЭтапОкончаниеВводаТекста(Элемент, Текст, Значение, СтандартнаяОбработка)
   // Вставить содержимое обработчика.
   к=0;
   ДубльЭтап = Неопределено;
   Для Каждого Строчка Из СрокиЭтапов Цикл
      Если Строчка.Этап = Элемент.Значение Тогда
         к=к+1;
         ДубльЭтап = Элемент.Значение;
      КонецЕсли;      
   КонецЦикла;
   Если к>0 Тогда
      к=к+1;
      Сообщить("Для этапа "+ДубльЭтап+": "+к+" повторов");   
   КонецЕсли;

КонецПроцедуры


Теги:
 

Запрос к виртуальной таблице регистра накопления: что писать в "Произвольном Выражении"?

Автор Светлана РождественскаяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 452
Последний ответ 27 Окт 2017, 21:02
от MuI_I_Ika
Как правильно сделать запрос и получить количество повторяющихся элементов в таблице (временная)?

Автор Владислав КлишинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2568
Последний ответ 18 Янв 2016, 13:38
от Дмитрий@
Сохранение сгенерированных колонок и данных их ячеек в таблице значений документа

Автор LonerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2334
Последний ответ 06 Мар 2014, 07:48
от sdilshod
Нельзя обращаться к вложенной таблице через поле составного типа

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2174
Последний ответ 04 Авг 2015, 15:20
от ferrari314
Как Табличный документ (полученный Exсel) отобразить в Таблице УпрФормы

Автор leotomРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 6450
Последний ответ 02 Фев 2014, 23:27
от LordWizard

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
78 Сообщений
byte777
41 Сообщений
AIFrame AIFrame
40 Сообщений
wise wise
36 Сообщений
alex0402
36 Сообщений
alexandr_ll
30 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
26 Сообщений
LexaK
23 Сообщений
happynattion
22 Сообщений
antoneus
20 Сообщений

* Кто онлайн

  • Точка Гостей: 231
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal